debconf: setting console triggers update-initramfs

Bug #1018884 reported by Scott Moser on 2012-06-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
debconf (Ubuntu)
Medium
Colin Watson

Bug Description

after launching a fresh quantal instance of the cloud images in EC2, I then ran:
  apt-get install pastebinit
and saw:

$ sudo apt-get install pastebinit
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  pastebinit
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 16.0 kB of archives.
After this operation, 176 kB of additional disk space will be used.
Get:1 http://us-east-1.ec2.archive.ubuntu.com/ubuntu/ quantal/universe pastebinit all 1.3-2ubuntu3 [16.0 kB]
Fetched 16.0 kB in 0s (263 kB/s)
Selecting previously unselected package pastebinit.
(Reading database ... 46708 files and directories currently installed.)
Unpacking pastebinit (from .../pastebinit_1.3-2ubuntu3_all.deb) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.5.0-2-generic
Processing triggers for man-db ...
Setting up pastebinit (1.3-2ubuntu3) ...

Clearly, pastebinit should not have caused an update of the initramfs.

I asked in #ubuntu-devel and cjwatson made some suggestions on debugging what is causing this. See
http://irclogs.ubuntu.com/2012/06/28/%23ubuntu-devel.html#t15:04

Related branches

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1018884/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

It looks like the problem is with the code that sets the console font selection. In /live-config/common/020-pkg-configure.chroot:
  27 # Configure the console-setup
  28 dpkg-reconfigure --frontend=noninteractive console-setup ||
  29 { echo "FAILED to recofigure console-setup"; exit 1; }

Which triggers an initramfs update. The trigger remains unacted on till the next package installation. By simply putting in a "dpkg --configure -a" after, this problem is fixed.

Found linux image: /boot/vmlinuz-3.5.0-2-generic
Found initrd image: /boot/initrd.img-3.5.0-2-generic
Found memtest86+ image: /boot/memtest86+.bin
done
grub-probe: invalid option -- 't'
Usage: euca-psuedo-grub-probe
   this is a wrapper around grub-probe to provide the answers for an ec2 guest
/usr/sbin/grub-probe: 8: /usr/sbin/grub-probe: fail: not found
grub-probe: invalid option -- 't'
Usage: euca-psuedo-grub-probe
   this is a wrapper around grub-probe to provide the answers for an ec2 guest
/usr/sbin/grub-probe: 8: /usr/sbin/grub-probe: fail: not found
grub-probe: invalid option -- 't'
Usage: euca-psuedo-grub-probe
   this is a wrapper around grub-probe to provide the answers for an ec2 guest
/usr/sbin/grub-probe: 8: /usr/sbin/grub-probe: fail: not found
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.5.0-2-generic
Found initrd image: /boot/initrd.img-3.5.0-2-generic
Found memtest86+ image: /boot/memtest86+.bin
done
console-setup console-setup/console-setup/fontface47 string Fixed
debconf-set-selections
update-initramfs: deferring update (trigger activated)
Adding admin group...
Adding netdev group...
Adding ubuntu user...
Adding user ubuntu to group netdev
Locking ubuntu user...
Disabling root user...

Marking as fix committed pending verification.

Changed in ubuntu:
status: Confirmed → Fix Committed

On Fri, 29 Jun 2012, Ben Howard wrote:

> It looks like the problem is with the code that sets the console font selection. In /live-config/common/020-pkg-configure.chroot:
> 27 # Configure the console-setup
> 28 dpkg-reconfigure --frontend=noninteractive console-setup ||
> 29 { echo "FAILED to recofigure console-setup"; exit 1; }
>
> Which triggers an initramfs update. The trigger remains unacted on till
> the next package installation. By simply putting in a "dpkg --configure
> -a" after, this problem is fixed.

Ben,
   Could you please check with someone from foundations (cjwatson or
slangasek would likely know) if this is expected behavior. It doesn't
seem to me that it is. If it is not, we should fix the real problem, not
patch on top.

After talking to to cjwatson, this is a bug in debconf. I'm backing out the workaround. Reflagging this a debconf bug.

Changed in ubuntu:
status: Fix Committed → Confirmed
assignee: Ben Howard (utlemming) → nobody
summary: - cloud-images run update-initramfs on first package install
+ debconf: setting console triggers update-initramfs
Colin Watson (cjwatson) on 2012-07-02
affects: ubuntu → debconf (Ubuntu)
Colin Watson (cjwatson) on 2012-07-02
Changed in debconf (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debconf - 1.5.45ubuntu1

---------------
debconf (1.5.45ubuntu1) quantal; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Gnome.pm: Do not show "Cancel" or "Close" buttons, to avoid breaking
      maintainer scripts.
  * dpkg-reconfigure: Drop support for old dpkg-query ${PackageSpec}, since
    Ubuntu has a newer dpkg now.

debconf (1.5.45) unstable; urgency=low

  [ Programs translations ]
  * German updated.

  [ Colin Watson ]
  * dpkg-reconfigure: Fix dpkg-query parsing when detecting which triggers
    are pending (LP: #1018884).
 -- Colin Watson <email address hidden> Tue, 03 Jul 2012 09:23:41 +0100

Changed in debconf (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers