Invalid end-of-line backslash in Build-Depends

Bug #393099 reported by Andrew Sayers
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
deal.ii (Ubuntu)
Undecided
Andrew Starr-Bochicchio
Karmic
Undecided
Andrew Starr-Bochicchio

Bug Description

This bug was sent manually, but the text was written to a template, as I have several similar bugs to report today. Please see my recent bug reports for a list, or bug #391165 for the root cause.

Version 6.2.0-3 of deal.ii has a backslash at the end of the line(s) in the "Build-Dependencies" section of debian/control. There shouldn't be a backslash in the area(s) marked by ***asterisks***:

Build-Depends: debhelper (>= 4.1.67), quilt, autoconf, gfortran, zlib1g-dev, ***\***
  libblas-dev, liblapack-dev, libpetsc3.0.0-dev, libslepc3.0.0-dev, ***\***
  libtrilinos-dev (>=9.0.2.dfsg-4), libscotchmetis-dev (>= 5.1.4.dfsg-2), ***\***
  libsuitesparse-dev, libnetcdf-dev, libboost-dev

This is currently allowed because of bug #391165. However, deal.ii will fail to build once that bug has been fixed. This bug can be fixed by removing all end-of-line backslashes.

Changed in deal.ii (Ubuntu Karmic):
assignee: nobody → David Stansby (dstansby)
status: New → In Progress
assignee: David Stansby (dstansby) → nobody
status: In Progress → Confirmed
Changed in deal.ii (Ubuntu Karmic):
assignee: nobody → fabrice_sp (fabricesp)
status: Confirmed → In Progress
Revision history for this message
Fabrice Coutadeur (fabricesp) wrote :

Debdiff that fixes this bug and also a FTBFS because of a missing build dependency (#395431)

Changed in deal.ii (Ubuntu Karmic):
assignee: fabrice_sp (fabricesp) → nobody
status: In Progress → Confirmed
Changed in deal.ii (Ubuntu Karmic):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
status: Confirmed → In Progress
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Uploaded. Thanks for your work!

Boy, that was a long test build for such a small change. ;-)

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package deal.ii - 6.2.0-3ubuntu1

---------------
deal.ii (6.2.0-3ubuntu1) karmic; urgency=low

  * debian/control:
    - Added build dependency on libboost-graph-dev to fix a FTBFS (LP: 395431),
      as stated in Debian bug 533629
    - Deleted backslashs in the build-depend list to fix another FTBFS
      (LP: #393099)

 -- Fabrice Coutadeur <email address hidden> Fri, 10 Jul 2009 17:34:59 +0200

Changed in deal.ii (Ubuntu Karmic):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers