Ubuntu

Right click on graph'ed obj locks ddd/Ubuntu

Reported by mmlb on 2010-05-03
This bug report is a duplicate of:  Bug #553415: mouse trapped in box for Open Motif. Edit Remove
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
X.Org X server
Unknown
Unknown
ddd (Ubuntu)
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ddd

I expect to be able to right click a graphed object in and get a menu.

Instead when I right click a graph'ed var in a gdb C++ session, the mouse gets locked into the graph area. The mouse can be moved but it is bound by the edges of the graph. Key combinations such as Alt+F4 or Alt+F2 don't work. I have to kill the X Server with Ctrl+Alt+Backspace to continue.

lsb_release -rd:
Description: Ubuntu 10.04 LTS
Release: 10.04

apt-cache policy ddd
ddd:
  Installed: 1:3.3.11-1ubuntu2
  Candidate: 1:3.3.11-1ubuntu2
  Version table:
 *** 1:3.3.11-1ubuntu2 0
        500 http://www.gtlib.gatech.edu/pub/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status

Stephen Warren (srwarren) wrote :

I'm affected by this too. Just to be explicit, here are repro steps:

g++ -ggdb -Wall -Werror -o bug1 bug1.cpp # I'll attach that in a second
ddd ./bug1
View Menu -> ensure" Data Window" is checked
b alter_list
r
# wait for breakpoint to be hit
In ddd source window, right-click on the "list" parameter to function alter_list(), and select "Display list"
Now, go to the data window, right-click on the graphic view of "list". ddd will hang, and mouse will be grabbed into the data window.

Note: You can recover from this without killing X by:
CTRL-ALT-F2 to switch to a text console
Log in
kill `pidof ddd`
CTRL-ALT-F<<n>> to switch back to X

Stephen Warren (srwarren) wrote :
tags: added: lucid
Stephen Warren (srwarren) wrote :

FYI, I think this is upstream bug http://savannah.gnu.org/bugs/?28247 However, I can't add that as a bug watch to Launchpad, since Launchpad doesn't know about the ddd upstream project.

FYI, a partial workaround is to left double-click on items you want to expand. This appears to do what right-click "Display" would do. However, that doesn't allow access to all the other actions that are on the right-click menu.

Rajeev (rajeeja) wrote :

+1, I'm affected by this too. Thanks Stephan for workarounds.

The bug in ddd points to LessTif (a clone OSF/Motif) http://sourceforge.net/tracker/index.php?func=detail&aid=1578451&group_id=8596&atid=108596 This bug however seems to be closed.

Stephen Warren (srwarren) wrote :

I looked ath that lesstif bug, and I'm not sure why you think it's related to this bug, nor do I see where the upstream ddd bug links to the lesstif bug. Can you explain further, thanks.

Stephen Warren (srwarren) wrote :

The following lesstif bug sounds somewhat similar to this bug: https://sourceforge.net/tracker/?func=detail&aid=2912821&group_id=8596&atid=108596, although unfortunately, there's no traction or useful information there w.r.t. what the root-cause is.

The lesstif bug points at Red Hat bug https://bugzilla.redhat.com/show_bug.cgi?id=543647. That bug was apparently solved by a new X server RPM. I *think* the patch is attached to bug http://bugs.freedesktop.org/show_bug.cgi?id=25400 as 0001-dix-if-owner-events-is-true-for-passive-grabs-add-th.patch (that fd.o bug does mention an unspecific ddd issue).

Stephen Warren (srwarren) wrote :

Gentoo bug https://bugs.gentoo.org/296514 explicitly details this ddd problem, and provides further evidence that the X server is to blame, and that the patch included in the fd.o bug solves this.

Note: There may be some issues with the way X.org was patched to solve this. Apparently the patch in the fd.o bug works, but the actual checkin to X.org sources was different and broke other things; see the comments in the Gentoo bug.

Rajeev (rajeeja) wrote :

@Stephen I just picked up LessTif thingy from the forum. It's the X that seems to be the root of the problem as you rightly point out.

A bigger bug surrounds me now....https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/571258 unable to get networking to work and boot properly.

Yanti (timo-t-karki) wrote :

Hi. I can see this also. Ubuntu 10.04 LTS and DDD 3.3.11.

Steps to reproduce:

1) start DDD

2) open some executive in DDD for tracing

3) select view -> data window

4) right click inside the data window area.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Changed in ddd (Ubuntu):
status: New → Fix Committed
status: Fix Committed → Confirmed
status: Confirmed → New
Changed in xorg-server (Ubuntu):
status: Confirmed → New
Changed in ddd (Ubuntu):
status: New → Confirmed
Stephen Warren (srwarren) wrote :

In my PPA, I rebuilt Lucid's xorg-server package with patch " 0001-dix-if-owner-events-is-true-for-passive-grabs-add-th.patch" (http://bugs.freedesktop.org/attachment.cgi?id=32100) applied (from http://bugs.freedesktop.org/show_bug.cgi?id=25400). This solved the problem.

Hence, I will mark this bug "invalid" in ddd, since it's an X server bug.

I will mark this bug "confirmed' in X server (Ubuntu) since at least 3 people are seeing it.

Hopefully, this patch or similar can be applied to the official Ubuntu package.

Changed in ddd (Ubuntu):
status: Confirmed → Invalid
Changed in xorg-server (Ubuntu):
status: New → Confirmed
tags: added: patch

The bug also affects my system.
Running Ubuntu 10.04 w/ DDD 3.3.11. The behaviour is identical to the one described by Yanti.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.