Ubuntu

All-registers view broken

Reported by Elie De Brauwer on 2007-05-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ddd (Ubuntu)
Undecided
Unassigned

Bug Description

When launching ddd, I tested this with a hello world C++ application. Select view -> Data window and Go to Date -> Status-display -> And check "List of all registers and their contents"

Now this window is broken. The borders are wrongly aligned and no newlines are printed in the contents. I will attach a screenshot hereafter.

I've tested some other windows Locals, Proc and Arguments and they work fine ...

I'll try to attach a screenshot.

Tested on feisty:
e@lape:~$ dpkg -l ddd
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii ddd 3.3.11-1 The Data Display Debugger, a graphical debug

Elie De Brauwer (elie) wrote :

Attached screenshot to illustrate the issue.

Elie De Brauwer (elie) wrote :
Download full text (4.5 KiB)

Displaying the registers like this works:

(gdb) graph display `info registers`

But this fails to work:

(gdb) graph display `info all-registers`

It could perhaps be due the amount of data that all-registers returns, which is rather large:

(gdb) info all-registers
eax 0xbf9c8a74 -1080259980
ecx 0xbf9c89f0 -1080260112
edx 0x1 1
ebx 0xb7db2ff4 -1210372108
esp 0xbf9c89c0 0xbf9c89c0
ebp 0xbf9c89d8 0xbf9c89d8
esi 0xb7f06ce0 -1208980256
edi 0x0 0
eip 0x80486e7 0x80486e7 <main+17>
eflags 0x286 [ PF SF IF ]
cs 0x73 115
ss 0x7b 123
ds 0x7b 123
es 0x7b 123
fs 0x0 0
gs 0x33 51
st0 0 (raw 0x00000000000000000000)
st1 0 (raw 0x00000000000000000000)
st2 0 (raw 0x00000000000000000000)
st3 0 (raw 0x00000000000000000000)
st4 0 (raw 0x00000000000000000000)
st5 0 (raw 0x00000000000000000000)
st6 0 (raw 0x00000000000000000000)
st7 0 (raw 0x00000000000000000000)
fctrl 0x37f 895
fstat 0x0 0
ftag 0xffff 65535
fiseg 0x0 0
fioff 0x0 0
foseg 0x0 0
fooff 0x0 0
fop 0x0 0
xmm0 {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm1 {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm2 {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm3 {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm4 {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm5 {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm6 {v4_float = {0x0, 0x0, 0x0, 0x0}, v2_double = {0x0, 0x0}, v16_int8 = {0x0 <repeats 16 times>}, v8_int16 = {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, v4_int32 = {0x0, 0x0, 0x0, 0x0}, v2_int64 = {0x0, 0x0}, uint128 = 0x00000000000000000000000000000000}
xmm7 {v4_float = {0x0, 0x0, ...

Read more...

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 beta?

Changed in ddd:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in ddd:
status: Incomplete → Invalid
Elie De Brauwer (elie) wrote :

Well that's what I call the easy way out, the simplest check possible is to verify if the version of the package changed ever since.

edb@lapedb:~$ dpkg -l ddd
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii ddd 1:3.3.11-1 The Data Display Debugger, a graphical debug

And me-o-my it hasn't, so this puts the likelihood of the existence of the bug to 95%. And yes, even after verifying the couple of steps I wrote a year and a half ago verifies that the issue is still there.

Changed in ddd:
status: Invalid → Incomplete
themusicgod1 (themusicgod1) wrote :

According to http://blog.launchpad.net/general/of-bugs-and-statuses , this really should be 'confirmed'. It is trivial to reproduce, obvious compared to other results given in the very clear bug existing report, and has spanned at least two Ubuntu versions. I've started looking through the code itself but the code seems to be very orthogonal to what seems to be happening.

Changed in ddd:
status: Incomplete → Confirmed
Peter Wainwright (prw) wrote :

I can confirm this too. I've copied the original report into the upstream bug tracker (https://savannah.gnu.org/bugs/?25566).

Elie De Brauwer (elie) wrote :

After the disappointing comment on 20081217 i already created an upstream bug for this: http://savannah.gnu.org/bugs/?25109

themusicgod1 (themusicgod1) wrote :

still a live bug in 2013

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.