ddclient start too early

Bug #998700 reported by asasoft
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ddclient (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 12.04 LTS
ddclient 3.8.0-11.4ubuntu1
Linux station6 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

On my system ddclient start too early on boot without a valid active network (Im using a wired connection) , then fail to update because cannot connect to check the ip :

ddclient[1289]: WARNING: cannot connect to checkip.dyndns.com:80 socket: IO::Socket::INET: Bad hostname 'checkip.dyndns.com'

after that, the daemon still runing and try to update the dns without check for network first.
As the result we need to wait that the ddclient daemon re-check the ip ( 5 minutes with stock config ) for a successful update.
In other systems, this can be solved adding a "if up/down then start/stop" script at /etc/NetworkManager/dispatcher.d/50-ddclient

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ddclient (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ddclient - 3.8.1-1ubuntu2

---------------
ddclient (3.8.1-1ubuntu2) saucy; urgency=low

  * debian/ddclient.NetworkManager
    - Use NetworkManager dispatcher to stop/start ddclient, fixes DNS lookup
      errors that caused checkins to fail (LP: #998700)
  * debian/ddclient.init
    - lintian reports missing runlevels for stop, adjusted to 0 1 6
  [ Tristan Schmelcher ]
  * debian/ddclient.init
    - ddclient init script fails to stop process (LP: #980409)
 -- Ken VanDine <email address hidden> Mon, 29 Jul 2013 09:41:53 -0400

Changed in ddclient (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers