ddclient unusable with FreeDNS due to missing libdigest-sha1-perl

Bug #1068884 reported by Reuben Thomas on 2012-10-19
80
This bug affects 17 people
Affects Status Importance Assigned to Milestone
ddclient (Ubuntu)
High
Scott Talbert
Trusty
High
Brian Murray
Utopic
High
Brian Murray

Bug Description

[Impact]
The current ddclient package found in Trusty and Utopic is unusable with FreeDNS (one of the popular free dynamic DNS sites) due to a missing dependency (libdigest-sha1-perl). The patch (cherry-picked from upstream) enables ddclient to correctly locate this dependency.

[Test Case]
- Install the ddclient package on Trusty or Utopic
- Use a ddclient.conf with content similar to the following:
daemon=1h
ssl=yes
protocol=freedns
use=web
server=freedns.afraid.org
login=<username>
password='<password>'
<hostname>
- Observe that ddclient successfully connects up to FreeDNS and updates the IP address.

[Regression Potential]
Generally limited as the patch only touches code that is used for FreeDNS.

[Original description]
When I tried to set up ddclient to access an afraid.org host in quantal, I got an error: it says it needs libdigest-sha1-perl; this package has not been shipped since oneiric.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ddclient (not installed)
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Fri Oct 19 23:28:37 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
SourcePackage: ddclient
UpgradeStatus: Upgraded to quantal on 2012-10-19 (0 days ago)

Reuben Thomas (rrt) wrote :
Reuben Thomas (rrt) wrote :

The solution to this bug is simple (use Digest::SHA instead of Digest::SHA1) and outlined in Debian bug #690568.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ddclient (Ubuntu):
status: New → Confirmed
wimpunk (wimpunk) wrote :

This issue has been fixed upstream in revision 152. See https://sourceforge.net/p/ddclient/code/152/
This revision isn't part of a release yet.

Murz (murznn) wrote :

How to fix this on older versions:
Become root and edit /usr/sbin/ddclient. Look for require Digest::SHA1 and replace it with require Digest::SHA. Then look for import Digest::SHA1 a few lines later and replace it with import Digest::SHA.

Andrew (andrewkk) wrote :

A cleaner workaround would be to simply install the missing dependency:

    sudo apt-get install cpanminus
    cpanm --sudo Digest::SHA1

Tong Sun (suntong001) wrote :

As wimpunk has fixed the problem long time ago,
https://bugs.launchpad.net/ubuntu/+source/ddclient/+bug/1068884/comments/4
can we have the new release please?

@wimpunk, is your revision 152 change now in the official release? Please do if not, because it works.

Thanks

Nick Maynard (nick-maynard) wrote :

@suntong001 mentioned this has been fixed. This patch has now been included in ddclient 3.8.2 - I guess upgrading to this version would be the most expedient method to fix the issue.

Reuben Thomas (rrt) wrote :

The Debian package has already been updated to 3.8.2; I'm guessing the Ubuntu package hasn't been because it has Ubuntu-specific patches, so it didn't update automatically.

Changed in ddclient (Ubuntu):
assignee: nobody → Scott Talbert (swt-techie)
status: Confirmed → In Progress
Daniel Holbach (dholbach) wrote :

It'd be great if somebody could look into merging 3.8.2 from Debian. In the meantime, I'm happy to upload this fix.

Scott Talbert (swt-techie) wrote :

Yes, I was going to take a stab at that next.

I was hoping to try to get this particular fix SRU'd to Trusty and Utopic.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ddclient - 3.8.1-1ubuntu3

---------------
ddclient (3.8.1-1ubuntu3) vivid; urgency=low

  * Add patch from upstream which enables ddclient to find Digest::SHA to
    fix FreeDNS support (LP: #1068884)
 -- Scott Talbert <email address hidden> Sat, 06 Dec 2014 22:49:13 -0500

Changed in ddclient (Ubuntu):
status: In Progress → Fix Released
summary: - ddclient can't be used in quantal: needs missing libdigest-sha1-perl
+ ddclient unusable with FreeDNS due to missing libdigest-sha1-perl
description: updated
Changed in ddclient (Ubuntu):
importance: Undecided → High
Changed in ddclient (Ubuntu Trusty):
importance: Undecided → High
Changed in ddclient (Ubuntu Utopic):
importance: Undecided → High
Changed in ddclient (Ubuntu Trusty):
status: New → Triaged
Changed in ddclient (Ubuntu Utopic):
status: New → Triaged
Sebastien Bacher (seb128) wrote :

unsubscribing sponsors, there is nothing ready for review/sponsoring here

tags: added: trusty utopic
Changed in ddclient (Ubuntu Trusty):
assignee: nobody → Brian Murray (brian-murray)
Changed in ddclient (Ubuntu Utopic):
assignee: nobody → Brian Murray (brian-murray)
Changed in ddclient (Ubuntu Trusty):
status: Triaged → In Progress
Changed in ddclient (Ubuntu Utopic):
status: Triaged → In Progress

Hello Reuben, or anyone else affected,

Accepted ddclient into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ddclient/3.8.1-1ubuntu2.14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ddclient (Ubuntu Utopic):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in ddclient (Ubuntu Trusty):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Reuben, or anyone else affected,

Accepted ddclient into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ddclient/3.8.1-1ubuntu2.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Reuben Thomas (rrt) wrote :

After installing the proposed update, and restarting ddclient (it wasn't clear to me whether it had been restarted by the upgrade), it started up fine, so given that I still use afraid.org, it seems to be working. Thanks very much.

On Wed, Feb 11, 2015 at 11:47:06PM -0000, Reuben Thomas wrote:
> After installing the proposed update, and restarting ddclient (it wasn't
> clear to me whether it had been restarted by the upgrade), it started up
> fine, so given that I still use afraid.org, it seems to be working.

On which release of Ubuntu were you testing? The package is available in
-proposed for two releases.

--
Brian Murray

Scott Talbert (swt-techie) wrote :

Verified on trusty.

@Brian: thanks for fixing up my patches. :-)

tags: added: verification-done-trusty
tags: added: verification-needed-utopic
removed: verification-needed
Reuben Thomas (rrt) wrote :

I am using Trusty, sorry for not mentioning that earlier.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ddclient - 3.8.1-1ubuntu2.14.04.1

---------------
ddclient (3.8.1-1ubuntu2.14.04.1) trusty-proposed; urgency=low

  * Add patch from upstream which enables ddclient to find Digest::SHA to
    fix FreeDNS support (LP: #1068884)
 -- Scott Talbert <email address hidden> Sat, 06 Dec 2014 22:49:13 -0500

Changed in ddclient (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ddclient has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

The fix for this bug has been awaiting testing feedback in the -proposed repository for utopic for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Reuben Thomas (rrt) wrote :

The fix is fine for utopic.

tags: added: verification-done-utopic
removed: verification-needed-utopic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ddclient - 3.8.1-1ubuntu2.14.10.1

---------------
ddclient (3.8.1-1ubuntu2.14.10.1) utopic; urgency=low

  * Add patch from upstream which enables ddclient to find Digest::SHA to
    fix FreeDNS support (LP: #1068884)
 -- Scott Talbert <email address hidden> Sat, 06 Dec 2014 22:49:13 -0500

Changed in ddclient (Ubuntu Utopic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments