Ubuntu

Please sync dcraw 8.39-1 (main) from Debian unstable 8.80-1 (main)

Reported by Patrice Vetsel on 2007-02-20
20
Affects Status Importance Assigned to Milestone
dcraw (Debian)
Fix Released
Unknown
dcraw (Ubuntu)
Medium
Martin Pitt

Bug Description

Now that licence problem is solved. Please sync dcraw from Debian.

Patrice Vetsel (vetsel-patrice) wrote :

diffstat of the upstream tarballs

Patrice Vetsel (vetsel-patrice) wrote :

build-/install-log

Changed in dcraw:
importance: Undecided → Wishlist
assignee: nobody → motu-uvf

Changelog between 8.38<>8.54

Added a color matrix for the Fuji S6000fd.
Set aspect ratio for the Kodak DC20 and DC25.
If the JPEG thumbnail has no EXIF table, add one.
Built a color matrix for the Canon PowerShot S3 IS.
Added the Olympus SP510UZ.
Support the Panasonic DMC-L1, Leica Digilux 3, and Casio EX-Z4.
Run remove_zeroes() on most Panasonic and Leica models.
Built a color matrix for the Canon PowerShot A610.
Support Sinar IA file format.
Support internationalization if LOCALEDIR is defined.
Added stretch() function for cameras with non-square pixels.
Support "-h" and "-s" with Sinar 4-shot files.
Never append "DNG" to the camera model.
Added the Kodak DCS200 and Canon PowerShots A620 and S3 IS.
Added the Pentax K10D.
Added the Canon PowerShot A610.
Added "-K" option for dark-frame subtraction.
Get the Olympus black level from the ORF metadata.
Don't truncate PPM thumbnails.
Support the Olympus E-400 and Sinar 4-shot files.
Updated color matrices from DNG Converter 3.6.
Changed "-s" option to support multi-shot cameras.
Found a more reliable way to identify 4775936-byte images.
Updated link to Ting Chen's webpage.
Display the focal length of Canon CRW images.
Fixed "maximum" for the Canon EOS 5D.
Added the Nikon E3200.

Daniel Holbach (dholbach) wrote :

Although the changes are not exactly fixes, it'd be nice to have better 'hardware support'. But as you're bug contact for it, you have my +1 for it.

Changed in dcraw:
status: Unconfirmed → Needs Info
Hubert Figuiere (hub) wrote :

make sure it does not break the other programs that call dcraw from the command line. This is know to happen quite often.

Patrice Vetsel (vetsel-patrice) wrote :

@Hub : i do not know other programs calling directly dcraw (except gimp-cdraw, tested and working well with new version).

ufraw have it's own dcraw module included/like rawstudio/digikam

Patrice Vetsel (vetsel-patrice) wrote :

Updated package on revu to 8.61

description: updated

What are the changes to 8.61?

Patrice Vetsel (vetsel-patrice) wrote :

8.61<->8.54

Found larger JPEG thumbs for Nikon D100,D1H,D1X,D2H,D2X,E5000,E5700.
Reworded the copyright notice to avoid mention of the GPL.
Replaced bilateral filter with wavelet denoising.
Fixed incompatibility between "-f" and "-p".
Fixed strange color casts with the Polaroid x530.
Added Adobe matrices for the Nikon D40 and Pentax K10D.

Extract of new licence text :

/*
   dcraw.c -- Dave Coffin's raw photo decoder
   Copyright 1997-2007 by Dave Coffin, dcoffin a cybercom o net

   This is a command-line ANSI C program to convert raw photos from
   any digital camera on any computer running any operating system.

   No license is required to download and use dcraw.c. However,
   to lawfully redistribute this code, you must either (a) include
   full source code* for all executable files containing RESTRICTED
   functions, (b) remove all RESTRICTED functions, re-implement them,
   or copy them from an earlier, unrestricted Revision of dcraw.c,
   or (c) purchase a license from the author.

   The functions that process Foveon images have been RESTRICTED
   since Revision 1.237. All other code remains free for all uses.

   *If you have not modified dcraw.c in any way, a link to my
   homepage qualifies as "full source code".

   $Revision: 1.368 $
   $Date: 2007/02/25 03:09:54 $
 */

We must discuss if the (a) condition is ok for us to redistribute without any changes new dcraw in main.

Tollef Fog Heen (tfheen) wrote :

I have talked with James (Troup) over this and he is not happy with the licence, so that's a "no" to the UVF request (with this licence).

Daniel Holbach (dholbach) wrote :

Sorry. Feel free to file a new bug report if there's a new license or different circumstances under which we can do an update. I suggest talking to upstream about it.

Changed in dcraw:
assignee: motu-uvf → vetsel-patrice
status: Needs Info → Rejected
Achim Bohnet (allee) wrote :

FWIW: Here's a response from upstream:

2007/3/15, <email address hidden> <email address hidden>:
>
> Hi Gilles,
>
> It's the same rules as before. Does Debian have a
> problem with releasing their source code? Most Linux
> distros provide source packages so that anyone can
> rebuild any package from scratch.

Good question Dave. I'm not a Debian user but i use of course dcraw source
code with digikam and digiKam is currrently frozen to 8.60 because of this
bug report.

I CC your response to Achim Bohnet, witch packaging digiKam to Debian and
report me this problem. Please, please, please just guide Debian comunity to
solve it (:=)))

     Is anyone going to add the localization files to
> this package? Dcraw was internationalized with v8.48,
> and now supports nine languages:
>
> http://cybercom.net/~dcoffin/dcraw/#i18n

I know internationalization. This is another question for Achim. Note than
digiKam do not use it (and do not need).

                                Dave Coffin 3/14/2007

Thanks for your fast response.

Gilles Caulier

On Wed, Mar 14, 2007 at 10:10:02PM +0100, Gilles Caulier wrote:
> > Dave,
> >
> > are you seen this Debian bug entry :
> >
> > https://launchpad.net/ubuntu/+source/dcraw/+bug/86480
> >
> > Sound like the dcraw.c version over 8.60 cannot be included in Debian.
> it a
> > major problem for open source world...
> >
> > Regards
> >
> > Gilles Caulier
> > digiKam project
> > http://www.digikam.org
>

Achim Bohnet (allee) wrote :

@Tollef and/or James:

Gilles pointed Dave Coffin, dcraw upstream, to this report
and gave him a link to the DFSG.

Can you elaborate where/why you see problems with the
new license. Should be a start to get the ball rolling.

Discussion is on the way at debian :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=431883

Changed in dcraw:
status: Invalid → Incomplete

May be we have to look at softwares using dcraw because of licence problem… I think at digikam/ufraw/rawstudio

ChristofferS (ubuntu-curo) wrote :

The version should probably be upgraded to 8.77.

My olympus E-510 produces raw pictures which cannot be converted with the version in gutsy so it would be nice if the newest one could be made available.

I think we should ask the author to split dcraw into two files. One free part which supports all cameras but one and one non-free part for the camera where the author was not able to release the code as free software (Sigma DSLR with Foveon sensor SD 14? Royalties? Patents?). We should also tell Linux users if they want to have a DSLR, there are enough other systems: Canon, Nikon, Pentax, Olympus, Sony (and you can use Sigma lenses and flashes on them, too).

Scott Kitterman (kitterman) wrote :

Package is in Main, not Universe. Unsubscribing motu-uvf.

Achim Bohnet (allee) wrote :

Hi Till,
AFAIU the restricted part is _NOT_ the problem, 'cause: this part in the license has _NOT_
changed. Problem is, AFAIU, GPL was replace by "No license is required to download and .."

See also my comment from 26-Feb: Dave does not understand _WHY_ Debian/Kubuntu
has a problem with the license at all. I've asked for clarification but neither Tollef nor
James answered :(

IMHO: As we provide the code in the source pkg, I (whatever that's worth) and obviously Dave,
as it looks to me from Dave answer to Gilles question, see no problem distributing dcraw.
If in doubt, append the source code (it's one C file) in the debian/copyright file.

As is, we are stuck. :( Nobody, that has a problem with the license explicitly states/explains
what the problem with the license is. This blocks completetly the support of all new
RAW cameras. As a consequence all linux apps that support raw cameras will need
backporting as dcraw interface changed as usual and every app will need to be
backported to the older dcraw.

Sad but true :(

Achim

For more informations :

ufraw 0.11 in Gutsy use 8.62
rawstudio 0.5.1+20070601 in Gutsy use 8.46
digikam 0.9.2 use libkdcraw1 0.1.1 in Gutsy which use 8.60

Changed in dcraw:
status: Unknown → New
Luka Renko (lure) wrote :

Correct, we need to address ufraw in gutsy and if license is not free enough, move it to multiverse.

This is from ufraw package: dcraw.cc:

/*
   dcraw.cc - Dave Coffin's raw photo decoder - C++ adaptation
   Copyright 1997-2007 by Dave Coffin, dcoffin a cybercom o net
   Copyright 2004-2007 by Udi Fuchs, udifuchs a gmail o com

   This program is free software; you can redistribute it and/or modify
   it under the terms of the GNU General Public License version 2
   as published by the Free Software Foundation. You should have received
   a copy of the license along with this program.

   This is a adaptation of Dave Coffin's original dcraw.c to C++.
   It can work as either a command-line tool or called by other programs.

   Notice that the original dcraw.c is published under a different
   license. Naturaly, the GPL license applies only to this derived
   work.

   $Revision: 1.370 $
   $Date: 2007/03/02 17:40:15 $
 */

Tollef Fog Heen (tfheen) wrote :

The last suggestion from David in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=431883#60 seems fine to me. Ideally, I'd like the wording to be even clearer than it is that dcraw is under the GPLv2 or later (or at the distributor's option, a list of other licences).

I'm also naively assuming that the licence here is for dcraw as a whole, not particular to single source files. (In the latter case, we need to make sure the GPLv2 (or another free licence) is ok for all source files.)

Can we close this bug now and upgrade dcraw/ufraw... ?

/*
   dcraw.c -- Dave Coffin's raw photo decoder
   Copyright 1997-2007 by Dave Coffin, dcoffin a cybercom o net

   This is a command-line ANSI C program to convert raw photos from
   any digital camera on any computer running any operating system.

   No license is required to download and use dcraw.c. However,
   to lawfully redistribute dcraw, you must either (a) offer, at
   no extra charge, full source code* for all executable files
   containing RESTRICTED functions, (b) distribute this code under
   the GPL Version 2 or later, (c) remove all RESTRICTED functions,
   re-implement them, or copy them from an earlier, unrestricted
   Revision of dcraw.c, or (d) purchase a license from the author.

   The functions that process Foveon images have been RESTRICTED
   since Revision 1.237. All other code remains free for all uses.

   *If you have not modified dcraw.c in any way, a link to my
   homepage qualifies as "full source code".

   $Revision: 1.396 $
   $Date: 2007/11/16 15:24:52 $
 */

Changed in dcraw:
status: Incomplete → In Progress
importance: Wishlist → Medium
Martin Pitt (pitti) wrote :

Nothing to do for ubuntu-archive here. As soon as it's sorted out in Debian, then it'll get autosynced, and we are not in feature freeze in Hardy yet.

Changed in dcraw:
milestone: ubuntu-7.04 → none
status: In Progress → Invalid
Changed in dcraw:
status: New → Fix Released
description: updated
Martin Pitt (pitti) on 2007-12-25
Changed in dcraw:
status: Invalid → Confirmed

dcraw-8.80-1 packages have been uploaded to Debian on 2007-12-23 (reported in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=431883).

Since the Hardy Heron debian package freeze was on 2007-12-13, someone will have to explicitly upload the new dcraw package for inclusion - Martin/Daniel?

Martin Pitt (pitti) wrote :

synced

Changed in dcraw:
assignee: vetsel-patrice → pitti
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.