gnome tweak tool and control center should gracefully handle corrupt dconf database

Bug #1781832 reported by Jazz Veritas on 2018-07-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dconf (Ubuntu)
Undecided
Unassigned
gnome-tweak-tool (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 18.04 on Dell XPS 15 9570.
gnome-tweak-tool 3.28.1-1

Steps to reproduce:
1) Open gnome-tweaks (via launcher or command line)
2) Switch to "fonts" page
3) Click the font switcher for "Interface" fonts (Others may also do this but I can't test without losing this report.)

Expected:
Font chooser opens.

Actual:
System becomes unresponsive for a few seconds. Sometimes the chooser partially renders at the end of this time. Whether it does or not, the session immediately ends and bounces me back to the login screen.

This worked on my system at one point; I don't think I changed anything since then besides installing various other packages and possibly `apt-get update && apt-get upgrade`.

Jazz Veritas (jazzv) wrote :

Tested the other font categories, and they crash as well.

Jazz Veritas (jazzv) wrote :

I may have filed this in the wrong component: I'm getting a similar-looking crash when I try to change keyboard shortcuts through the default settings tool.

Jazz Veritas (jazzv) wrote :

I think this is the same problem:
https://www.reddit.com/r/Ubuntu/comments/8j6iu5/ubuntu_1804_crashes_when_opening_system_settings/

However, their solution was to upgrade nvidia drivers to 384, and I'm already running 390.

Gunnar Hjalmarsson (gunnarhj) wrote :

Can it be that your dconf database is corrupt or with incorrect file permissions? You may want to test by doing:

cd ~/.config/dconf
mv user user.bak

and relogin.

Jazz Veritas (jazzv) wrote :

Yup, #4 seems to have fixed it. That narrows the scope of the bug considerably: now I'm reduced to complaining that it crashed, rather than gracefully handling a corrupted database.

summary: - gnome tweak tool kills session when changing fonts
+ gnome tweak tool and control center should gracefully handle corrupt
+ dconf database
Sebastien Bacher (seb128) wrote :

That's rather a dconf issue

affects: gnome-control-center (Ubuntu) → dconf (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers