/usr/lib/dbus-1.0/dbus-daemon-launch-helper not executable by other

Bug #992366 reported by gpk on 2012-05-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dbus (Ubuntu)
Undecided
Unassigned

Bug Description

After an upgrade from Ubuntu 11.10 to 12.04, pulseaudio didn't work, and the root cause turned out to be that /usr/lib/dbus-1.0/dbus-daemon-launch-helper did not have o+x permissions. See this:

-rwsr-xr-- 1 root messagebus 292944 Feb 22 03:48 /usr/lib/dbus-1.0/dbus-daemon-launch-helper

and then when I did
sudo chmod o+x /usr/lib/dbus-1.0/dbus-daemon-launch-helper
pulseaudio worked.

As an additional clue, when I started the pulse audio volume control, it said that /usr/lib/dbus-1.0/dbus-daemon-launch-helper failed, and then when I tried running pulseaudio from the command line, it saud that dbus-daemon-launch-helper didn't have permissions to execute.

This is either an installer problem or a dbus problem.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: dbus 1.4.18-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Mon Apr 30 23:18:00 2012
ExecutablePath: /bin/dbus-daemon
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: dbus
UpgradeStatus: Upgraded to precise on 2012-04-28 (2 days ago)

gpk (gpk-kochanski) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers