Ubuntu

dbus behaviour change from natty to oneiric: now enables X11 autolaunch

Reported by James Hunt on 2011-07-19
72
This bug affects 15 people
Affects Status Importance Assigned to Milestone
The Leadville project
Undecided
Unassigned
dbus (Ubuntu)
Undecided
Unassigned

Bug Description

The Ubuntu dbus package is not explicitly setting configure options. The latest version of lp:ubuntu/dbus appears to have introduced a new option (?) which is defaulting to "enabled". The option is "--enable-x11-autolaunch":

./configure
grep "^#define DBUS_ENABLE_X11_AUTOLAUNCH" config.h

(The question mark about is due to the fact that the natty dbus package doesn't seem to have a configure.ac script so can't do a direct diff).

The behaviour now is that if you are running in an environment where there is no X11, you get this error when you first attempt to use a binary/lib that requires dbus:

  Unable to autolaunch a dbus-daemon without a $DISPLAY for X11'

This behaviour is different to that with natty. Fix would appear to be to set "--disable-x11-autolaunch" explicitly (and maybe audit the other options to check for changes).

James Hunt (jamesodhunt) wrote :

As discussed with Colin, it may be better (and safer) to retain this change since it is now the default in dbus and as such is the new expected behaviour.

Users who may be affected by this change in auto-launch behaviour can either:

1) Arrange for dbus to auto-launch on address they specify using the DBUS_*_BUS_ADDRESS variables.

2) Manually start the dbus-daemon themselves (maybe as a background job to avoid bug 812913).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dbus (Ubuntu):
status: New → Confirmed
Danjel McGougan (danjel-k) wrote :

The uptrack cron job on my headless server started to produce this output every 30 minutes since the upgrade to oneiric:

(process:7032): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Unable to autolaunch a dbus-daemon without a $DISPLAY for X11

I suppose this is related to this bug? How do I work around it?

Jason Ward (jason-jasonward) wrote :

Why does my job work when I run it manually, but fail with this error when run by cron?

Also can you explain what "Arrange for dbus to auto-launch on address they specify using the DBUS_*_BUS_ADDRESS variables." means so that I might be able to do it?

Cheers
Jason

Danjel McGougan (danjel-k) wrote :

Ping! Anything happening with this bug?

Jason Ward (jason-jasonward) wrote :

Would love an update on this, and/or if someone could answer my question that would be cool.

Danjel McGougan (danjel-k) wrote :

I solved my problem by telling uptrack not to check gconf for network proxy settings.

In the general case, how are cron jobs supposed to query gconf with this new behavior? Or is that not supported?

Reed Loden (reed) wrote :

re: comment #1, are you meaning something like what's mentioned in http://www.rootninja.com/dbus-session-bus-address-with-applications-using-ssh/ ?

Dan Kortschak (dan-kortschak) wrote :

Is there any movement on this?

Mike Carifio (carifio) wrote :

If I understand this bug correctly, if I want to add pulseaudio, which is started by dbus, then I must install xorg also.

We are doing a project where we want audio on a headless system. So we don't want to install X to get sound. When I install just pulseaudio, I get the error above and no sound. When I install xorg, I get sound and no error. Is there a workaround?

tags: added: leadville
Rex Tsai (chihchun) wrote :

libpulse0 depends on libxcb1, which pull other x11 libraries anyway. But if you don't want whole Xorg, then you can run pulseaudio as system mode (/etc/default/pulseaudio), which does not require X11 and dbus user session.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers