Sometimes DBus fails to reload after resuming from suspend-to-RAM

Bug #27638 reported by Celso Pinto on 2005-12-27
16
Affects Status Importance Assigned to Milestone
dbus (Ubuntu)
Medium
Unassigned

Bug Description

On a laptop, sometimes after resuming from suspend-to-RAM, DBus fails to come
up. A few running applications depend on it (gnome-power-manager or
network-manager) and it's easy to detect when DBus failed to come up mostly
because network-manager will fail to bring the wlan interface up.

Running dbus-viewer I get something like "failed to open bus connection". DBus
version is 0.60-2ubuntu6 in Dapper.

Daniel Stone (daniels) wrote :

er, dbus doesn't need to restart on suspend-to-ram. the question would be more
'why does it die?'. can you please try running it from the terminal and seeing
if it spits out any errors?

Daniel Stone (daniels) on 2006-03-10
Changed in dbus:
assignee: daniels → nobody
Celso Pinto (cpinto) wrote :

I can't reproduce the reported error anymore, I'm using Dapper Flight6.

Pedro Côrte-Real (pedrocr) wrote :

I'm seeing this semi-reliably. What log should I check when it happens? How do I run it from the terminal?

Pedro Côrte-Real (pedrocr) wrote :

I think this is a network-manager bug after all. Dbus isn't crashing at all. I've submitted the bugreport:

https://launchpad.net/distros/ubuntu/+source/network-manager/+bug/57689

I have the same problem.
Somehow dbus isn't responding anymore. Trying to start any program from the Gnome menu's doesn't work, as they can't connect to dbus.

Sebastian Dröge (slomo) wrote :

Any program? not all gnome programs are using dbus now... is, say, mahjongg still starting?

I had a similar problem in the past with no apps starting after waking up from suspend-to-ram but this was caused by the X session manager not responding anymore.

Well, the programs I use don't work anymore. I'll try to start mahjongg next time it happens (happens in 2 out of 5 I think).

Seems it's not related to x session manager.
Firefox just starts as normal, but every other app I tried (gnome-terminal, mahjongg, gaim) doesn't start.
When I switch to a different console and run something like:
DISPLAY=:0 gnome-terminal

It starts normally...
How weird is that?

BTW, when I run a killall gnome-panel from a different console, it restarts gnome-panel and loads all applications I tried to start earlier, by clicking on them in the menu's.

wolfger (wolfger) wrote :

This bug hasn't been touched in over a year. Is there still a problem?

Changed in dbus:
status: Incomplete → New
Pedro Côrte-Real (pedrocr) wrote :

Haven't seen this happen for a long time. I'm running gutsy now. I'd say close it.

wolfger (wolfger) wrote :

Closing per the above comments. If the problem still exists, please provide information on it and set the status back to "new".

Changed in dbus:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.