suspend, hibernate cause dbus crash

Bug #165318 reported by Harrison on 2007-11-27
6
Affects Status Importance Assigned to Milestone
dbus (Ubuntu)
Undecided
Unassigned

Bug Description

After resuming from hibernate or suspend on Dell Inspiron 1420 with Ubuntu Gutsy 7.10, dbus seems to fail. NetworkManager no longer works and there is no internet. The Volume Control applet shuts down and a dialog appears to restore it. Restarting dbus (sudo /etc/init.d/dbus restart) fixes all issues and everything goes back to normal.

SK (stephantom) wrote :

Thank you for taking the time to report this bug.
Unfortunaltely you have not provided us with enough information to effectively takle it.
Please look at the System Log (avaliable from "Administration" in your System menu) and see if there are any messages relating to dbus after a resume.
It would also be important to know which version of dbus you are having the problem with.

Iulian Udrea (iulian) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem. Please reopen it if you can give us the missing information. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Thank you.

Changed in dbus:
status: Incomplete → Invalid
maho (maho) wrote :

Hi,

I have almost exactly the same problem with notebook HP dv6780ew.

When I suspend or hibernate, and resume, I have no wifi working. knetworkmanager or nm-applet (depending if I'm using gnome or kde) shows no wifi interfaces available.

Next, I do /etc/init.d/dbus restart, nm-applet/knetworkmanager still doesn't show wifi networks. Next, I close them and re-launch again, and bingo - it works.

Module used: iwl3954

Please tell me what you need to know about my system

Changed in dbus:
status: Invalid → New
maho (maho) wrote :

Problem disappeared when upgraded ubuntu from 7 to 8.

Bryce Harrington (bryce) wrote :

Closing as per last comment from maho. Also, I have an Inspiron 1420 with Intrepid and have not seen this particular issue. (Sleep fails for me, but not due to dbus crashing)

Changed in dbus:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers