Installing unity8-session-snap adversely effects unity7

Bug #1644323 reported by Pat McGowan on 2016-11-23
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Will Cooke
dbus (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
unity-gtk-module (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[ Description ]

In Xenial, when dbus-user-session is installed, dbus' upstart job still starts a new bus. Things get confused about which bus to talk to.

[ Fix ]

Already fixed in Yakkety. Cherry-pick the upstart job. On top of Yakkety's version, call `dbus-update-activation-environment --verbose --systemd GTK_MODULES', because Xenial does not have the change in upstart to automatically publish to the systemd activation environment.

/etc/X11/Xsession.d/95dbus_update-activation-env is called too early - before unity-gtk-module.conf is started - so dbus activated services miss the GTK_MODULES environment variable. Update unity-gtk-module.conf to set it in the dbus activation environment.

[ QA ]

Install dbus-user-session, press print screen. It should be delayed if you are experiencing this bug, and not delayed otherwise.

Remove dbus-user-session, make sure the session still works properly - the global menu works, everything launches properly, etc.

Test that gnome-terminal has global menus in both situations.

[ Regression potential ]

This change alters the way that the session bus is launched, even if you aren't using dbus-user-session. Even though this same change is deployed in ≥ yakkety, be aware of this. In yakkety we have installed dbus-user-session by default, so the case where you don't have it isn't as well tested. I would suggest focusing some testing on the non dbus-user-session case.

[ Original report ]

After installing the deb (and then the snap), certain things in the unity7 session take a very long time (30 to 60 secs), such as launching chromium and ctrl-alt-t for a new terminal session.

Removing both the deb and the snap followed by a reboot does not fix the symptoms.

Xenial amd64 laptop

description: updated
Changed in unity8-session-snap:
assignee: nobody → Michael Terry (mterry)
Changed in canonical-devices-system-image:
milestone: none → p1
description: updated
description: updated
Michael Terry (mterry) wrote :

Seems to be related to synchronous DBus calls to gnome-keyring timing out... Digging more.

Michael Terry (mterry) wrote :

A workaround is to run "gnome-keyring-daemon -r" in a terminal.

Michael Terry (mterry) wrote :

Removing dbus-user-session fixes this. It's also a new dependency of unity8-session-snap, which is when this bug appeared.

affects: unity8-session-snap → dbus (Ubuntu)
Changed in dbus (Ubuntu):
assignee: Michael Terry (mterry) → Ted Gould (ted)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dbus (Ubuntu):
status: New → Confirmed
dinamic (dinamic6661) wrote :

yep, same here. it takes almost 30s - 1 min to take a screenshot :/ press Print Screen and chrome takes a while to load

Pat McGowan (pat-mcgowan) wrote :

Need to check if already fixed in later versions

Changed in canonical-devices-system-image:
assignee: nobody → Will Cooke (willcooke)
importance: Undecided → High
status: New → Confirmed
Will Cooke (willcooke) wrote :
Iain Lane (laney) wrote :

not pk, we need to fix the dbus upstart job to not start a daemon if there already is one

Iain Lane (laney) on 2016-11-30
Changed in dbus (Ubuntu):
assignee: Ted Gould (ted) → nobody
Changed in dbus (Ubuntu Xenial):
status: New → In Progress
Changed in dbus (Ubuntu):
status: Confirmed → Fix Released
Iain Lane (laney) wrote :

unity-gtk-module needs to update the systemd environment now too

description: updated
Iain Lane (laney) on 2016-11-30
Changed in unity-gtk-module (Ubuntu):
status: New → Fix Released
Changed in unity-gtk-module (Ubuntu Xenial):
status: New → In Progress
Iain Lane (laney) wrote :

Both uploaded.

Iain Lane (laney) on 2016-11-30
description: updated
Changed in canonical-devices-system-image:
status: Confirmed → In Progress

Hello Pat, or anyone else affected,

Accepted dbus into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/dbus/1.10.6-1ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in dbus (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Pat McGowan (pat-mcgowan) wrote :

Tested with version 1.10.6-1ubuntu3.2 of the packages dbus dbus-x11 libdbus-1-3 libdbus-1-3:i386 libdbus-1-dev dbus-user-session from xenial-proposed

tags: added: verification-done
removed: verification-needed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Iain Lane (laney) wrote :

I don't see how this can be v-done given the QA steps in the description, since unity-gtk-module isn't accepted yet. Were those steps followed? If so, maybe I was too hasty in linking u-g-m into the bug. If not, please could u-g-m be reviewed and ideally accepted into x-proposed so this can be re-verified?

Pat McGowan (pat-mcgowan) wrote :

@laney I tested per my original report, and the delays are gone when d-u-s is installed. Otherwise things I tried work with and without dbus-user-session.

I am unclear on the symptoms in the rest of your description. I never recall seeing global menus for terminal app.

Brian Murray (brian-murray) wrote :

Hello Pat, or anyone else affected,

Accepted unity-gtk-module into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-gtk-module/0.0.0+15.04.20150118-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-gtk-module (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed

I've tested dbus 1.10.6-1ubuntu3.2 on frieza xenial/arm64 and it renders the device completely unusable (cf bug 1654241)

Marking as verification-failed.

tags: added: verification-failed
removed: verification-needed

On Tue, Jan 10, 2017 at 12:39:40PM -0000, Jean-Baptiste Lallement wrote:
> I've tested dbus 1.10.6-1ubuntu3.2 on frieza xenial/arm64 and it renders
> the device completely unusable (cf bug 1654241)
>
> Marking as verification-failed.

That's fair, but note that this is *not* a bug with this SRU. Something
is starting a dbus-daemon and setting its address in the environment. It
then is terminated and not available in the session. This SRU makes dbus
not start a new bus if the environment is saying there already is one.

Yes, it should be held out of -updates until that is fixed. But the fix
is elsewhere.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Pat McGowan (pat-mcgowan) wrote :

@jibel can we open a new bug, this was about unity7 which seems fixed to me

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released

I reopened bug 1654241

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dbus - 1.10.6-1ubuntu3.3

---------------
dbus (1.10.6-1ubuntu3.3) xenial; urgency=medium

  * debian/dbus.user-session.upstart:
    - Temporarily revert latest changes as those seem to cause issues in the
      unity8 session on touch (LP: #1654241).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 12 Jan 2017 19:01:21 +0100

Changed in dbus (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in dbus (Ubuntu Xenial):
status: Fix Released → Fix Committed
Pat McGowan (pat-mcgowan) wrote :

This official update regressed for me, I once again have the delays starting certain apps. I had not seen them since installing the packages per comment #13 which was a previous revision.

Changed in dbus (Ubuntu Xenial):
status: Fix Committed → Confirmed
Changed in canonical-devices-system-image:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.