Merge dbus 1.10.10-1 (main) from Debian unstable (main)

Bug #1622401 reported by Jeremy Bicha on 2016-09-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dbus (Ubuntu)
Wishlist
Unassigned

Bug Description

Please merge dbus 1.10.10-1 (main) from Debian unstable (main)

1.10.10 is a bugfix release in the stable 1.10 series.

https://sources.debian.net/src/dbus/1.10.10-1/NEWS/

https://cgit.freedesktop.org/dbus/dbus/log/?h=dbus-1.10

I am personally interested in Debian's virtual default-dbus-session-bus package since Debian is increasingly depending on it instead of directly depending on dbus-x11.

https://lists.debian.org/debian-devel/2016/08/msg00554.html

Explanation of the Ubuntu delta and why it can be dropped:
  - debian/dbus.preinst: divert the dbus-daemon-launch-helper if upgrading
    from < 1.9.4-2~. This will make sure we keep the setuid bit during upgrade.
   (LP: #1555237)
 Not needed after Ubuntu 16.04 LTS

Explanation of the remaining Ubuntu delta
    - Add upstart jobs
      + debian/dbus.upstart and debian/dbus.user-session.upstart
    - debian/dbus.postinst: remove diversion.
    - debian/rules: Don't start D-Bus on package installation, as that doesn't
      work any more. Instead, start dbus.socket in postinst, which will then
      start D-Bus on demand after package installation.
    - Add debian/patches/dont-stop-dbus.patch: Don't stop D-Bus in the service
      unit (see patch header and upstream bug for details). Fixes various
      causes of shutdown hangs, particularly with remote file systems. (LP:
      #1438612) (LP: #1540282)
    - aa-get-connection-apparmor-security-context.patch: This is not
      intended for upstream inclusion. It implements a bus method
      (GetConnectionAppArmorSecurityContext) to get a connection's AppArmor
      security context but upstream D-Bus has recently added a generic way of
      getting a connection's security credentials (GetConnectionCredentials).
      Ubuntu should carry this patch until packages in the archive are moved
      over to the new, generic method of getting a connection's credentials.

Changelog entries since current yakkety version 1.10.6-1ubuntu4:

dbus (1.10.10-1) unstable; urgency=medium

  * New upstream stable release 1.10.10
  * Provide new virtual packages for other packages to depend on:
    - dbus-session-bus: any implementation of the D-Bus well-known session bus
      (provided by: dbus-user-session, dbus-x11)
    - default-dbus-session-bus: the recommended implementation of
      dbus-session-bus (currently provided by: dbus-user-session)
  * Add arm64, mips64el, ppc64el to the list of architectures that
    have valgrind
  * debian/gbp.conf: use DEP-14 branch names
  * Standards-Version: 3.9.8 (no changes needed)
  * debian/rules: fail the build if "make install" installs anything we
    don't package or delete. Only do this for final releases (suite
    in debian/changelog is not UNRELEASED) to facilitate future
    autobuilding of new upstream releases.
  * debian/rules: do not require symbols file to be complete if the
    suite in debian/changelog is UNRELEASED, again to facilitate
    autobuilding new upstream releases.
  * debian/source/options: don't fail dpkg-source on changes to
    build-aux/{compile,depcomp,missing}. We regenerate that directory anyway,
    and during a snapshot build they might become symlinks.
  * debian/rules: do the build in debian/build-* so it's easier to .gitignore
  * debian/.gitignore: update
  * Use the correct systemctl for Debian even if not installed on the build
    system. (Regression in 1.10.2)

 -- Simon McVittie <email address hidden> Mon, 15 Aug 2016 22:05:45 +0100

dbus (1.10.8-1) unstable; urgency=medium

  * New upstream release
  * dbus.prerm: ensure that dbus.socket is stopped before removal,
    so that a new connection to the bus won't cause dbus.service to be
    restarted (Closes: #813970)
  * debian/75dbus_dbus-launch: when not using systemd --user or the
    dbus-user-session package is not installed, start dbus-daemon early,
    then upload the full environment from Xsession.d later on
    (in 95dbus_update-activation-env). This more closely matches the
    behaviour with dbus-user-session. (Closes: #815503; thanks to Samuel
    Thibault)
  * Switch Vcs-Git to https (see #810378)
  * debian/upstream/signing-key.asc: add upstream signing keys
    (just my keys for now, in practice I do almost all dbus releases)
  * debian/watch: use https and describe how to download signatures
  * Standards-Version: 3.9.7 (no changes needed)
  * Sort .install files and remove unnecessary debian/tmp prefix
  * Normalize lists of packages and uploaders via wrap-and-sort -ast
  * Normalize order of packages via wrap-and-sort -b

 -- Simon McVittie <email address hidden> Mon, 07 Mar 2016 19:15:47 +0000

Jeremy Bicha (jbicha) on 2016-09-11
Changed in dbus (Ubuntu):
importance: Undecided → Wishlist
Jeremy Bicha (jbicha) wrote :

debdiff from current Ubuntu packaging to proposed

description: updated
tags: added: upgrade-software-version
Jeremy Bicha (jbicha) wrote :

debdiff from current Debian packaging to proposed Ubuntu packaging

Jeremy Bicha (jbicha) wrote :

old debdiff (from Debian's 1.10.6-1 to Ubuntu's 1.10.6-1ubuntu4)

Jeremy Bicha (jbicha) on 2016-09-11
description: updated
Martin Pitt (pitti) wrote :

LGTM, thanks! I'll take the liberty to add the cleanup of /etc/init/dbus.conf.

Changed in dbus (Ubuntu):
status: New → In Progress
Martin Pitt (pitti) on 2016-09-12
Changed in dbus (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package dbus - 1.10.10-1ubuntu1

---------------
dbus (1.10.10-1ubuntu1) yakkety; urgency=medium

  [ Jeremy Bicha ]
  * Merge with Debian (LP: #1622401), remaining changes:
    - Add debian/dbus.user-session.upstart.
    - debian, dbus.postinst, debian/rules: Don't start D-Bus on package
      installation, as that doesn't work any more. Instead, start dbus.socket
      in postinst, which will then start D-Bus on demand after package
      installation.
    - Add debian/patches/dont-stop-dbus.patch: Don't stop D-Bus in the service
      unit (see patch header and upstream bug for details). Fixes various
      causes of shutdown hangs, particularly with remote file systems. (LP:
      #1438612) (LP: #1540282)
    - aa-get-connection-apparmor-security-context.patch: This is not
      intended for upstream inclusion. It implements a bus method
      (GetConnectionAppArmorSecurityContext) to get a connection's AppArmor
      security context but upstream D-Bus has recently added a generic way of
      getting a connection's security credentials (GetConnectionCredentials).
      Ubuntu should carry this patch until packages in the archive are moved
      over to the new, generic method of getting a connection's credentials.
  * Dropped changes:
    - debian/dbus.preinst: divert the dbus-daemon-launch-helper if upgrading
      from < 1.9.4-2~. This will make sure we keep the setuid bit during upgrade.
      (LP: #1555237)
    - Drop system upstart job.

  [ Martin Pitt ]
  * Clean up /etc/init/dbus.conf on upgrades. This needs to be kept until
    after 18.04 LTS.

dbus (1.10.10-1) unstable; urgency=medium

  * New upstream stable release 1.10.10
  * Provide new virtual packages for other packages to depend on:
    - dbus-session-bus: any implementation of the D-Bus well-known session bus
      (provided by: dbus-user-session, dbus-x11)
    - default-dbus-session-bus: the recommended implementation of
      dbus-session-bus (currently provided by: dbus-user-session)
  * Add arm64, mips64el, ppc64el to the list of architectures that
    have valgrind
  * debian/gbp.conf: use DEP-14 branch names
  * Standards-Version: 3.9.8 (no changes needed)
  * debian/rules: fail the build if "make install" installs anything we
    don't package or delete. Only do this for final releases (suite
    in debian/changelog is not UNRELEASED) to facilitate future
    autobuilding of new upstream releases.
  * debian/rules: do not require symbols file to be complete if the
    suite in debian/changelog is UNRELEASED, again to facilitate
    autobuilding new upstream releases.
  * debian/source/options: don't fail dpkg-source on changes to
    build-aux/{compile,depcomp,missing}. We regenerate that directory anyway,
    and during a snapshot build they might become symlinks.
  * debian/rules: do the build in debian/build-* so it's easier to .gitignore
  * debian/.gitignore: update
  * Use the correct systemctl for Debian even if not installed on the build
    system. (Regression in 1.10.2)

dbus (1.10.8-1) unstable; urgency=medium

  * New upstream release
  * dbus.prerm: ensure that dbus.socket is stopped before removal,
    so that a new conne...

Read more...

Changed in dbus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers