Breaks policykit/systemctl commands when restarted

Bug #1540282 reported by Unit 193 on 2016-02-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dbus (Ubuntu)
Low
Martin Pitt

Bug Description

When dbus is restarted, lightdm and network-manager flake out like normal, but in addition to that `service` and `systemctl` commands fail with a policykit timeout error. This issue is not in Debian and when dbus is installed from Debian this specific issue goes away.

While restarting dbus isn't a "supported" thing to do, the system breaking apart and requiring restart is certainly bad.

Unit 193 (unit193) wrote :

Part of the problem is that while d/p/dont-stop-dbus.patch prevents dbus from being stopped, it doesn't prevent another one from starting, thus systemctl restart dbus.service will not stop the current one but will indeed launch a new instance.

Martin Pitt (pitti) wrote :

This is due to our "ExecStop=/bin/true" which prevents killing dbus during shutdown. We should indeed prevent manual restarts due to that.

Changed in dbus (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Low
status: New → Triaged
Martin Pitt (pitti) on 2016-02-11
Changed in dbus (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dbus - 1.10.6-1ubuntu2

---------------
dbus (1.10.6-1ubuntu2) xenial; urgency=medium

  * dont-stop-dbus.patch: Disallow manual (re)starts, as we don't (want to)
    stop D-Bus on shutdown. (LP: #1540282)
  * debian/rules: Don't start D-Bus on package installation, as that doesn't
    work any more with the above. Instead, start dbus.socket in postinst,
    which will then start D-Bus on demand after package installation.

 -- Martin Pitt <email address hidden> Thu, 11 Feb 2016 12:58:02 +0100

Changed in dbus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers