Ubuntu 14.04.1 LTS - apt-get broken after upgrade - Package netbase is not configured yet.

Bug #1375836 reported by juniorsa on 2014-09-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dbus (Ubuntu)
Undecided
William Lee

Bug Description

After doing the dist-upgrade to Ubuntu 14.04.1 LTS we now have a system that apt-get is broken.
When we try and do apt-get -f install this is the output:

root@web2:~# apt-get -f install
Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
24 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up netbase (5.2) ...
Installing new version of config file /etc/services ...
dpkg: error processing package netbase (--configure):
 unable to install `/etc/services.dpkg-new' as `/etc/services': Operation not permitted
dpkg: dependency problems prevent configuration of ntpdate:
 ntpdate depends on netbase; however:
  Package netbase is not configured yet.

dpkg: error processing package ntpdate (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of dbus:
 dbus depends on netbase (>= 4.45ubuntu3); however:
  Package netbase is not configured yet.

dpkg: error processing package dbus (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of accountsservice:
 accountsservice depends on dbus; however:
  Package dbus is not configured yet.

dpkg: error processing package accountsservice (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of language-selector-common:
 language-selector-common depends on dbus; however:
  Package dbus is not configured yet.
 language-selector-common depends on accountsservice (>= 0.6.29-1ubuntu6); however:
  Package accountsservice is not configured yet.

dpkg: error processing package language-selector-common (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of systemd-services:
 systemd-services depends on dbus; however:
  Package dbus is not configured yet.

dpkg: error processing package systemd-services (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of libpam-systemd:amd64:
 libpam-systemd:amd64 depends on systemd-services (= 204-5ubuntu20.6); however:
  Package systemd-services is not configured yet.

dpkg: error processing package libpam-systemd:amd64 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ntp:
 ntp depends on netbase; however:
  Package netbase is not configured yet.

dpkg: error processing package ntp (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ubuntu-minimal:
 ubuntu-minimal depends on netbase; however:
  Package netbase is not configured yet.
 ubuntu-minimal depends on ntpdate; however:
  Package ntpdate is not configured yet.

dpkg: error processing package ubuntu-minimal (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ftp:
 ftp depends on netbase; however:
  Package netbase is not configured yet.

dpkg: error processing package ftp (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of telnet:
 telnet depends on netbase; however:
  Package netbase is not configured yet.

dpkg: error processing package telnet (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of ubuntu-standard:
 ubuntu-standard depends on ftp; however:
  Package ftp is not configured yet.
 ubuntu-standard depends on language-selector-common; however:
  Package language-selector-common is not configured yet.

dpkg: error processing package ubuntu-standard (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of libio-socket-ssl-perl:
 libio-socket-ssl-perl depends on netbase; however:
  Package netbase is not configured yet.

dpkg: error processing package libio-socket-ssl-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of libnet-smtp-ssl-perl:
 libnet-smtp-ssl-perl depends on libio-socket-ssl-perl; however:
  Package libio-socket-ssl-perl is not configured yet.

dpkg: error processing package libnet-smtp-ssl-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of libmailtools-perl:
 libmailtools-perl depends on libnet-smtp-ssl-perl; however:
  Package libnet-smtp-ssl-perl is not configured yet.

dpkg: error processing package libmailtools-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of libmime-tools-perl:
 libmime-tools-perl depends on libmailtools-perl; however:
  Package libmailtools-perl is not configured yet.

dpkg: error processing package libmime-tools-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of libwww-perl:
 libwww-perl depends on netbase; however:
  Package netbase is not configured yet.

dpkg: error processing package libwww-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of liblwp-protocol-https-perl:
 liblwp-protocol-https-perl depends on libio-socket-ssl-perl (>= 1.54); however:
  Package libio-socket-ssl-perl is not configured yet.
 liblwp-protocol-https-perl depends on libwww-perl (>= 6.05-2); however:
  Package libwww-perl is not configured yet.

dpkg: error processing package liblwp-protocol-https-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of libxml-parser-perl:
 libxml-parser-perl depends on libwww-perl; however:
  Package libwww-perl is not configured yet.

dpkg: error processing package libxml-parser-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of libsoap-lite-perl:
 libsoap-lite-perl depends on libio-socket-ssl-perl; however:
  Package libio-socket-ssl-perl is not configured yet.
 libsoap-lite-perl depends on libmime-tools-perl; however:
  Package libmime-tools-perl is not configured yet.
 libsoap-lite-perl depends on libwww-perl; however:
  Package libwww-perl is not configured yet.
 libsoap-lite-perl depends on libxml-parser-perl; however:
  Package libxml-parser-perl is not configured yet.

dpkg: error processing package libsoap-lite-perl (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of postfix:
 postfix depends on netbase; however:
  Package netbase is not configured yet.

dpkg: error processing package postfix (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of mailutils:
 mailutils depends on default-mta | mail-transport-agent; however:
  Package default-mta is not installed.
  Package postfix which provides default-mta is not configured yet.
  Package mail-transport-agent is not installed.
  Package postfix which provides mail-transport-agent is not configured yet.

dpkg: error processing package mailutils (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of policykit-1:
 policykit-1 depends on libpam-systemd; however:
  Package libpam-systemd:amd64 is not configured yet.
 policykit-1 depends on dbus; however:
  Package dbus is not configured yet.

dpkg: error processing package policykit-1 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python-secretstorage:
 python-secretstorage depends on dbus; however:
  Package dbus is not configured yet.

dpkg: error processing package python-secretstorage (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
Errors were encountered while processing:
 netbase
 ntpdate
 dbus
 accountsservice
 language-selector-common
 systemd-services
 libpam-systemd:amd64
 ntp
 ubuntu-minimal
 ftp
 telnet
 ubuntu-standard
 libio-socket-ssl-perl
 libnet-smtp-ssl-perl
 libmailtools-perl
 libmime-tools-perl
 libwww-perl
 liblwp-protocol-https-perl
 libxml-parser-perl
 libsoap-lite-perl
 postfix
 mailutils
 policykit-1
 python-secretstorage
E: Sub-process /usr/bin/dpkg returned an error code (1)

William Lee (wlee753159) wrote :

I have recently upgraded from 13.10 to 14.04.1 LTS.
Tell me what version you upgraded from and did anything happen during the upgrade that could have affected the system?
Also have you tried "sudo dpkg --configure -a" (without the quotes)?

William Lee (wlee753159) on 2014-09-30
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
assignee: nobody → William Lee (wlee753159)
juniorsa (gilbert) wrote :

we upgraded from 12.10 LTS to 14.04 LTS

there were no issues.

I have tried dpkg --configure -a
The output is more or less the same see pastebin

http://pastebin.com/JFv4ZjUj

William Lee (wlee753159) wrote :

juniorsa, the pastebin has been removed or is missing. Can you upload it again?

juniorsa (gilbert) wrote :

Here is the pastebin
sorry for the delay

http://pastebin.com/bdA0z0BH

William Lee (wlee753159) wrote :

Your apt-get install not broken. It's the netbase package that's the problem. All of these packages depend on netbase on way or another. There is something wrong with netbase that is causing these problems.
Also, can you actually access the internet on your computer?

William Lee (wlee753159) wrote :

Sorry, I meant just apt-get is not apt-get install.

juniorsa (gilbert) wrote :

Hi William,

Yes I can access the internet fine.

Is there any way for me to manually download a good netbase package and force install it?

This is a production server and I really like to keep all the packages up to date with the latest security fixes.

Thanks,
Gilbert.

William Lee (wlee753159) wrote :

There is a netbase 5.2 source package for trusty downloaded for this link: https://launchpad.net/ubuntu/+archive/primary/+files/netbase_5.2_all.deb
Use sudo dpkg -i /path/to/file.deb

Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → In Progress
William Lee (wlee753159) wrote :

You don't have to use sudo, by the way. You can use something else.

William Lee (wlee753159) on 2014-10-04
affects: ubuntu-release-upgrader (Ubuntu) → netbase (Ubuntu)
juniorsa (gilbert) wrote :

Hi William,

When I try and download the package I get:

root@web2:~# dpkg -i netbase_5.2_all.deb
(Reading database ... 277574 files and directories currently installed.)
Preparing to unpack netbase_5.2_all.deb ...
Unpacking netbase (5.2) over (5.2) ...
Setting up netbase (5.2) ...
Installing new version of config file /etc/services ...
dpkg: error processing package netbase (--install):
 unable to install `/etc/services.dpkg-new' as `/etc/services': Operation not permitted
Errors were encountered while processing:
 netbase

Any suggestions - it seems like /etc/services is locked?

William Lee (wlee753159) wrote :

Hi, Gilbert
Can you post the output of ls -l /etc/services please?
Thank you

William Lee (wlee753159) wrote :

It seems that the file has been locked during the upgrade and the process has not unlocked it for use. Also do apt-get install lslk and use lslk /etc/services to see what processes have locked the file.

William Lee (wlee753159) wrote :

EDIT: Do not do the above. The package is obsolete.
Use fuser -a /etc/services then use ps <PID>, replace <PID> with the process ID that comes up in fuser:
Example:
root@web2:~# fuser -a /etc/services
/etc/services: 4567
root@web2:~# ps 4567
  PID TTY STAT TIME COMMAND
4567 tty1 Ss 0:01 <command>

juniorsa (gilbert) wrote :

joe:~# ls -l /etc/services
-rw-r--r-- 1 root root 19398 May 13 2012 /etc/services

joe:~# fuser -a /etc/services
/etc/services:

fuser doesn't show any processing having that file open :(

William Lee (wlee753159) wrote :

What about doing the commands as the superuser?

juniorsa (gilbert) wrote :

I was superuser when issuing those commands.

William Lee (wlee753159) wrote :

It looks like you do not have full read-write to the file, even on root.

juniorsa (gilbert) wrote :

No where to go from here?

William Lee (wlee753159) wrote :

You could try do it in recovery mode?

William Lee (wlee753159) wrote :

Have you found a solution to the problem yet?

William Lee (wlee753159) on 2015-01-05
Changed in netbase (Ubuntu):
status: In Progress → Incomplete
Christopher (soft-kristal) wrote :

It appears to be a duplicate of https://bugs.launchpad.net/bugs/1397065 but I'm not qualified to make the connection without the maintainer's OK.

William Lee (wlee753159) wrote :

Thanks, Christopher. Unfortuntely, the bug mentioned as duplicate has already been marked as duplicate of this one, therefore I can't make it a duplicate.

Changed in netbase (Ubuntu):
status: Incomplete → Confirmed
affects: netbase (Ubuntu) → dbus (Ubuntu)
Seth Arnold (seth-arnold) wrote :

I'd be very surprised if this report is related to https://bugs.launchpad.net/bugs/1397065 -- it just looks like the same symptoms but not cause. (/etc/services isn't mentioned in the other report, and no upstart service dependency loop is reported here.)

Check dmesg output; there may be additional information there.

Try lsattr /etc/services -- the file may have been set immutable.

Try to move /etc/services out of the way by hand. Not much should care about the contents, so there's no real risk to trying to move a new services file in by hand. If you get errors, try moving other files in /etc/.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers