dbus-daemon consumes 100% cpu without reason

Bug #1230031 reported by Sergio Benjamim on 2013-09-25
150
This bug affects 34 people
Affects Status Importance Assigned to Milestone
dbus (Ubuntu)
Critical
Unassigned

Bug Description

Just login in to session, and dbus-daemon consumes 100% of cpu. Before, I did a login and logout. This problem appears randomly, not all the time.

 9107 sergio 20 0 30376 1660 1356 R 100,1 0,0 11:35.08 dbus-daemon
11692 root 20 0 433m 54m 37m S 1,0 1,4 0:05.46 Xorg
12279 sergio 20 0 1506m 78m 30m S 0,7 2,1 0:05.40 compiz
12417 sergio 20 0 553m 20m 11m S 0,7 0,6 0:00.93 gnome-terminal
13757 sergio 20 0 853m 160m 40m S 0,7 4,2 0:06.83 firefox

See sensors, dbus-daemon is heating up my laptop:

Adapter: Virtual device
temp1: +68.0°C (crit = +98.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0: +69.0°C (high = +84.0°C, crit = +100.0°C)
Core 0: +49.0°C (high = +84.0°C, crit = +100.0°C)
Core 1: +51.0°C (high = +84.0°C, crit = +100.0°C)
Core 2: +69.0°C (high = +84.0°C, crit = +100.0°C)
Core 3: +55.0°C (high = +84.0°C, crit = +100.0°C)

asus-isa-0000
Adapter: ISA adapter
temp1: +6280.0°C

pkg-temp-0-virtual-0
Adapter: Virtual device
temp1: +68.0°C

---

Description: Ubuntu Saucy Salamander (development branch)
Release: 13.10
Linux sergio-X751JB 3.11.0-8-generic #15-Ubuntu SMP Fri Sep 20 04:11:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

dbus:
  Installed: 1.6.12-0ubuntu5
  Candidate: 1.6.12-0ubuntu5
  Version table:
 *** 1.6.12-0ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: dbus 1.6.12-0ubuntu5
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
Uname: Linux 3.11.0-8-generic x86_64
ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
Date: Wed Sep 25 04:31:14 2013
InstallationDate: Installed on 2013-09-20 (4 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130920)
MarkForUpload: True
SourcePackage: dbus
UpgradeStatus: No upgrade log present (probably fresh install)

Sergio Benjamim (sergio-br2) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dbus (Ubuntu):
status: New → Confirmed
Petar Sredojevic (perosredo) wrote :

Same issue - top and dbus-monitor logs attached.

Sergio Benjamim (sergio-br2) wrote :

In Xubuntu does not happen, only in Ubuntu (unity).

Jason Robinson (jaywink) wrote :

This has started to be very annoying, happens sometimes after boot. Solution is to kill dbus-daemon.

Attaching log from ubuntu-bug dbus.

Same problem here. Ubuntu unity 13.10. 100% cpu on startup, fans kick in immediately. Have to kill dbus-deamon to correct. Checking the internet I have seen people complaining about this issue since 2009 on various distributions including Ubuntu and OpenSuse? Hope this Bug gets fixed soon, very nervy!

Changed in dbus (Ubuntu):
importance: Undecided → Critical
Simon Tremblay (tremblaysimon) wrote :

For information, the user was lightdm when dbus-daemon was using 100% of CPU.

James Meek (jimmeek) wrote :

I am having to reboot about once a week due to this bug, because I know of no way to restore normal operation after killing the dbus. Is there any way? This is nearly as bad as the old Windows Blue Screen of Death.

Parag Warudkar (parag-warudkar) wrote :

Here is some hopefully useful info - Perf Report data and gdb stack trace - lightdm user, 100% CPU for dbus-daemon.

Loaded symbols for /lib/x86_64-linux-gnu/libnss_files.so.2
__errno_location () at ../csu/errno-loc.c:26
26 ../csu/errno-loc.c: No such file or directory.
(gdb) bt
#0 __errno_location () at ../csu/errno-loc.c:26
#1 0x000000000043ae88 in _dbus_babysitter_unref (sitter=0x181e640) at ../../dbus/dbus-spawn.c:317
#2 0x00000000004058ab in bus_pending_activation_unref (pending_activation=0x1815700)
    at ../../bus/activation.c:194
#3 0x000000000042d9ee in free_entry_data (table=0x180aec0, table=0x180aec0, entry=0x1815e80,
    entry=0x1815e80) at ../../dbus/dbus-hash.c:445
#4 _dbus_hash_table_unref (table=0x180aec0) at ../../dbus/dbus-hash.c:395
#5 0x0000000000405b8d in bus_activation_unref (activation=0x180c880)
    at ../../bus/activation.c:969
#6 0x00000000004088af in bus_context_unref (context=0x1809160) at ../../bus/bus.c:1086
#7 0x0000000000404503 in main (argc=<optimized out>, argv=<optimized out>)
    at ../../bus/main.c:650

------------------------------------------------------------------------------------------------------------------------------
perf report
---------------
Samples: 67K of event 'cycles', Event count (approx.): 37182799970
 55.43% dbus-daemon dbus-daemon [.] _dbus_babysitter_unref â
 33.54% dbus-daemon libpthread-2.17.so [.] __errno_location â
 10.88% dbus-daemon dbus-daemon [.] __errno_location@plt â

Annotation
-' â", â+" jns 36fca
-' â", â+' callq __errno_location@plt
 20.05 â", mov (%rax),%edi
 39.55 â", mov %rax,%r12
       â", cmp $0x4,%edi
-' â", â+" jne 37000
 20.20 â", test %ebp,%ebp
       â", â+" je 36fa0
-' â", test %ebp,%ebp
 20.20 â", â+" js 36fb3
       â", movl $0xffffffff,0x18(%rbx)

Reuben Thomas (rrt) wrote :

This looks like this bug: https://bugs.freedesktop.org/show_bug.cgi?id=68945 which is fixed in dbus 1.6.14. 1.6.18 is in trusty, so perhaps worth trying the trusty package (as I'm about to).

Nicholas Hinsch (nicholaa) wrote :

Reuben,

Any luck with dbus 1.6.18 on 13.10?

decimus (h-matthias-u) wrote :

To #11 Nicholas, I tried the solution Reuben proposed in #10 and installed the dbus trusty packages on Ubuntu 13.10 saucy. Since then, the problem with high CPU load has not appeared again (about a week now). So it seems to work.

In particular, I installed the following:
dbus_1.6.18-0ubuntu3_amd64.deb
dbus-1-dbg_1.6.18-0ubuntu3_amd64.deb
dbus-1-doc_1.6.18-0ubuntu3_all.deb
dbus-x11_1.6.18-0ubuntu3_amd64.deb
libdbus-1-3_1.6.18-0ubuntu3_amd64.deb
libdbus-1-3_1.6.18-0ubuntu3_i386.deb
libdbus-1-dev_1.6.18-0ubuntu3_amd64.deb

Sydney (sydneygb) wrote :

I've been running Ubuntu 12.04 (with various de's over time) for two years and saw this error happen for the first time today. I'm currently running Gnome Shell 3.4.1, but I haven't removed Unity. My Xubuntu 12.04 with xfce 4.8 has not shown this behaviour to date.

Tomofumi (tomofumi) wrote :

Hi all,

I've been suffering from this bug from time to time in 12.04 LTS, and today I finally found out the culprit that cause the high cpu% in my case. According to "strace -p" dump of the dbus-daemon, the problem seems related to the org.kde.nepomuk.* service:

recvmsg(111, 0xbfd5b658, MSG_CMSG_CLOEXEC) = -1 EAGAIN (Resource temporarily unavailable)
sendmsg(111, {msg_name(0)=NULL, msg_iov(2)=[{"l\3\1\1J\0\0\0\203\243\353\6u\0\0\0\6\1s\0\6\0\0\0:1.175\0\0\4\1s\0)\0\0\0org.freedesktop.DBus.Error.LimitsExceeded\0\0\0\0\0\0\0\5\1u\0\333f\354\6\10\1g\0\1s\0\0\7\1s\0\24\0\0\0org.freedesktop.DBus\0\0\0\0", 136}, {"E\0\0\0The maximum number of pending replies per connection has been reached\0", 74}], msg_controllen=0, msg_flags=0}, MSG_NOSIGNAL) = 210
clock_gettime(CLOCK_MONOTONIC, {2505630, 149771846}) = 0
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=6, events=POLLIN}, {fd=8, events=POLLIN}, {fd=9, events=POLLIN}, ...(skip)...{fd=13, events=POLLIN}, {fd=132, events=POLLIN}, {fd=14, events=POLLIN}, {fd=21, events=POLLIN}, {fd=23, events=POLLIN}, {fd=141, events=POLLIN}], 141, -1) = 1 ([{fd=111, revents=POLLIN}])
clock_gettime(CLOCK_MONOTONIC, {2505630, 150552531}) = 0
recvmsg(111, {msg_name(0)=NULL, msg_iov(1)=[{"l\1\0\0010\0\0\0\334f\354\6\177\0\0\0\1\1o\0\25\0\0\0/org/freedesktop/DBus\0\0\0\6\1s\0\24\0\0\0org.freedesktop.DBus\0\0\0\0\2\1s\0\24\0\0\0org.freedesktop.DBus\0\0\0\0\3\1s\0\f\0\0\0GetNameOwner\0\0\0\0\10\1g\0\1s\0\0+\0\0\0org.kde.nepomuk.services.nepomukfileindexer\0\0\0.nepomukstorage',path='/servicecontrol',interface='org.kde.nepomuk.ServiceControl',member='serviceInitialized'\0\0\0\0\0\0(...skip...)\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 2048}], msg_controllen=0, msg_flags=MSG_CMSG_CLOEXEC}, MSG_CMSG_CLOEXEC) = 192

$ ps -ef | grep nepom
user 16909 26479 0 10:50 pts/0 00:00:00 grep --color=auto nepom
user 19923 19879 0 Jan05 ? 00:00:00 /usr/bin/akonadi_nepomuk_feeder --identifier akonadi_nepomuk_feeder
user 19950 1 1 Jan05 ? 05:08:31 /usr/bin/nepomukserver
user 19954 19950 0 Jan05 ? 00:00:02 /usr/bin/nepomukservicestub nepomukstorage
user 19968 19950 0 Jan05 ? 00:00:01 /usr/bin/nepomukservicestub nepomukfilewatch
user 19969 19950 0 Jan05 ? 00:00:00 /usr/bin/nepomukservicestub nepomukbackupsync
user 19970 19950 0 Jan05 ? 00:00:00 /usr/bin/nepomukservicestub nepomukfileindexer
user 19971 19950 0 Jan05 ? 00:00:00 /usr/bin/nepomukservicestub nepomukqueryservice

So i tried to stop kde programs, and attempt to restart this nepomukserver, I've tried to kill by pid, it does not respond. So I tried to "kill -HUP", it starts restart itself and the 100% cpu goes away now.

Hope this helps someone with the similar problem as me.

Yo (yleduc) wrote :

Hi
Have you tried using the d-feet Install d-feet tool?

Richard (rlettich) wrote :

I'm not sure if this bug is the same, but I have cpu use of 50-90%. It says dbus is only using ~15% though, but it is the top task. It is also forking alot.

To reproduce, I dont know the repo's, but I installed

 sudo apt-get install elementary-theme elementary-icon-theme elementary-default-settings elementary-desktop

and purging those packages caused this to happen. reinstalling those packages "fixes" it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.