Update to 1.6.4

Bug #1014850 reported by Robert Ancell on 2012-06-18
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Neil J. Patel
dbus (Ubuntu)
Wishlist
Sebastien Bacher
unity (Ubuntu)
High
Unassigned

Bug Description

or 1.5 first.

Related branches

Robert Ancell (robert-ancell) wrote :

Pitti, I believe you are working on this? Opening this bug so there's a note on the versions page.

Changed in dbus (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

https://launchpad.net/~pitti/+archive/ppa has a D-BUS 1.5.12 merge with Debian. It's mostly working fine, but it makes some indicators disappear (or at least did so a few weeks ago when I tried it). Can you guys coordinate with DX the fixing of the indicators?

Changed in dbus (Ubuntu):
assignee: Martin Pitt (pitti) → Robert Ancell (robert-ancell)
Changed in dbus (Ubuntu):
assignee: Robert Ancell (robert-ancell) → Ubuntu Desktop (ubuntu-desktop)
weiqiu (qiuwei1987) wrote :

For dbus 1.6.0, the global menu doesn't work either.

Thomas Bechtold (toabctl) wrote :

i tried dbus-1.6.2 from debian (but without systemd build-dep and with debian/dbus.upstart). indicators and global menu are still broken. the ppa with 1.6.2 is here: https://launchpad.net/~toabctl/+archive/testing

Iain Lane (laney) wrote :

Here's a 'proper' merge (with disabled upstart-activation patches)

  https://launchpad.net/~laney/+archive/experimental/+packages

which also has the noted effects. I'll see about getting DX to look at it.

Iain Lane (laney) wrote :

seb128 found that http://cgit.freedesktop.org/dbus/dbus/commit/?id=a940e7b1d1b6b832e2ec732a11f495240156fb31 was the commit which broke it. We'll probably revert that for now and get the proper fix (likely in Unity) ASAP.

summary: - Update to 1.6.0
+ Update to 1.6.4
Changed in dbus (Ubuntu):
assignee: Ubuntu Desktop (ubuntu-desktop) → Iain Lane (laney)
Sebastien Bacher (seb128) wrote :

Neil said he would have a look to the unity-panel-service issues, something there seems to be confused by the eavesdropping limitations

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
Logan Rosen (logan) on 2012-07-25
tags: added: upgrade-software-version
Changed in unity:
importance: Undecided → High
tags: removed: desktop-upgrade
Changed in unity:
status: New → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
importance: Undecided → High
Changed in dbus (Ubuntu):
status: Triaged → In Progress
assignee: Iain Lane (laney) → Sebastien Bacher (seb128)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.0.0-0ubuntu6

---------------
unity (6.0.0-0ubuntu6) quantal; urgency=low

  * Don't specify a specific destination for the dbus signals, that
    creates issues with the new dbus eavedropping behaviour,
    thanks Neil J. Patel for the fix! Required for the new dbus version.
    (lp: #1014850)
 -- Sebastien Bacher <email address hidden> Thu, 02 Aug 2012 16:35:04 +0200

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in dbus (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.6 KiB)

This bug was fixed in the package dbus - 1.6.4-1ubuntu1

---------------
dbus (1.6.4-1ubuntu1) quantal-proposed; urgency=low

  * Upload to quantal (lp: #1014850)
  * debian/control:
    - use "Breaks: unity-services (<< 6.0.0-0ubuntu6)", the new dbus
      eavedropping protection was creating issues with previous versions

  [ Iain Lane ]
  * Merge with Debian experimental for the new stable series. Remaining Ubuntu
    changes:
    - Install binaries into / rather than /usr:
      + debian/rules: Set --exec-prefix=/
      + debian/dbus.install, debian/dbus-x11.install: Install from /bin
    - Use upstart to start:
      + Add debian/dbus.upstart.
      + debian/control: Add upstart dependency.
      + debian/dbus.postinst: Use upstart call instead of invoking the init.d
        script for checking if we are already running.
      + debian/control: versioned dependency on netbase that emits the new
        deconfiguring-networking event used in upstart script.
    - 20_system_conf_limit.patch: Increase max_match_rules_per_connection for
      the system bus to 5000 (LP #454093)
    - 81-session.conf-timeout.patch: Raise the service startup timeout from 25
      to 60 seconds. It may be too short on the live CD with slow machines.
    - Add 0001-activation-allow-for-more-variation-than-just-system.patch,
      0002-bus-change-systemd-activation-to-activation-systemd.patch,
      0003-upstart-add-upstart-as-a-possible-activation-type.patch,
      0004-upstart-add-UpstartJob-to-service-desktop-files.patch,
      0005-activation-implement-upstart-activation.patch: Patches from Scott
      James Remnant to implement Upstart service activation. Not upstream.
      Disable patches since they do not apply and this facility is unused
      anyway.
  * Remove systemd BDs; not appropriate for Ubuntu.

dbus (1.6.4-1) experimental; urgency=low

  * gbp.conf: switch to experimental branch
  * New upstream stable release
    - remove incorrect assertion and have correct default for developer mode
      (Closes: #680027, differently)

dbus (1.6.2-2) unstable; urgency=low

  * Disable "developer mode", which was intended to be off-by-default,
    but was incorrectly on-by-default in 1.6.2, causing an incorrect
    assertion to be hit when starting fcitx before dbus-launch.
    (Closes: #680027)

dbus (1.6.2-1) unstable; urgency=low

  * New upstream stable release
    - dbus-launch --exit-with-session no longer monitors its stdin if
      run under X11 (Closes: #453755)
  * Remove the workaround for #453755 from dbus-Xsession

dbus (1.6.0-1) unstable; urgency=low

  * Merge from "experimental" (1.5.12 was accidentally uploaded to unstable)
  * New upstream stable release
  * debian/watch: only match stable (0.even.x) releases

dbus (1.5.12-1) unstable; urgency=low

  * Merge from unstable
  * New upstream release
    - adds new API
  * Standards-Version: 3.9.3 (no changes)
  * Remove lintian override for #629648, hopefully the ftpmasters are using
    lintian 2.5.1 by now
  * Add lintian overrides for the empty directories we (intentionally) ship
  * Don't run dh_makeshlibs on dbus-1-dbg, nothing should be linking to its
    extra-debug-enabled build of the ...

Read more...

Changed in dbus (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Changed in unity:
milestone: none → 6.2
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers