Oneiric shutdown : Tomboy not responding

Bug #816950 reported by Xavier Guillot on 2011-07-27
236
This bug affects 50 people
Affects Status Importance Assigned to Milestone
tomboy
Unknown
Medium
dbus-sharp (Ubuntu)
High
Chris Halse Rogers
Oneiric
High
Chris Halse Rogers

Bug Description

On Ubuntu Oneiric alpha 64, updated, and last version of Tomboy 1.7, when I want to shutdown my computer, I get an error message :

A program is still running

Tomboy Notes
Not responding

Each time I try. If I click on "Shutdown anyway", computer closes and I have not lost notes for the moment.

If I quit Tomboy before closing computer, no error message.

Related branches

Xavier Guillot (valeryan-24) wrote :
Changed in tomboy (Ubuntu):
status: New → Confirmed
Xavier Guillot (valeryan-24) wrote :

Bug also occurs when I want to disconnect and is still present in Oneiric alpha 3 for the moment.

Changed in tomboy (Ubuntu):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

Somebody should send the bug upstream, that's new since this unstable serie, 1.6 didn't have that issue

Jeff Licquia (jeff-licquia) wrote :

Tomboy does this on natty for me, with one difference: if you just wait, it goes away on its own after a very short wait (a few seconds). On oneiric, I've waited for several minutes for it to close on its own, with no luck.

ngsupb (ngsupb) wrote :

all is up. the same bug.

Julian Taylor (jtaylor) on 2011-08-23
Changed in tomboy:
importance: Undecided → Unknown
status: New → Unknown
Changed in tomboy:
importance: Unknown → Medium
status: Unknown → New
Changed in tomboy (Ubuntu Oneiric):
status: Confirmed → Triaged
Changed in tomboy (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: rls-mgr-o-tracking
Jay A. Babcock (newyorkcityjay) wrote :

it happened in 32-bit as well

Jamie Strandboge (jdstrand) wrote :

FYI, looking at the upstream bug, it seems no one cares.

Sebastien Bacher (seb128) wrote :

Rodrigo pinged them on IRC this week but I'm not sure how active their team is...

pablomme (pablomme) wrote :

Tomboy remains responsive and can be shut down by hand in the indicator, which means (if I interpret this fact correctly) that the end-session signal is either not being received or not being acted upon. Having a look at the source (Tomboy/GnomeApplication.cs:{147,164}) it looks like the debug output should indicate whether the query-end-session and end-session signals are being received.

I've attached the stdout/err from 'tomboy --debug' when I reboot the machine. There should be an "[INFO]" entry saying that the query-end session signal has been received, but that does not appear in the log. It is possible that the problem lies outside of tomboy, or that tomboy needs a refresh regarding session handling (possibly due to the switch to gtk3? tomboy links against gtk2 - is the end-session signal passed correctly to gtk2 apps?).

By the way, this bug is also present with gnome-shell, so the culprit is common to unity & shell sessions.

Evan Broder (broder) wrote :

If you run with DBUS_VERBOSE=1, you can see that the DBus bindings are receiving the QueryEndSignal, but it's not getting passed onto tomboy's handler:

evan@caron:~$ DBUS_VERBOSE=1 tomboy
Warning: WriteBsdCred() failed; falling back to ordinary WriteCred()
Warning: WriteBsdCred() failed; falling back to ordinary WriteCred()
Warning: No signal handler for NameAcquired
Warning: No signal handler for NameAcquired
[INFO 11:52:53.993] Initializing Mono.Addins
Warning: No signal handler for NameAcquired
Warning: No signal handler for QueryEndSession
Warning: No signal handler for CancelEndSession

Sebastien Bacher (seb128) wrote :

Evan, could you add those comments to the upstream bug?

Chris Halse Rogers (raof) wrote :

This is actually a bug in dbus-sharp, not Tomboy. dbus-sharp was failing to pass the signals on to the subscribers, which was why Tomboy wasn't receiving it. This looks to be fixed in dbus-sharp trunk, in two nicely cherry-pickable commits. I'll do that now :)

affects: tomboy (Ubuntu Oneiric) → dbus-sharp (Ubuntu Oneiric)
Martin Pitt (pitti) on 2011-10-04
Changed in dbus-sharp (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Chris Halse Rogers (raof)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dbus-sharp - 0.7.0-3ubuntu1

---------------
dbus-sharp (0.7.0-3ubuntu1) oneiric; urgency=low

  * Cherry-pick 608328b and 76f43e6c from upstream trunk. Fixes broken signal
    dispatch. (LP: #816950)
 -- Christopher James Halse Rogers <email address hidden> Tue, 04 Oct 2011 16:18:08 +1100

Changed in dbus-sharp (Ubuntu Oneiric):
status: Triaged → Fix Released
Changed in tomboy:
status: New → Unknown
snowguy (snowguy) wrote :

I see that this was fixed on 10-4. am I reading this right? If so, the fix didn't take. I am still seeing this bug. At least I think it is the same bug. My behavior exactly matches what another user describes at http://askubuntu.com/questions/68006/how-to-fix-desktop-reloading-during-logout-shutdown-restart-after-upgrading-to-1

Colin Law (colin-law) wrote :

@snowguy, think that if you are not seeing the Not Responding message but are just seeing a delay on logout then you are seeing a different bug. I have started a new bug for the delay issue bug #880299, if this looks like your problem then please add yourself to the affected list.

snowguy (snowguy) wrote :

Thanks Colin. Agree, I do not see the "not responding" message.

Sebastien Bacher (seb128) wrote :

while this bug is fixed there are still some issue, see bug #880299 where users claim that tomboy block the session closing for 30s

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.