package python-dbus 1.2.0-3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1677503 reported by Adnan Iftekhar on 2017-03-30
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
dbus-python (Ubuntu)
Undecided
Unassigned

Bug Description

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  attr dh-translations dia-libs gfortran gfortran-5 gnome-control-center-data
  gnome-icon-theme gnome-icon-theme-symbolic gnome-settings-daemon
  iio-sensor-proxy intltool launchpad-getkeys libblas-dev libbz2-dev
  libcairo-script-interpreter2 libcolord-gtk1 libdbus-1-dev libegl1-mesa-dev
  libepoxy-dev libfontconfig1-dev libfreetype6-dev libgfortran-5-dev
  libgmp-dev libgmpxx4ldbl libharfbuzz-dev libharfbuzz-gobject0 libice-dev
  libjavascriptcoregtk-3.0-0 libjpeg-dev libjpeg-turbo8-dev libjpeg8-dev
  liblapack-dev liblzma-dev libmirclient-dev libmircommon-dev libmircookie-dev
  libmircookie2 libncurses5-dev libpixman-1-dev libpng12-dev libprotobuf-dev
  libpython-all-dev libpython-dev libpython2.7-dev libreadline-dev
  libreadline6-dev libsm-dev libtinfo-dev libwayland-dev libwbclient0
  libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libxcb-shm0-dev libxcomposite-dev
  libxcursor-dev libxft-dev libxi-dev libxinerama-dev libxkbcommon-dev
  libxrandr-dev libxrender-dev libxtst-dev nettle-dev planner-data planner-doc
  ppa-purge samba-common scrollkeeper tdb-tools x11proto-composite-dev
  x11proto-randr-dev x11proto-record-dev x11proto-render-dev
  x11proto-xinerama-dev xclip yad
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  python python-gobject python-pyodbc python2.7
Suggested packages:
  python-doc python-tk python2.7-doc
The following NEW packages will be installed:
  python python-gobject python-pyodbc python2.7
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
31 not fully installed or removed.
Need to get 408 kB of archives.
After this operation, 1,174 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 python2.7 amd64 2.7.12-1ubuntu0~16.04.1 [224 kB]
Get:2 http://archive.ubuntu.com/ubuntu xenial/main amd64 python amd64 2.7.11-1 [137 kB]
Get:3 http://archive.ubuntu.com/ubuntu xenial/universe amd64 python-gobject all 3.20.0-0ubuntu1 [2,544 B]
Get:4 http://archive.ubuntu.com/ubuntu xenial/universe amd64 python-pyodbc amd64 3.0.7-0ubuntu2 [44.4 kB]
Fetched 408 kB in 18s (21.6 kB/s)
Selecting previously unselected package python2.7.
(Reading database ... 287768 files and directories currently installed.)
Preparing to unpack .../python2.7_2.7.12-1ubuntu0~16.04.1_amd64.deb ...
Unpacking python2.7 (2.7.12-1ubuntu0~16.04.1) ...
Selecting previously unselected package python.
Preparing to unpack .../python_2.7.11-1_amd64.deb ...
Unpacking python (2.7.11-1) ...
Selecting previously unselected package python-gobject.
Preparing to unpack .../python-gobject_3.20.0-0ubuntu1_all.deb ...
Unpacking python-gobject (3.20.0-0ubuntu1) ...
Selecting previously unselected package python-pyodbc.
Preparing to unpack .../python-pyodbc_3.0.7-0ubuntu2_amd64.deb ...
Unpacking python-pyodbc (3.0.7-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for doc-base (0.10.7) ...
Processing 1 added doc-base file...
Registering documents with scrollkeeper...
Setting up python2.7 (2.7.12-1ubuntu0~16.04.1) ...
Setting up python (2.7.11-1) ...
Setting up python-dbus (1.2.0-3) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-dbus (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up python-gobject-2 (2.28.6-12ubuntu1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-gobject-2 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up python-gi (3.20.0-0ubuntu1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-gi (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python-gobject:
 python-gobject depends on python-gi (>= 3.20.0-0ubuntu1); however:
  Package python-gi is not configured yet.
 python-gobject depends on python-gobject-2; however:
  Package python-gobject-2 is not configured yet.

dpkg: error processing package python-gobject (--configure):
 dependency problems - leaving unconfigured
Setting up python-cairo (1.8.8-2) ...
No apport report written because MaxReports is reached already
                                                              Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-cairo (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of python-gtk2:
 python-gtk2 depends on python-cairo (>= 1.0.2-1.1); however:
  Package python-cairo is not configured yet.
 python-gtk2 depends on python-gobject-2 (>= 2.21.3); however:
  Package python-gobject-2 is not configured yet.

dpkg: error processing package python-gtk2 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Setting up python-libxml2 (2.9.3+dfsg1-1ubuntu0.2) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-libxml2 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of font-manager:
 font-manager depends on python-dbus; however:
  Package python-dbus is not configured yet.
 font-manager depends on python-gobject; however:
  Package python-gobject is not configured yet.
 font-manager depends on python-gtk2; however:
  Package python-gtk2 is not configured yet.
 font-manager depends on python-libxml2; however:
  Package python-libxml2 is not configured yet.

dpkg: error processing package font-manager (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                            dpkg: dependency problems prevent configuration of gimp:
 gimp depends on python-gtk2 (>= 2.8.0); however:
  Package python-gtk2 is not configured yet.

dpkg: error processing package gimp (--configure):
 dependency problems - leaving unconfigured
Setting up libglib2.0-dev (2.48.2-0ubuntu1) ...
No apport report written because MaxReports is reached already
                                                              Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package libglib2.0-dev (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Setting up python-mysql.connector (2.0.4-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-mysql.connector (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of mysql-utilities:
 mysql-utilities depends on python-mysql.connector (>= 1.2.1); however:
  Package python-mysql.connector is not configured yet.

dpkg: error processing package mysql-utilities (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Setting up python-crypto (2.6.1-6ubuntu0.16.04.2) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-crypto (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Setting up python-six (1.10.0-3) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-six (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of python-ecdsa:
 python-ecdsa depends on python-six (>= 1.2); however:
  Package python-six is not configured yet.

dpkg: error processing package python-ecdsa (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of python-paramiko:
 python-paramiko depends on python-crypto (>= 2.1.0-2); however:
  Package python-crypto is not configured yet.
 python-paramiko depends on python-ecdsa; however:
  Package python-ecdsa is not configured yet.

dpkg: error processing package python-paramiko (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Setting up python-ptyprocess (0.5-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-ptyprocess (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of python-pexpect:
 python-pexpect depends on python-ptyprocess; however:
  Package python-ptyprocess is not configured yet.

dpkg: error processing package python-pexpect (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Setting up python-pyodbc (3.0.7-0ubuntu2) ...
Setting up python-pysqlite2 (2.7.0-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-pysqlite2 (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of mysql-workbench:
 mysql-workbench depends on python-mysql.connector; however:
  Package python-mysql.connector is not configured yet.
 mysql-workbench depends on python-paramiko; however:
  Package python-paramiko is not configured yet.
 mysql-workbench depends on python-pexpect; however:
  Package python-pexpect is not configured yet.
 mysql-workbench depends on python-pysqlite2; however:
  Package python-pysqlite2 is not configured yet.

dpkg: error processing package mysql-workbench (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-appindicator:
 python-appindicator depends on python-gobject; however:
  Package python-gobject is not configured yet.

No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                            dpkg: error processing package python-appindicator (--configure):
 dependency problems - leaving unconfigured
Setting up python-apt (1.1.0~beta1build1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-apt (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Setting up python-dnspython (1.12.0-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-dnspython (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Setting up python-ldb (2:1.1.24-1ubuntu3) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-ldb (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Setting up python-pip (8.1.1-2ubuntu0.4) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-pip (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Setting up python-pkg-resources (20.7.0-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-pkg-resources (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of python-scour:
 python-scour depends on python-six (>= 1.9.0); however:
  Package python-six is not configured yet.
 python-scour depends on python-pkg-resources; however:
  Package python-pkg-resources is not configured yet.

dpkg: error processing package python-scour (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-setuptools:
 python-setuptools depends on python-pkg-resources (= 20.7.0-1); however:
  Package python-pkg-resources is not configured yet.

dpkg: error processing package python-setuptools (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                            Setting up python-sip (4.17+dfsg-1build1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-sip (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Setting up python-tdb (1.3.8-2) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-tdb (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Setting up python-wheel (0.29.0-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-wheel (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of qtiplot:
 qtiplot depends on sip-api-11.2; however:
  Package sip-api-11.2 is not installed.
  Package python-sip which provides sip-api-11.2 is not configured yet.

dpkg: error processing package qtiplot (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Processing triggers for libc-bin (2.23-0ubuntu7) ...
Errors were encountered while processing:
 python-dbus
 python-gobject-2
 python-gi
 python-gobject
 python-cairo
 python-gtk2
 python-libxml2
 font-manager
 gimp
 libglib2.0-dev
 python-mysql.connector
 mysql-utilities
 python-crypto
 python-six
 python-ecdsa
 python-paramiko
 python-ptyprocess
 python-pexpect
 python-pysqlite2
 mysql-workbench
 python-appindicator
 python-apt
 python-dnspython
 python-ldb
 python-pip
 python-pkg-resources
 python-scour
 python-setuptools
 python-sip
 python-tdb
 python-wheel
 qtiplot
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: python-dbus 1.2.0-3
Uname: Linux 4.10.4 x86_64
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
Date: Thu Mar 30 12:47:40 2017
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2016-11-02 (148 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.19
SourcePackage: dbus-python
Title: package python-dbus 1.2.0-3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Adnan Iftekhar (livenicely) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dbus-python (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers