Classpath problem in libdbus-java package

Bug #663277 reported by Michael Haggerty on 2010-10-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dbus-java (Debian)
Fix Released
Unknown
dbus-java (Ubuntu)
Undecided
Unassigned

Bug Description

Using libdbus-java version 2.7-1 and openjdk-6-jdk version 6b18-1.8.1-0ubuntu1 under lucid (10.04.1):

$ echo 'public class Foo {}' >Foo.java
$ /usr/lib/jvm/java-6-openjdk/bin/javac -Xlint:path -classpath /usr/share/java/dbus.jar Foo.java
warning: [path] bad path element "/usr/share/java/usr/share/java/unix.jar": no such file or directory
warning: [path] bad path element "/usr/share/java/usr/share/java/hexdump.jar": no such file or directory
2 warnings

The two warnings indicate a problem. (I haven't noticed that the functionality of the library is affected.)

Clearly the path elements listed are incorrect. It appears that the problem is in dbus.jar, because if that jar file is left out of the classpath then the warning goes away.

Related branches

Michael Haggerty (mhagger) wrote :

The problem is apparently that the rules file adds some jar dependencies to the package's Class-Path using absolute paths, whereas (e.g., according to http://java.sun.com/developer/Books/javaprogramming/JAR/basics/manifest.html#download) the paths should be relative. I have attached a patch to fix the problem.

tags: added: patch
Marc Deslauriers (mdeslaur) wrote :

Thanks for reporting this issue and adding a patch. The best way for us to fix this in Ubuntu would be to fix this issue in the upstream Debian package, and sync it from Debian. Could you please file a bug in Debian's bug tracker for this package and link the bug here? (Use http://www.debian.org/Bugs/)

Thanks!

Michael Haggerty (mhagger) wrote :
Martin Pitt (pitti) wrote :

Thanks! Sponsored.

Changed in dbus-java (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dbus-java - 2.8-1ubuntu1

---------------
dbus-java (2.8-1ubuntu1) natty; urgency=low

  * debian/rules: Use relative paths for the .jar dependencies. (LP: #663277)
 -- Michael Haggerty <email address hidden> Wed, 30 Mar 2011 12:48:02 +0200

Changed in dbus-java (Ubuntu):
status: Fix Committed → Fix Released
Changed in dbus-java (Debian):
status: Unknown → New
Changed in dbus-java (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.