[MIR] b-d for libffado

Bug #730759 reported by Matthias Klose on 2011-03-07
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dbus-c++ (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

introduced with sync, needs a MIR

Related branches

Matthias Klose (doko) on 2011-03-07
Changed in dbus-c++ (Ubuntu Natty):
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-1
status: New → Confirmed
Matthias Klose (doko) wrote :

- code was already in main as an internal copy in a superseded version of the libffado package.

- again, it's an old snapshot, and maybe could use an update after natty.

Michael Terry (mterry) wrote :

Some nitpicks:
 * Would be nice to see an Ubuntu bug subscriber
 * Patch 02_host_name_max.diff injects GPL-3+ code into an LGPL-2.1 example program. Which is legal [1], but requires the program to be conveyed as GPL-3+, which the patch does not actually do. This is an exceedingly minor point, since the example program isn't even distributed.

Major issues:
 * It's orphaned in Debian, what's the maintenance story here?
 * There's no symbols file for the library

So rejecting for now.

[1] http://www.gnu.org/licenses/gpl-faq.html#AllCompatibility

Changed in dbus-c++ (Ubuntu Natty):
status: Confirmed → Incomplete
holstein (mikeholstein) wrote :

i have just became aware of this issue, and have subscribed to the reports.. demoting this package is not really an option for ubuntustudio... this would mean that out of the box, JACK would not have firewire support... i will continue to do what i can to help resolve this issue in a timely manner.. thanks

Having checked Debian and Ubuntu, there are only 2 packages using dbus-c++, libffado included. Since libffado is likely going to be the more actively developed package, I will contact the debian pkg-multimedia team about possibly taking over maintainership in Debian. I see it in their best interest, as libffado now depends on it, so think they will concent to take over maintainership. Once maintainership is settled regardless of who takes over, I will see about correcting the GPL issue raised in point 2 above. If the MIR reviewers feel its major enough to address now, then I can do so and upload a new revision.

As for the rest, I am happy to subscribe ubuntu-audio to this package's bugmail, since libffado is the only package in main requiring this library. I've also uploaded a new package revision with a symbols file included.

 affects ubuntu/dbus-c++
 status new

Luke Yelavich (themuso) on 2011-03-18
Changed in dbus-c++ (Ubuntu Natty):
status: Incomplete → New
Matthias Klose (doko) wrote :
Changed in dbus-c++ (Ubuntu Natty):
status: New → Incomplete
Luke Yelavich (themuso) wrote :

Ok, the package now has symbols for all arches.

Changed in dbus-c++ (Ubuntu Natty):
status: Incomplete → New
Michael Terry (mterry) wrote :

Luke, no need to do a special upload for the GPL thing. Like I said, we don't even distribute that example program.

The symbols seem fine now (though there is a bit of #MISSING cruft). So the only remaining issue is maintenance in Debian.

Luke Yelavich (themuso) wrote :

The pkg-multimedia team do not want to take over maintainership of dbus-c++, however I have been offered help to keep it maintained in Debian, in terms of mentoring etc. I was hoping that a discussion would have sprung up around the dependency on an unmaintained package, particularly one that hasn't actually got a stable API upstream yet...

I am wondering if in the short term, I should patch the dbus-c++ code back in, and deal with maintenance more thoroughly in the next cycle.

Michael Terry (mterry) wrote :

So, moving dbus-c++ back to be bundled seems like a sleight of hand. The problem here is that we have an unmaintained chunk of code in main. It seems bad to approve it just because it happened to be there before and we just didn't know it was unmaintained.

Could ubuntu-audio maintain it in Ubuntu?

Daniel T Chen (crimsun) wrote :

I'm willing to spend some time post-mid-May on it as part of ~ubuntu-audio-dev.

Matthias Klose (doko) wrote :

this sounds promising. now Debian has an update, so I would suggest merging this for natty (checked that it builds in natty, and that libffado builds with the new version). Then maintenance can start with the updated version.

subscribing ubuntu-release for the FFe for the new upstream version.

Martin Pitt (pitti) wrote :

Looking at the changes at http://gitorious.org/dbus-cplusplus/mainline/commits/master, these are mostly bug fixes, and look appropriate for natty at this point, approved. Please do test this new version against libffado, though.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dbus-c++ - 0~20110310-1ubuntu1

---------------
dbus-c++ (0~20110310-1ubuntu1) natty; urgency=low

  * Merge with Debian (LP: #730759). Remaining changes:
    - Add symbols files.

dbus-c++ (0~20110310-1) unstable; urgency=low

  * QA upload.
  * Change maintainer field in debian/control to: Debian QA Group
    <email address hidden>.
  * New upstream snapshot.
  * Drop patches/01_gcc44.diff: patch applied upstream.
  * Add patch to fix FTBFS with binutils-gold, thanks to Ilya Barygin.
    (Closes: #554301)
  * Update Standards version from 3.7.3 to 3.9.1 (no changes needed).
  * Switch to 3.0 (quilt) source package format and original tar.bz2 tarballs.
  * Update copyright file.
  * Add README.source with information about upstream's git repository.
  * Improve package descriptions and update website URL.
 -- Matthias Klose <email address hidden> Mon, 28 Mar 2011 17:09:48 +0200

Changed in dbus-c++ (Ubuntu Natty):
status: New → Fix Released
Martin Pitt (pitti) wrote :

Reopening, as the package upload doesn't settle the MIR promotion/approval.

Changed in dbus-c++ (Ubuntu Natty):
status: Fix Released → New
Matthias Klose (doko) wrote :

promoted

Changed in dbus-c++ (Ubuntu Natty):
status: New → Fix Released
Vincent Cheng (vincent-c) wrote :

Hi,

Since a package I regularly use (gnote) depends on dbus-c++, I'd be interested in maintaining it (or co-maintaining it, even). I'm also open to the possibility of adopting the package upstream in Debian, but my sponsor suggested that I start off with a QA upload instead; this was my first package upload to Debian, and I'm still relatively new to the process of adopting/maintaining packages. Nevertheless, if there are any patches or fixes you would like to see applied to the dbus-c++ package upstream in Debian, I can package it and upload it (with the help of my sponsor, of course).

Michael Terry (mterry) wrote :

Awesome, thanks Vincent. Presumably we'll file bugs and patches in Debian directly, but to catch anything that falls through the cracks, you're welcome to subscribe to the package's bugs in Ubuntu: https://launchpad.net/ubuntu/+source/dbus-c++/+subscribe

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers