system wide options result in inconsistent user experience

Bug #746700 reported by Michael R. Crusoe on 2011-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
davfs2
Fix Released
Undecided
Unassigned
davfs2 (Debian)
Fix Released
Unknown
davfs2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: davfs2

If the sysadmin set system wide options in /etc/davfs2/davfs2.conf and she allows for unprivileged users to mount WebDAV resources then they will experience inconsistent results.

Example:

sysadmin@host:~$ echo "davfs2 davfs2/suid_file boolean true" | sudo debconf-set-selections --
sysadmin@host:~$ sudo dpkg-reconfigure davfs2
sysadmin@host:~$ sudo sh -c 'echo "http://webdav.cyberteams.com:8080/ /mnt davfs noauto,user 0 0" > /etc/fstab'

user@host:~$ mount /mnt
Please enter the username to authenticate with server
http://webdav.cyberteams.com:8080 or hit enter for none.
  Username: guest
Please enter the password to authenticate user guest with server
http://webdav.cyberteams.com:8080 or hit enter for none.
  Password: guest
user@host:~$ ls /mnt
aaa
[snip]
user@host:~$ umount /mnt
/sbin/umount.davfs: waiting while mount.davfs (pid 13147) synchronizes the cache .
user@host:~$ mount /mnt
/sbin/mount.davfs:/home/user/.davfs2/davfs2.conf:24: unknown option
user@host:~$ ls /mnt
user@host:~$

This happens because /etc/davfs2/davfs2.conf is copied to ~/.davfs/ if ~/.davfs2 doesn't exist when mount.davfs2 is called.
Due to LP: 459998 Ubuntu needs to include a system option in /etc/davfs2/davfs2.conf

Fix: Warn instead of exiting when system options are in the users configuration and vice-versa

Related branches

Michael R. Crusoe (misterc) wrote :

New behavior:

user@host:~$ mount /mnt
/sbin/mount.davfs:/home/user/.davfs2/davfs2.conf:24: system option in user configuration file
user@host:~$ ls /mnt
aaa
[snip]

description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package davfs2 - 1.4.6-1ubuntu3

---------------
davfs2 (1.4.6-1ubuntu3) natty; urgency=low

  * Warn on misplaced configuration options, don't exit (LP: #746700)
  * Add kernoops to ignore_home to allow mounts under / in Ubuntu.
    (LP: #459998)
  * Add distccd to ignore_home to allow mount under / in Debian & Ubuntu.
 -- <email address hidden> (Michael R. Crusoe) Fri, 01 Apr 2011 12:20:43 +0200

Changed in davfs2 (Ubuntu):
status: New → Fix Released
Michael R. Crusoe (misterc) wrote :
Changed in davfs2:
status: New → Fix Committed
Michael R. Crusoe (misterc) wrote :

Note that this is a different approach that fixed this and lp: #459998. It still needs packaging.

Changed in davfs2 (Debian):
status: Unknown → Confirmed
Changed in davfs2 (Debian):
status: Confirmed → Fix Released
Changed in davfs2:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.