Can't write via davfs2

Bug #466960 reported by marcus.arminius on 2009-10-31
86
This bug affects 16 people
Affects Status Importance Assigned to Milestone
davfs2 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: davfs2

Release is Kubuntu 9.10 (amd64). Package version of davfs2 is 1.4.1-1 (amd64)

I can't write files on my internet disk (provider of the internet disk is GMX Mediacenter). Via webdav writing is no problem. But if I mount it to my file system, writing is not possible. Reading is possible, Even creating folders or deleting files is no problem.

The problem also arises, if I try to write files with root priviliges.

If I try to write a file via shell, I'm told that the file cannot be written on the target disk. Reason: "File exists" (although there is no file there).

The problem doesn't arise, when I try the same with Kubuntu 8.04 (amd 64 and KDE 3.5).

ProblemType: Bug
Architecture: amd64
Date: Sat Oct 31 17:23:27 2009
DistroRelease: Ubuntu 9.10
Package: davfs2 1.4.1-1
ProcEnviron:
 LANGUAGE=
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: davfs2
Uname: Linux 2.6.31-14-generic x86_64

marcstraemke (marcstraemke) wrote :

I stumbled upon the same problem, using the share in question worked fine until the upgrade to karmic koala. The first meassure i used was to disable locking, which resolved the "file exists" problem, but still created files don't appear after the cache flush, creating folders is working correctly. What type of logfile is needed to diagnose this? Are the secrets in the logfile? I would prefer not to send the secrets with the logfile...

themroc (rauchweihe) wrote :

Same problem at me after changing to Kubuntu 9.10.

After adding "use_locks 0" in the ~/.davfs2/davfs2.conf and using cp -uv instead of cp -av, I don't get the error message "file exist" during copy. But the copy-command doesn't have any effect. I can't copy files to the webdav-drive.

William Stone III (wrs) wrote :

I can confirm that this problem exists in 64-bit Ubuntu 9.10.

It's probably a somewhat higher-priority that one might imagine, considering all the new online storage services.

Marko Koenig (m-k) wrote :

It looks like that is not a problem of the davfs-deb package. Because, manual compiling and installing of davfs version 1.4.5 from http://savannah.nongnu.org/projects/davfs2 occurs in the same problem.

twin (twin) wrote :

I had the same problem, it was fixed by adding "if_match_bug 1" to /etc/davfs2.conf. I think the reason is that in webdav 1.4 the default has changed.

William Stone III (wrs) wrote :

I can confirm that adding the statement:

if_match_bug 1

as the final line of the stock

/etc/davfs2/davfs2.conf

resolved this issue for me in 64-bit Ubuntu 9.10.

Marko Koenig (m-k) wrote :

@twin: Thanks for this information. This works perfect for me!

amirsd (internet-bus) wrote :

I need to ask you about the same issue. When I copy a file using davfs I see the copied file for sometime (like 5 sec) but then it disappears. Above you have mentioned to set the line in davfs2.conf file as "if_match_bug 1". This line originally is commented in "etc/davfs2/davfs2.conf" file.

Is the above discussion indicating to add a new line in davfs2.conf file or just remove the comment and change the default from 0 to 1. Also do I need to re-start anything after making the change. Any tip would be nice.

twin (twin) wrote :

Un-commenting the existing line is fine, you don't need to add another line in that case. You don't need to re-start anything after changing the config file, it will take effect the next time you mount something via davfs.

themroc (rauchweihe) wrote :

The workaround from DakotaSmith works for me too.

Thanks!

I'd like to confirm the same issue on Karmic 9.10 (i386). Workaround works but anyway each process of mount.davfs takes ~150MB of memory. I was using davfs2 under Debian and for sure processes didn't consume so huge amoount of RAM.

Bill Poser (billposer) wrote :

Just in case anyone tries manually installing a newer version (1.4.6) of davfs2 from Savannah like I did, the workaround doesn't work with Karmic 9.10. It worked when I reverted to 1.4.1 from the Ubuntu repository.

Itamar Carvalho (itamarc) wrote :

This bug also affects Lucid (10.04).

The "if_match_bug 1" workaround from twin works.

rmcd (rmcd1024) wrote :

This bug affects me on 10.04 using mount.davfs version 1.4.5. The "if_match_bug 1" workaround does *not* fix the problem. To be specific, when I have mounted the davfs folder, I can create directories and I can delete files on the webdav server. But I cannot create files. A copy command creates the file for a few seconds and then it vanishes. I *can* create files on the webdav server using nautilus, just not from the command line.

rmcd (rmcd1024) wrote :

As a follow-up to my comment about mount.davfs, I have discovered that fusedav works correctly for the same resource. So this does seem to be a davfs2 problem.

Philip Muškovac (yofel) wrote :

Confirmed broken in natty.

Changed in davfs2 (Ubuntu):
status: New → Confirmed
tags: added: karmic regression-release
Eterion (eterion) wrote :

Hi.

"if_match_bug 1" workaround works on 10.10.

Thank you very much!

Rolf Leggewie (r0lf) on 2011-10-03
Changed in davfs2 (Ubuntu):
importance: Undecided → High
tags: added: lucid maverick natty
Rolf Leggewie (r0lf) wrote :

It would be great if one of the people affected would also confirm this for precise.

mpw (matthiaspeterw) wrote :

Hello,

I can update files manually from terminal, but unison can't sync updates or delete files. It can once create new files, but not remove or update files at all.

I use the options

use_locks 0
if_match_bug 1

Any ideas?

Bye
MPW

rmcd (rmcd1024) wrote :

Using xubuntu 12.04, I still cannot create files on the davfs device. I copy a file, it appears for about 5 seconds and then it vanishes.

Oliver Tacke (o-tacke) wrote :

I can confirm the bug using Ubuntu 12.04 (64bit) Precise Pangolin and davfs2_1.4.6-1ubuntu3_amd64.

Mounting a WebDAV environment works fine. After setting "use_locks 0" and "if_match_bug 1" copying large files, interestingly, seems to be possible via nautilus, but not via cp. With cp, the file shows up briefly and then vanishes.

Jan Lorenz (0tlwui8xk-post) wrote :

I confirm the same issue as Oliver Tacke, using Ubuntu 10.04 32bit. After mounting with davfs I can copy files via nautilus (even running kde) to the web space, these files also appear in the webinterface of the web-resource. But nothing (nor directories nor files) is visible in the mountpoint in Dolphin, nor in konsole using ls or cp.

Rolf Leggewie (r0lf) wrote :

does this ever occur in precise or later?

Changed in davfs2 (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Confirmed → Incomplete
Chris O'Brien (cjobrien) wrote :

I can confirm that the same bug (or something very similar) still exists in saucy. Consider the following:

cobrien@tasman:~$ mount /media/ipad
cobrien@tasman:~$ cp ~/Documents/AVIA\ 101/Handbook/hb_su8.pdf /media/ipad/My\ Documents/Aviation/AVIA\ 101/Handbook/
cobrien@tasman:~$ umount /media/ipad
/sbin/umount.davfs: waiting while mount.davfs (pid 6324) synchronizes the cache .. OK
cobrien@tasman:~$ mount /media/ipad
cobrien@tasman:~$ ls /media/ipad/My\ Documents/Aviation/AVIA\ 101/Handbook/
hb_intro.pdf hb_su1.pdf hb_su2.pdf hb_su3.pdf hb_su4.pdf hb_su5.pdf hb_su7.pdf hb_su8.pdf

Browsing the same webdav share via Nautilus shows that hb_su8.pdf does not exist on the iPad. Confirmed via the GoodReader app on the iPad itself. Files copies via Nautilus to the same webdav share are successful.

Note that it was necessary to set "use_locks 0" in ~/.davfs2/davfs2.conf otherwise any attempt to create a new file on the webdav share failed.

Rolf Leggewie (r0lf) wrote :

Christ, does it help if you sync before unmounting? How big is the file?

Rolf Leggewie (r0lf) wrote :

s/Christ/Chris/ ;-)

Rolf Leggewie (r0lf) wrote :

Chris? ping!

Rolf Leggewie (r0lf) wrote :

no further response. It works for me is all I can say.

tags: added: precise saucy
Changed in davfs2 (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
importance: High → Low
status: Incomplete → Confirmed
knb (knb) wrote :

It's 2016. last post from 2014.
I was still affected from this bug, but maybe it's just me.
Whatever, my installed ubuntu version is a few years old, upgraded multiple times, and some legacy code might be lurking in the system.

my /etc/davfs2/davfs2.conf file:

use_proxy 0 # system wide config file only
use_locks 0
if_match_bug 1

my mount command
sudo mount.davfs -o uid=knb,file_mode=775,dir_mode=775 https://webdav.somesite.com/mydir /media/somesite

Woodrow Shen (woodrow-shen) wrote :

Due to the bug didn't update since 2016, I'd like to close it as invalid.

Changed in davfs2 (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers