umount errors (patch)

Bug #178650 reported by Adrian Bridgett on 2007-12-25
10
Affects Status Importance Assigned to Milestone
davfs2 (Debian)
Fix Released
Unknown
davfs2 (Ubuntu)
Low
Unassigned

Bug Description

This is on gutsy, all up to date.

Trying to umount (as a normal user) a dav directory yields this:

/sbin/umount.davfs:
  can't find mount.davfs-process with pid 26262;
  trying to unmount anyway.
  you propably have to remove /var/run/mount.davfs/home-abridgett-dav.pid manually

it is successfully unmounted.

Looking at the code, it tries to do "ps -p (pid) -C (mpoint)" which errors here (but not on a Debian etch box BTW) with "ERROR: Unsupported option (BSD syntax)"

I'll attach a patch imminently.

patch for problem

Changed in davfs2:
importance: Undecided → Low

Providing a debdiff.

In debdiff there is an update of Standards-Version. It's better to wait Debian in this case.
Unsubscribe u-u-s. After made the new debdiff, subsribe it another time.

Changed in davfs2:
assignee: nobody → mariobonino

Thank you for your comment Michele.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package davfs2 - 1.2.1-3ubuntu1

---------------
davfs2 (1.2.1-3ubuntu1) hardy; urgency=low

  * debian/control, debian/rules,
    debian/patches/00list:
    - added dpatch support
  * debian/patches/umount_errors.dpatch:
    - patch to fix umount errors (LP: #178650)
      (patch from Adrian Bridgett)
  * debian/control:
    - updated Maintainer field

 -- Mario Bonino <email address hidden> Thu, 27 Dec 2007 13:11:59 +0100

Changed in davfs2:
status: New → Fix Released

I've forwarded the patch to Debian.

Changed in davfs2:
status: Unknown → New

Adrian, can you have a look at the Debian bug ?

On Sun, Jan 13, 2008 at 09:54:43 -0000 (-0000), Mario Bonino wrote:
> Adrian, can you have a look at the Debian bug ?

Hmm - that's quite odd - it shows the command line arguments to me on
sid at least.

Aha - it's because I have: "I_WANT_A_BROKEN_PS=1" set in the
environment.

~$ ps -p 5217
  PID TTY STAT TIME COMMAND
   5217 ? S 0:00 /sbin/dhclient -1 -lf
/var/lib/dhcp3/dhclient.wlan0.l
~$ set |grep PS
GROUPS=()
I_WANT_A_BROKEN_PS=1
PS1='\[\033]2;\w\007\033[35m\]\w\$\[\033[39m\] '
PS2='> '
PS4='+ '
~$ unset I_WANT_A_BROKEN_PS
~$ ps -p 5217
  PID TTY TIME CMD
   5217 ? 00:00:00 dhclient

That explains that then!

Adrian
--
Email: <email address hidden> -*- GPG key available on public key servers
Debian GNU/Linux - the maintainable distribution -*- www.debian.org

Changed in davfs2:
status: New → Fix Released
Alex Zvoleff (azvoleff) wrote :

I still see this error on Hardy using davfs2 1.2.1-3ubuntu1:

/sbin/umount.davfs:
  can't find mount.davfs-process with pid 15429;
  trying to unmount anyway.
  you propably have to remove /var/run/mount.davfs/mnt-CSWebDAV.pid manually

Although, as said before, it successfully unmounts.

krouskop (krouskop) wrote :

I can confirm the bug is still around in Hardy. (I'm experiencing it too).

davfs2 version: 1.2.1

Error message encountered:

can't find mount.davfs-process with pid 4935;
  trying to unmount anyway.
  you propably have to remove /var/run/mount.davfs/tmp-site.pid manually

(Also fwiw, "propably" is misspelled. ... I assume that should be "probably.")

Finally, I'm not sure what the stuff about the I_WANT_A_BROKEN_PS env. var. is all about above in the thread, but I do -not- have this env. var. set. ([$set | grep BROKEN_PS] comes back w/ no output)

Peter Bubenik (peter-bubenik) wrote :

I am also experiencing this bug in Hardy using davfs2 1.2.1-3ubuntu1

can't find mount.davfs-process with pid 6344;
  trying to unmount anyway.
  you propably have to remove /var/run/mount.davfs/mnt-campusDrive.pid manually
umount: /mnt/campusDrive: device is busy
umount: /mnt/campusDrive: device is busy

linuxball (linuxball) wrote :

I'm running Hardy with davfs2 package 1.2.1-3ubuntu1 and I can confirm what Adrian has posted:

If environment variable I_WANT_A_BROKEN_PS is not set then "umount <davfs_mount_point>" will output the error message:

  $ umount /home/reimer/gmx
  /sbin/umount.davfs:
    can't find mount.davfs-process with pid 27246;
    trying to unmount anyway.
    you propably have to remove /var/run/mount.davfs/home-reimer-gmx.pid manually

Setting the environment variable I_WANT_A_BROKEN_PS can be used as work around for this bug. I set an alias in .bashrc to do this:

  alias umount='I_WANT_A_BROKEN_PS=1 umount'

Now umount works:
  $ umount /home/reimer/gmx
  /sbin/umount.davfs: waiting while mount.davfs (pid 27659) synchronizes the cache ... OK

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.