davfs2 downloads same file over and over

Bug #1490555 reported by Minosone on 2015-08-31
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
davfs2 (Ubuntu)
Undecided
Unassigned

Bug Description

From time to time davfs2 (version 1.4.7-3) chokes on a file, although I haven't been able to pinpoint the cause of this. However when this happens the following occurs:

1. The mounted WEBDAV filesystem becomes very slow (possibly related to bug https://bugs.launchpad.net/ubuntu/+source/davfs2/+bug/185986).
2. All available bandwith to the WEBDAV server is saturated (as seen from the resources tab of the system monitor).
3. When looking at the davfs2 cache at ~/.davfs2/cache/<mount-point>/ the file size of a single file keeps changing when monitoring the directory. The file size goes from some small size to it's full size in several steps as it is being downloaded and then starts over at some small size. Often this file is also present multiple times with different strings appended to the end.

This does not seem to stop. I have let it go on a couple times and it managed to download a 11MB file many times for a total of 4GB of received data, with no other data connections active.

From this I conclude that davfs2 chokes on a particular file and for some reason decides it has to download the same file over and over again, which saturates the available bandwidth and causes the entire WEBDAV mount to become unresponsive.

As a temporary fix I have discovered that unmounting and deleting the offending file from the cache fixes the issue temporarily (until it chokes on something again).

I have this issue on multiple systems with Ubuntu 14.04 LTS. Although reproducibility is a bit of an issue, it does seem to occur more often when the network connection is already slow to begin with. Such as when there is a bad wifi signal or when using a mobile connection. Possibly this causes the file download to become corrupted.

R. Diez (rdiezmail-ubuntu) wrote :

I am just a Kubuntu 14.04.3 user who is experiencing freezing problems with davfs2 and I am considering compiling the latest 1.5.2 on my system, which involves some work. It would be good to know whether this bug is still there with davfs version 1.5.2, which is what newer Ubuntu releases come with.

Minosone (menno-pleijster) wrote :

As all my systems are still on Ubuntu 14.04.3, you're probably in a better position to to see if the bug is still present in newer releases. So do report back when you have tried a newer version of davfs2.

Angelo Machils (angelo-3) wrote :

I've tried on an Arch based system, which has version davfs2 1.5.2-1 and the issue is still there. After a while the WebDAV mount slows everything down that has anything to do with opening files and/or directories, so Nautilus, but also opening files within applications. I've looked around a little and it seems that this problem has been around for years now.....

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in davfs2 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers