Dasher just doesn't work at all

Bug #244828 reported by Lionel Dricot on 2008-07-02
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dasher (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: dasher

Dasher just doesn't work in hardy. (i'm usin onboard to write this)

Dasher just doesn't start to flow through the letters. It stays static and trying to change de preferences so it starts with a given mouse position crashes the program. In its current state, it is completely useless.

I'm sorry I cannot give much more info but writing with onboard is a bit painful. Please just try dasher too see

JM Williams (jmdwilliams) wrote :

Can you start Dasher’s movement by clicking a mouse button?

For me, changing the “Start with mouse position” option crashes Dasher only
sometimes (not that this stops it from being a bug, of course!), and once the
option has successfully changed, it is still changed when Dasher restarts.

Lionel Dricot (ploum) wrote :

No, I can't.

And it crashes all the time

(sorry for being short, same reason)

JGJones (jgjones) wrote :

I've just installed dasher - apt-get install dasher

It is working perfectly fine for me, sorry to say. Like JM Williams - I click the left mouse button to start the letters moving and click again to stop it.

I hate to say that I'm not able to replicate your bug as it doesn't help in your case. Is there anything else that you might be running on your system that might affect Dasher? Compiz running? Have you tried it with Compiz off/on?

Lionel Dricot (ploum) wrote :

I don't use Compiz but I have Metacity compositing enabled. I will try without. (even if I'm now healed and I can type again with my fingers)

Pablo Angulo (pablo-angulo) wrote :

I had the same problem as Lionel reports. I have tried dasher on xubuntu hardy 32 bits with compiz, and in a virtualbox machine without any compiz or 3D stuff (this time xfwm4 was used) and neither worked at the beginning. The program would behave erratically and crash. I tried several control forms and the problem persisted. However, eventually it started to work ok. I think the option that made it all work was to explicitely select the mouse as input device.

The following is the kind of error it would leave on the terminal after a crash:

$ dasher

** Message: Glade file is: /usr/share/dasher/dasher.traditional.glade
Adding lock Training Dasher
Releasing Lock
** Message: 1
** Message: 2

** (dasher:9125): WARNING **: AT_SPI_REGISTRY was not started at session startup.

** (dasher:9125): WARNING **: Could not locate registry
** Message: Could not initialise SPI - accessibility options disabled
Adding lock Training Dasher
Rendering lock
Releasing Lock
Fallo de segmentación

This last sentence is spanish for "Segmentation fault".

I have the same issue under Jaunty.

Dasher doesn't start to move. I have tried with visual effects on and off.

In my case dasher doesn't crash but no work.

Here is the output that you can see allways in a bucle when you runs "strace dasher" until you exit.

gettimeofday({1239040687, 479844}, {0, 0}) = 0
select(4, [3], [3], NULL, NULL) = 1 (out [3])
writev(3, [{">\7\7\0i\0@\3j\0@\3\t\0@\3\0\0\0\0\0\0\0\0\214\1A\1"..., 28}, {NULL, 0}, {""..., 0}], 3) = 28
read(3, 0x964c7a8, 4096) = -1 EAGAIN (Resource temporarily unavailable)
gettimeofday({1239040687, 480356}, NULL) = 0
poll([{fd=3, events=POLLIN}, {fd=4, events=POLLIN}, {fd=8, events=POLLIN|POLLPRI}, {fd=12, events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}, {fd=14, events=POLLIN|POLLPRI}, {fd=15, events=POLLIN}, {fd=10, events=POLLIN|POLLPRI}], 8, 9) = 0 (Timeout)
gettimeofday({1239040687, 489731}, NULL) = 0
select(4, [3], [3], NULL, NULL) = 1 (out [3])
writev(3, [{"&\7\2\0g\0@\3"..., 8}, {NULL, 0}, {""..., 0}], 3) = 8
select(4, [3], [], NULL, NULL) = 1 (in [3])
read(3, "\1\1K\27\0\0\0\0\265\0\0\0\0\0\0\0\250\1\223\1\216\376@\0\4\0\33\v\320\336*\v"..., 4096) = 32
read(3, 0x964c7a8, 4096) = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], [3], NULL, NULL) = 1 (out [3])
writev(3, [{"&\7\2\0\265\0\0\0"..., 8}, {NULL, 0}, {""..., 0}], 3) = 8
select(4, [3], [], NULL, NULL) = 1 (in [3])
read(3, "\1\1L\27\0\0\0\0\265\0\0\0\265J\0\1\250\1\223\1\250\1\223\1\4\0\17\0\320\336*\v"..., 4096) = 32
read(3, 0x964c7a8, 4096) = -1 EAGAIN (Resource temporarily unavailable)
gettimeofday({1239040687, 496091}, {0, 0}) = 0
select(4, [3], [3], NULL, NULL) = 1 (out [3])
writev(3, [{">\7\7\0i\0@\3j\0@\3\t\0@\3\0\0\0\0\0\0\0\0\214\1A\1"..., 28}, {NULL, 0}, {""..., 0}], 3) = 28
read(3, 0x964c7a8, 4096) = -1 EAGAIN (Resource temporarily unavailable)
gettimeofday({1239040687, 496517}, NULL) = 0
poll([{fd=3, events=POLLIN}, {fd=4, events=POLLIN}, {fd=8, events=POLLIN|POLLPRI}, {fd=12, events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}, {fd=14, events=POLLIN|POLLPRI}, {fd=15, events=POLLIN}, {fd=10, events=POLLIN|POLLPRI}], 8, 18^C <unfinished ...>

Alan Bell (alanbell) wrote :

can you retest with Maverick please, there have been a bunch of crash scenarios removed and it now works OK for me, but it sounds like this issue was not reproduced on all machines anyway.

Alan Bell (alanbell) on 2010-10-21
Changed in dasher (Ubuntu):
status: New → Incomplete
Pablo Angulo (pablo-angulo) wrote :

Actually, I cannot reproduce this on ubuntu 10.04.

Lionel Dricot (ploum) wrote :

I've tested under maverick and it works fine. This bug can be marked as fixed. Thanks.

Alan Bell (alanbell) on 2010-10-22
Changed in dasher (Ubuntu):
status: Incomplete → Fix Released

Reviewed: https://reviews.mahara.org/5061
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/1826da168a3b23d1f402246114e6ae02047d963c
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 1826da168a3b23d1f402246114e6ae02047d963c
Author: Aaron Wells <email address hidden>
Date: Fri Aug 7 11:31:27 2015 +1200

Filter ASCII control characters out of Leap2a import (Bug 244828)

Change-Id: Iae83deaf8ac3e66e44fdc122e702ddc6dbfb5003
behatnotneeded: Can't yet test leap2a imports in Behat.

Reviewed: https://reviews.mahara.org/5080
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/a33b21d1e842d8293f9f626fe56fc86c7df0afde
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit a33b21d1e842d8293f9f626fe56fc86c7df0afde
Author: Aaron Wells <email address hidden>
Date: Fri Aug 7 11:31:27 2015 +1200

Filter ASCII control characters out of Leap2a import (Bug 244828)

Change-Id: Iae83deaf8ac3e66e44fdc122e702ddc6dbfb5003
behatnotneeded: Can't yet test leap2a imports in Behat.
(cherry picked from commit 1826da168a3b23d1f402246114e6ae02047d963c)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers