Package dante-client needs updated version dependency on libc6

Bug #767085 reported by Shawn Guo on 2011-04-20
106
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Linux Mint
Undecided
Unassigned
dante (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: dante-client

I was told to log a bug by https://answers.launchpad.net/ubuntu/+source/dante/+question/153547

$ lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

$ apt-cache policy dante-client
dante-client:
  Installed: (none)
  Candidate: 1.1.19.dfsg-3ubuntu4
  Version table:
     1.1.19.dfsg-3ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

I expect package dante-client can be installed and working. But now it fails to install.

Thanks,
Shawn

I am able to reproduce this bug on a Natty amd64 system of my own. This happens because libdsocksd0 (a dependency of dante-client) requires an *older* version of libc6 than what is available in Natty. Text from the Terminal in the original question (which I can reproduce on my machine), which was left out of this bug report, reveals this:

[start of text from https://answers.launchpad.net/ubuntu/+source/dante/+question/153547]

$ sudo apt-get install dante-client
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 dante-client : Depends: libdsocksd0 (= 1.1.19.dfsg-3ubuntu4) but it is not going to be installed
E: Broken packages

$ sudo apt-get install libdsocksd0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libdsocksd0 : Depends: libc6 (< 2.13) but 2.13-0ubuntu13 is to be installed
E: Broken packages

[end of text from https://answers.launchpad.net/ubuntu/+source/dante/+question/153547]

(I am able to confirm this bug down to the details of the error messages and the specific versions cited, which, given these errors, is expected.)

So this is actually a bug in libdsocksd0 rather than dante-client. To fix this bug, the version restriction in libdsocksd0's libc6 dependency must be lifted. I don't know if other changes will have to be made to libdsocksd0, though, because I don't know if that version restriction is totally artificial, or if libdsocksd0 does actually break in some way when used with a later version of libc6.

By the way, as expected, this same breaking version dependency is present in libsocksd0 (the version of the library associated with libsocksd-dev (whereas libdsocksd0, the package causing the specific breakage cited here, is just used by dante-client).

Changed in dante (Ubuntu):
status: New → Confirmed

In addition to the Natty amd64 system mentioned above, I am able to confirm this on a Natty i386 system as well.

tags: added: amd64 i386 natty

I can build from source, but then socksify gives:

ERROR: ld.so: object '/lib/libdl.so.2' from LD_PRELOAD cannot be preloaded: ignored.

That no longer exists.

I then run
ln -sf /lib/i386-linux-gnu/libdl.so.2 /lib/libdl.so.2

and then get:
symbolfunction(): compiletime configuration error? Failed to open "libc.so": /usr/lib/i386-linux-gnu/libc.so: invalid ELF header

Sorry, source: apt-get -b source dante-client.

An additional ln -sf /lib/i386-linux-gnu/libc.so.6 /lib/libc.so fixes that.

Shawn Guo (shawnguo) wrote :

Following the instructions from Berend, I got the problem fixed. Thanks.

I'm glad there is a workaround for this bug. Nonetheless, the bug itself is not fixed, and dante-client will still not install normally on Natty. The following still occurs on my Natty machines (and this is the same as the original problem):

ek@Apok:~$ sudo apt-get update; apt-get -s install dante-client
[sudo] password for ek:

(snip)

NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 dante-client : Depends: libdsocksd0 (= 1.1.19.dfsg-3ubuntu4) but it is not going to be installed
E: Broken packages

Kjmph (kjmph) wrote :

Still broken after official update.

Aime (aime-vareille) wrote :

Yes, I have the same problem and did not choose to fix with the workaround of Berend, but downloading and compiling the last version dante-1.2.3.tar.gz from http://www.inet.no/dante ; it put all at /usr/local (bin for socksify and lib for libdsocks.so) and the socks.conf necessary at etc should be adapted from dante-1.2.3/example directory of the compilation.

Changed in dante (Ubuntu):
assignee: nobody → Aime (aime-vareille)
Aime (aime-vareille) wrote :

I can't keep the Bug assignation to me. Sorry

Changed in dante (Ubuntu):
assignee: Aime (aime-vareille) → nobody
Scott Wood (scott-buserror) wrote :

I tried building from source (both as a package and with "./configure; make"). After resolving the libdl.so issue, when I try to run socksify the program just exits immediately with no message. Some simple programs like ls can run under socksify, but not the interesting ones.

I tried the libc symlink, and I tried changing the libc.so reference in the source to libc.so.6 -- neither made a difference. strace shows it looking at /usr/lib/x86_64-linux-gnu/libc.so (a linker script, probably expecting a binary) immediately before exiting.

Scott Wood (scott-buserror) wrote :

Putting the libc.so symlink in /usr/lib rather than /lib made it work.

Armen K (kriation) wrote :

Based on my research, this appears to be simply a version name mismatch in libdsocksd0.
The package is looking for 2.13 of libc6, but the package name for libc6 has '-0ubuntu13' added as a suffix as evident from the output of dpkg below:

 libdsocksd0 depends on libc6 (<< 2.13); however:
  Version of libc6 on system is 2.13-0ubuntu13.

Can the maintainer of the library simply update the version dependency field from 2.13 to 2.13-0ubuntu13?

Marc Gariépy (mgariepy) wrote :

Hello,

This package only need to be rebuild since libc6 changed from 2.12-xx to 2.13-xx during the development cycle.

so the rebuild is needed to update the dependency issue with libdsocksd0.

thanks

Stéphane Graber (stgraber) wrote :

I uploaded a no change rebuild to natty-proposed, should be ready for testing soon.

Changed in dante (Ubuntu Natty):
status: New → Triaged
importance: Undecided → Medium
milestone: none → natty-updates
Changed in dante (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dante - 1.1.19.dfsg-3ubuntu5

---------------
dante (1.1.19.dfsg-3ubuntu5) oneiric; urgency=low

  * No-change rebuild to update the dependency on libc6 (LP: #767085).
 -- Stephane Graber <email address hidden> Tue, 17 May 2011 09:18:25 -0400

Changed in dante (Ubuntu):
status: Triaged → Fix Released
summary: - Package dante-client is broken on natty beta
+ Package dante-client needs updated version dependency on libc6
Micah Gersten (micahg) wrote :

Removing ubuntu-sponsors since this was uploaded already.

Changed in dante (Ubuntu Natty):
status: Triaged → Fix Committed
Stefan Metzmacher (metze) wrote :

This happened also for maverick, see
https://bugs.launchpad.net/ubuntu/+source/dante/+bug/624425

Is it possible to add some test or dependency, so that this can't happen in future?

Can you please also trigger a rebuild for natty not only for oneiric?

Changed in dante (Ubuntu Natty):
status: Fix Committed → Incomplete
Micah Gersten (micahg) wrote :

There was a rebuild uploaded for Natty. It's currently waiting in the unapproved queue.

Changed in dante (Ubuntu Natty):
status: Incomplete → Fix Committed

Accepted dante into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Marc Gariépy (mgariepy) wrote :

I just tested with proposed and everything is working fine.

thanks.

Thanks for testing Marc. Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dante - 1.1.19.dfsg-3ubuntu4.1

---------------
dante (1.1.19.dfsg-3ubuntu4.1) natty-proposed; urgency=low

  * No-change rebuild to update the dependency on libc6 (LP: #767085).
 -- Stephane Graber <email address hidden> Tue, 17 May 2011 09:13:47 -0400

Changed in dante (Ubuntu Natty):
status: Fix Committed → Fix Released

zyrg posted this

https://answers.launchpad.net/ubuntu/+source/dante/+question/162295

It seems that the bug is not fixed

Unable to run danted sock server

$ uname -a
Linux server 2.6.38-8-generic-pae #42-Ubuntu SMP Mon Apr 11 05:17:09 UTC 2011 i686 i686 i386 GNU/Linux

$ lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

$sudo service danted start
Starting Dante SOCKS daemon: Jun 22 09:50:35 (1308721835) danted[13601]: socks_seteuid(): old: 0, new: 13
Jun 22 09:50:35 (1308721835) danted[13601]: socks_reseteuid(): current: 13, new: 0
Jun 22 09:50:35 (1308721835) danted[13601]: socks_seteuid(): old: 0, new: 65534
Jun 22 09:50:35 (1308721835) danted[13601]: socks_reseteuid(): current: 65534, new: 0
Jun 22 09:50:35 (1308721835) danted[13601]: socks_seteuid(): old: 0, new: 65534
Jun 22 09:50:35 (1308721835) danted[13601]: socks_reseteuid(): current: 65534, new: 0
Jun 22 09:50:35 (1308721835) danted[13601]: symbolfunction(): compiletime configuration error? Failed to open "libc.so": /usr/lib/i386-linux-gnu/libc.so: invalid ELF header
Jun 22 09:50:35 (1308721835) danted[13601]: sockdexit()
Jun 22 09:50:35 (1308721835) danted[13601]: sockdexit(): terminating

apt-cache policy dante-server
dante-server:
  Установлен: 1.1.19.dfsg-3ubuntu4.1
  Кандидат: 1.1.19.dfsg-3ubuntu4.1
  Таблица версий:
 *** 1.1.19.dfsg-3ubuntu4.1 0
        500 http://ru.archive.ubuntu.com/ubuntu/ natty-updates/universe i386 Packages
        100 /var/lib/dpkg/status
     1.1.19.dfsg-3ubuntu4 0
        500 http://ru.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages

zyrg (zyrgzyrg) wrote :

Dirty fix:
$ sudo ln -sf /lib/i386-linux-gnu/libc-2.13.so /lib/i386-linux-gnu/libc.so

I can confirm this is not fixed. With 1.1.19.dfsg-3ubuntu4.1, a simple "socksify ssh" just fails silently.

After adding the workaroud link for libc.so to /usr/lib as described by Scott Wood in comment #12, it worked.

Can someone please help in reopening this bug? Or shall I report a new one?

FiX (fix-kowalski) wrote :

Not fixed as of dante-client 1.1.19.dfsg-3ubuntu4.1 on amd64. How to re-open this?

@Stéphane Graber and/or Martin Pitt and/or Jean-Baptiste Lallement
As this has been reported and confirmed as not fixed for some people, either this bug should be reopened or a new one should be filed. Which is preferable in this particular situation? (My apologies for [re]subscribing you, if you preferred not to be.)

Excerpts from Eliah Kagan's message of Sun Sep 04 09:22:32 UTC 2011:
> @Stéphane Graber and/or Martin Pitt and/or Jean-Baptiste Lallement
> As this has been reported and confirmed as not fixed for some people, either this bug should be reopened or a new one should be filed. Which is preferable in this particular situation? (My apologies for [re]subscribing you, if you preferred not to be.)
>

Hi Eliah, I suggest you open a new report, and comment here with the
new bug # so we can see the link between the two.

Its either a regression or a different issue which causes the same effect.
Either way, without a new report showing your specific configuration,
it will be hard to address it for you.

@zyrg / Michael Basse, Gernot Hillier, FiX
Perhaps one of you could follow the above advice by Clint Byrum (since you are the ones who are still experiencing/reporting the existence of this problem).

Stefan Essl (stefan-essl-vhs) wrote :

yrg (zyrgzyrg) wrote on 2011-06-22:

sudo ln -sf /lib/i386-linux-gnu/libc-2.13.so /lib/i386-linux-gnu/libc.so

...made it work again! Thank you so much!!

Problem exists in:
 Linux Mint 11 - i386 (ubuntu based)
installation of dante-client worked fine: but configuration did not work...

socksify ssh
terminated first with comment:
ERROR: ld.so: object '/lib/libdl.so.2' from LD_PRELOAD cannot be preloaded

after symlinking without any comment...
I did the following first without success:
ln -sf /lib/i386-linux-gnu/libdl.so.2 /lib/libdl.so.2
ln -sf /lib/i386-linux-gnu/libc6.so.6 /lib/libc6.so.6

mint is not supported here. If the Bug only affects mint at the moment i would suggest to close this bug as fixed (for ubuntu)

@Michael Basse
Mint *is* supported here--like Ubuntu, Linux Mint uses Launchpad for bug tracking. While questions have a single project or distribution/package against which they are targeted (and therefore a question about Ubuntu is not a good place to work on a problem in Linux Mint[1]), bugs can contain multiple tasks targeted against different software. This is quite common. When a bug affects multiple projects, multiple packages in a distribution, and/or multiple distributions (or multiple packages in multiple distributions), it can and should have bug tasks opened for each.

This bug *is* closed as fixed, in Ubuntu. Its status in dante in Ubuntu is Fix Released.

Has this been reported against dante in Linux Mint? Linux Mint uses Launchpad for bugs just like Ubuntu. Based on the information from Stefan Essl in https://bugs.launchpad.net/ubuntu/+source/dante/+bug/767085/comments/31, I'm adding a task here for Linux Mint--if there is another bug that's been opened, then that should be marked as a duplicate of this bug.

[1] Also, while Linux Mint uses Launchpad for bugs, it does not (at least currently) use Launchpad for questions--the Linux Mint forums should be used instead.

If anyone is still experiencing this issue **in Ubuntu**, please do still follow the instructions in https://bugs.launchpad.net/linuxmint/+bug/767085/comments/29.

Rorzik (rorzik) wrote :

The installation bug reported above by Michael remains unfixed, and is now being tracked in #816153

Rorzik (rorzik) wrote :

(A post preview button would be nice.) The bug is being tracked at: https://bugs.launchpad.net/ubuntu/+source/dante/+bug/816153

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions