dahdi-dkms fails to install on 2.6.35 kernel: linux/autoconf.h: No such file or directory

Bug #591375 reported by Ky6uk on 2010-06-08
328
This bug affects 36 people
Affects Status Importance Assigned to Milestone
dahdi-linux (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: dahdi-linux

after use
~$ sudo aptitude install asterisk

I see next lines in aptitude log:

Loading new dahdi-2.2.1+dfsg-1ubuntu2 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.35-1-generic
Building for architecture i686
Building initial module for 2.6.35-1-generic
https://bit.ly/2BtN52W

Error! Bad return status for module build on kernel: 2.6.35-1-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/ for more information.
Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/dkms.py", line 57, in <module>
    report.write(open(apport.fileutils.make_report_path(report), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/dahdi-dkms.0.crash'
dpkg: error processing dahdi-dkms (--configure):
 subprocess installed post-installation script returned error exit status 10

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: dahdi-dkms 1:2.2.1+dfsg-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-1.1-generic 2.6.35-rc1
https://bit.ly/2BtN52W
Uname: Linux 2.6.35-1-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Tue Jun 8 23:38:33 2010
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=ru_RU:ru:en_GB:en
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: dahdi-linux

Ky6uk (ky6uk) wrote :
Ky6uk (ky6uk) wrote :

~$ cat /var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/
cat: /var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/: Это каталог
ky6uk@desu:~$ cat /var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/
build_tools/ dkms.conf drivers/ include/ Makefile make.log .version
ky6uk@desu:~$ cat /var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/make.log
DKMS make.log for dahdi-2.2.1+dfsg-1ubuntu2 for kernel 2.6.35-1-generic (i686)
Tue Jun 8 23:38:10 YEKST 2010
make -C /lib/modules/2.6.35-1-generic/build SUBDIRS=/var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/drivers/dahdi DAHDI_INCLUDE=/var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/include DAHDI_MODULES_EXTRA=" " HOTPLUG_FIRMWARE=yes modules DAHDI_BUILD_ALL=m
make[1]: Entering directory `/usr/src/linux-headers-2.6.35-1-generic'
  CC [M] /var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/drivers/dahdi/dahdi-base.o
In file included from /var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/include/dahdi/kernel.h:39,
                 from /var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/drivers/dahdi/dahdi-base.c:62:
/var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/include/dahdi/dahdi_config.h:27:28: error: linux/autoconf.h: No such file or directory
make[2]: *** [/var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/drivers/dahdi/dahdi-base.o] Error 1
make[1]: *** [_module_/var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/drivers/dahdi] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-1-generic'
make: *** [modules] Error 2

summary: - dahdi-dkms (1:2.2.1+dfsg-1ubuntu2) failed to install
+ dahdi-dkms fails to install on 2.6.35 kernel: linux/autoconf.h: No such
+ file or directory
Dimitrios Symeonidis (azimout) wrote :

Yes, the reason is that in 2.6.32 there's the file:
/usr/src/linux-headers-2.6.32-23-generic/include/linux/autoconf.h
while in 2.6.35 it's:
/usr/src/linux-headers-2.6.35-14-generic/include/generated/autoconf.h

Changed in dahdi-linux (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Dimitrios Symeonidis (azimout) wrote :

The error comes from the file
/var/lib/dkms/dahdi/2.2.1+dfsg-1ubuntu2/build/include/dahdi/dahdi_config.h

Changed in dahdi-linux (Ubuntu):
assignee: nobody → SevenMachines (sevenmachines)

debian version works now but theres a lot of ubuntu changes to go through so it would need to be looked at by someone more familiar with the package but for the moment....

Debdiff attached

Test build: https://edge.launchpad.net/~sevenmachines/+archive/release+1/+packages

dahdi-linux (1:2.2.1+dfsg-1ubuntu3) maverick; urgency=low

  * 2.6.35-build.patch:
    - fixes builds on 2.6.35 kernels. Fixed in debian 1:2.3.0.1+dfsg-1
    (LP: #591375)

Changed in dahdi-linux (Ubuntu):
assignee: SevenMachines (sevenmachines) → nobody
Stefano Rivera (stefanor) wrote :

SevenMachines: I agree about this being the wrong time in the release cycle to be merging this package. The patch looks decent, but a couple of quick things.

Would you mind using a real name in the changelog?

It's a big help to future MOTUs working on the package if quilt patches have a descriptive header. The DEP3 standard is quite popular: http://dep.debian.net/deps/dep3/

sorry, missing dep3 was a result of doing it late in the evening.

tags: added: patch
Changed in dahdi-linux (Ubuntu Maverick):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dahdi-linux - 1:2.2.1+dfsg-1ubuntu3

---------------
dahdi-linux (1:2.2.1+dfsg-1ubuntu3) maverick; urgency=low

  * 2.6.35-build.patch:
    - fixes builds on 2.6.35 kernels. Fixed in debian 1:2.3.0.1+dfsg-1
    (LP: #591375)
 -- Niall Creech <email address hidden> Fri, 17 Sep 2010 09:45:04 +0200

Changed in dahdi-linux (Ubuntu Maverick):
status: Fix Committed → Fix Released
Torsten Krah (tkrah) wrote :

Can this one maybe pushed to latest LTS (lucid) too? Lucid does suffer this one using a backported kernel.

Aiman Baharna (aiman) on 2012-02-15
no longer affects: lucid
tranadols (tramadols) on 2019-02-13
description: updated
description: updated
To post a comment you must log in.