dahdi-linux/1:2.11.1~dfsg-1ubuntu6.2 ADT test failure with linux-hwe-5.11/5.11.0-20.21~20.04.1

Bug #1932161 reported by Kleber Sacilotto de Souza
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dahdi-linux (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Tim Gardner
linux-hwe-5.11 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

[Impact]

This is a scripted bug report about ADT failures while running dahdi-linux tests for linux-hwe-5.11/5.11.0-20.21~20.04.1 on focal. Whether this is caused by the dep8 tests of the tested source or the kernel has yet to be determined.

Testing failed on:
    amd64: https://autopkgtest.ubuntu.com/results/autopkgtest-focal/focal/amd64/d/dahdi-linux/20210611_210158_32a25@/log.gz

[Test Plan]

sudo apt-get install dahdi-dkms

[Where problems could occur]

Run time regressions could occur due to compatibility changes required for linux-hwe-5.11.

[Other Info]

tags: added: kernel-adt-failure
Changed in dahdi-linux (Ubuntu Focal):
status: New → Confirmed
Revision history for this message
Kleber Sacilotto de Souza (kleber-souza) wrote :
tags: added: patch
Tim Gardner (timg-tpi)
description: updated
Changed in dahdi-linux (Ubuntu Focal):
status: Confirmed → In Progress
assignee: nobody → Tim Gardner (timg-tpi)
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Kleber, or anyone else affected,

Accepted dahdi-linux into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/dahdi-linux/1:2.11.1~dfsg-1ubuntu6.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in dahdi-linux (Ubuntu Focal):
status: In Progress → Fix Committed
Revision history for this message
Kleber Sacilotto de Souza (kleber-souza) wrote :

dahdi-linux 1:2.11.1~dfsg-1ubuntu6.3 can be built and loaded on focal with both 5.4 and 5.11 kernels. Waiting for autopkgtests to complete to confirm the verification.

Revision history for this message
Kleber Sacilotto de Souza (kleber-souza) wrote :
tags: added: verification-done-focal
Revision history for this message
Brian Murray (brian-murray) wrote :

The previous SRU of dahdi-linux was release to -security and -updates. I'd imagine this one also needs to be released to -updates and -security but I don't see that in the description, am I correct in thinking it needs to go to -security?

Revision history for this message
Kleber Sacilotto de Souza (kleber-souza) wrote :

Yes, this needs to go to -security as well. The reason is that users tracking only -security will need to get this update when the default hwe kernel in focal upgrades to 5.11.

What's the standard way of documenting this on the SRU template?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dahdi-linux - 1:2.11.1~dfsg-1ubuntu6.3

---------------
dahdi-linux (1:2.11.1~dfsg-1ubuntu6.3) focal; urgency=medium

  * Non-maintainer upload.
  * Backported from Hirsute 1:2.11.1~dfsg-1ubuntu8 (LP: #1932161)
    - Fix FTBFS with Linux 5.10
    - Added Linux-5.9-ioctl-fix.patch

 -- Tim Gardner <email address hidden> Thu, 24 Jun 2021 15:47:49 +0000

Changed in dahdi-linux (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for dahdi-linux has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dahdi-linux (Ubuntu):
status: New → Confirmed
Changed in linux-hwe-5.11 (Ubuntu Focal):
status: New → Confirmed
Changed in linux-hwe-5.11 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers