dahdi-linux 1:2.10.2~dfsg-1ubuntu1 ADT test failure with linux-hwe-edge 4.13.0-16.19~16.04.3

Bug #1724866 reported by Seth Forshee on 2017-10-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dahdi-linux (Ubuntu)
Undecided
Marcelo Cerri
Nominated for Xenial by Marcelo Cerri
Xenial
Undecided
Unassigned

Bug Description

[Impact]

Currently the DKMS package fails to install in supported custom kernels that are based on 4.11 or 4.13. That includes the current 4.11 hwe-edge and the upcoming 4.13 hwe-edge kernels and some of the custom and cloud kernels as well.

[Test Case]

Install the DKMS package with the 4.13 hwe-edge kernel from -proposed. The package installation should proceed without any errors.

[Regression Potential]

Although new patches were added, the regression risk is very low since the new changes are conditionally compiled based on the kernel version.

Besides that the new package was tested with the following kernels in an amd64 environment:

- linux-generic 4.4
- linux-hwe 4.10
- linux-hwe-edge 4.11
- linux-hwe-edge 4.13 (from xenial-proposed)

[Original description]

Testing failed on:
    amd64: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/d/dahdi-linux/20171018_120650_9d912@/log.gz
    i386: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/i386/d/dahdi-linux/20171018_122220_9d912@/log.gz

Seth Forshee (sforshee) on 2017-10-19
tags: added: kernel-adt-failure
Seth Forshee (sforshee) on 2017-10-25
tags: added: kernel-adt-failure-hwe-edge-4.11
removed: kernel-adt-failure
tags: added: kernel-adt-failure-hwe-edge-4.13
removed: kernel-adt-failure-hwe-edge-4.11
Marcelo Cerri (mhcerri) on 2017-10-27
description: updated
Marcelo Cerri (mhcerri) on 2017-11-01
Changed in dahdi-linux (Ubuntu):
status: New → In Progress
assignee: nobody → Marcelo Cerri (mhcerri)

Hello Seth, or anyone else affected,

Accepted dahdi-linux into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/dahdi-linux/1:2.10.2~dfsg-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in dahdi-linux (Ubuntu):
status: In Progress → Fix Released
Changed in dahdi-linux (Ubuntu Xenial):
status: New → Fix Committed
Marcelo Cerri (mhcerri) on 2017-11-30
tags: added: verification-done verification-done-xenial
Brian Murray (brian-murray) wrote :

Could you please add some verification details rather than just flipping the tag?

Changed in dahdi-linux (Ubuntu Xenial):
status: Fix Committed → Incomplete
Robie Basak (racb) on 2017-12-06
tags: added: verification-needed verification-needed-xenial
removed: verification-done verification-done-xenial
Marcelo Cerri (mhcerri) wrote :

ADT tests are passing version for 1:2.10.2~dfsg-1ubuntu2 with kernel 4.13.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Marcelo Cerri (mhcerri) wrote :

Adding more details. I also have run the ADT tests for the following kernels to ensure there's no regressions:

- linux-generic 4.4
- linux-hwe 4.10
- linux-hwe-edge 4.11
- linux-hwe-edge 4.13

Łukasz Zemczak (sil2100) wrote :

Hey! I would generally be fine with publishing this package, but I would like someone to confirm something for me first. This package had a s390x autopkgtest regression on the 4.4 kernel:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/s390x/d/dahdi-linux/20171103_083601_36006@/log.gz

This is with the current version in xenial-proposed. All other arches passed, just not s390x. Currently they're also failing with the old dahdi-linux, but if you check the test history for xenial, I'd expect it to pass with the new version.

http://autopkgtest.ubuntu.com/packages/d/dahdi-linux/xenial/s390x

Is that a one-time issue?

Marcelo Cerri (mhcerri) wrote :

Hi, Lukazs.

I tried to install the DKMS package on a s390x machine to check what is going on and it fails trying to download the following package:

http://downloads.digium.com/pub/telephony/firmware/releases/dahdi-fwload-vpmadt032-1.25.0.tar.gz

The link is valid but the s390x machine can't access that URL, maybe due to firewall rules. Do you think the same might be true for the machines that run the ADT tests?

Marcelo Cerri (mhcerri) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dahdi-linux - 1:2.10.2~dfsg-1ubuntu2

---------------
dahdi-linux (1:2.10.2~dfsg-1ubuntu2) xenial; urgency=medium

  * Linux 4.11 and 4.13 compatibility (LP: #1724866)
    - debian/patches/kernel-compat-4.11.patch
    - debian/patches/kernel-compat-4.13.patch

 -- Marcelo Henrique Cerri <email address hidden> Fri, 27 Oct 2017 09:44:47 -0200

Changed in dahdi-linux (Ubuntu Xenial):
status: Incomplete → Fix Released

The verification of the Stable Release Update for dahdi-linux has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers