package cvsd 1.0.16 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Bug #474666 reported by Raul Silva on 2009-11-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cvsd (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cvsd

On Ubuntu 9.10 when installing package cvsd (package version 1.0.16) aptitude fails when (apparently) creating the repositories.

ProblemType: Package
AptOrdering:
 cvs: Install
 cvsd: Install
 cvs: Configure
 cvsd: Configure
Architecture: i386
Date: Wed Nov 4 17:28:41 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 2
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: cvsd 1.0.16
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: cvsd
Title: package cvsd 1.0.16 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
Uname: Linux 2.6.31-14-generic i686

Related branches

Raul Silva (raulpsilva) wrote :
Arthur de Jong (adejong) wrote :

The relevant part of the dpkg log is:

Setting up cvsd (1.0.16) ...
Adding group `cvsd' (GID 125) ...
Done.
Adding system user `cvsd' (UID 116) ...
Adding new user `cvsd' (UID 116) with group `cvsd' ...
Creating home directory `/var/lib/cvsd' ...
creating directory structure under /var/lib/cvsd... dpkg: error processing cvsd (--configure):
 subprocess installed post-installation script returned error exit status 2

Apparently creating the chroot jail under /var/lib/cvsd failed for some reason. Can you run 'cvsd-buildroot /var/lib/cvsd' by hand and see if that also fails. If that does not show more useful output could you do 'sh -x /usr/sbin/cvsd-buildroot /var/lib/cvsd' and see if that results in more useful output.

Can you also provide some more information on your system (e.g. which /bin/sh are you using).

Also, please consider including the output from the cvsd-buginfo script in this report.

Thanks.

James Sears (james-hn-sears) wrote :

Arthur - find attached, hopefully, the information you requested.

Arthur de Jong (adejong) wrote :

The only problem is that sudo is missing from the sh -x call but I found the problem anyway (the cvsd-buginfo output showed how far it got). The problem is that bash 4 handles the this statement:
  false || ( false && false )
differently from bash 3 when set -e is used (bash 4 terminates the script and 3 doesn't). Btw, dash behaves the same as bash 3.

Anyway, I will change the cvsd-buildroot script to use less && and || magic (which is a good thing anyway) and create a new release shortly (the upload will be to Debian but I guess Ubuntu will pick it up soon enough).

As a workaround you can edit the cvsd-buildroot script and comment out the set -e statement at the beginning. Attached is a minimal patch which also fixes the issue. Note that this is not the patch that will go into 1.0.18, for that see http://arthurdejong.org/viewvc/cvsd/cvsd-buildroot.in?r1=1.49&r2=1.50

The cvsd-buginfo also pointed me to a bug in that script (was there since 2006 apparently) (the wrong uname call). That will also be fixed in the next release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cvsd - 1.0.18

---------------
cvsd (1.0.18) unstable; urgency=low

  * use simpler shell semantics in cvsd-buildroot to fix a problem with bash 4
    (LP: #474666)
  * fix call to uname in the cvsd-buginfo script
 -- Ubuntu Archive Auto-Sync <email address hidden> Wed, 27 Jan 2010 01:31:41 +0000

Changed in cvsd (Ubuntu):
status: New → Fix Released
James Sears (james-hn-sears) wrote :

After emailing Arthur I am wondering who maintains this package for Ubuntu and when the patch will be applied?

Such that 9.10 will pick it up when I do a apt-get install cvsd.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers