curtin from xenial daily ppa not installable

Bug #1831757 reported by Ryan Harper on 2019-06-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
curtin (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

On Xenial

1. add-apt-repository --enable-source --yes ppa:curtin-dev/daily
2. apt-get install --no-install-recommends -qy curtin

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 curtin : Depends: probert but it is not installable
E: Unable to correct problems, you have held broken packages.
failed apt-get install --no-install-recommends -qy curtin

Related branches

Ryan Harper (raharper) wrote :
Changed in curtin (Ubuntu):
status: New → Fix Committed
Ryan Harper (raharper) wrote :

since probert is not yet in main, we can't have probert as a depends in any of the releases.

Changed in curtin (Ubuntu Xenial):
status: New → Fix Committed

Hello Ryan, or anyone else affected,

Accepted curtin into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/curtin/19.1-7-g37a7a0f4-0ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in curtin (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in curtin (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed-cosmic
Łukasz Zemczak (sil2100) wrote :

Hello Ryan, or anyone else affected,

Accepted curtin into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/curtin/19.1-7-g37a7a0f4-0ubuntu1~18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello Ryan, or anyone else affected,

Accepted curtin into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/curtin/19.1-7-g37a7a0f4-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Łukasz Zemczak (sil2100) wrote :

Hello Ryan, or anyone else affected,

Accepted curtin into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/curtin/19.1-7-g37a7a0f4-0ubuntu1~19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in curtin (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed-disco
Łukasz Zemczak (sil2100) wrote :

Please remember that this bug will require SRU verification. Since this is basically resolved through a dependency removal, the only test case is to check if the package is installable for all the supported series.

Ryan Harper (raharper) wrote :

Xenial manual verification that installing curtin from -proposed does not pull in probert package.

Ryan Harper (raharper) wrote :

Bionic manual verification that installing curtin from -proposed does not pull in probert package.

Ryan Harper (raharper) wrote :

Cosmic manual verification that installing curtin from -proposed does not pull in probert package.

Ryan Harper (raharper) wrote :

Disco manual verification that installing curtin from -proposed does not pull in probert package.

tags: added: verification-done verification-done-bionic verification-done-cosmic verification-done-disco verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-cosmic verification-needed-disco verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package curtin - 19.1-7-g37a7a0f4-0ubuntu1~19.04.1

---------------
curtin (19.1-7-g37a7a0f4-0ubuntu1~19.04.1) disco; urgency=medium

  * d/control: drop probert dependency, not yet in main (LP: #1831757)
  * New upstream snapshot. (LP: #1831772)
    - vmtests: determine block name via dname when verifying volume groups
    - vmtest: add Centos66/Centos70 FromBionic release and re-add tests
    - block-discover: add cli/API for exporting existing storage to config
    - vmtest: refactor test_network code for Eoan
    - curthoooks: disable daemons while reconfiguring mdadm
      [Michael Hudson-Doyle]
    - mdadm: fix install to existing raid [Michael Hudson-Doyle]
    - apt_proxy env var set but empty => do not setup any proxy
      [Paride Legovini]
    - release 19.1
    - vmtest: add missing skip_by_date on Eoan test_network_mtu
    - vmtest: remove skip_by_date on Disco Allindata test
    - block: support multipath devices in lookup and partition_kname
    - grub: add grub config to control os_prober,terminal settings in target
    - vmtest: add eoan tests [Paride Legovini]
    - vmtest: add dependency on python3-jsonschema [Paride Legovini]
    - Pylint compatibility with Python 3.7 [Paride Legovini]
    - vmtest: disable disco multipath test
    - vmtests: bump network mtu tests out a bit
    - Fix up yaml.load warnings
    - vmtest: disable trusty, it's dead jim
    - vmtest: reenable UEFI 4k tests, which got dropped when fixing
      subclassing.
    - vmtests: Add test_kernel_img_conf stub for PsuedoVMBaseClass
    - curthooks: chzdev_import must encode data if provided
    - vmtest: test for kernel-img conf on ubuntu only

 -- Ryan Harper <email address hidden> Wed, 05 Jun 2019 13:46:57 -0500

Changed in curtin (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for curtin has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package curtin - 19.1-7-g37a7a0f4-0ubuntu1~18.10.1

---------------
curtin (19.1-7-g37a7a0f4-0ubuntu1~18.10.1) cosmic; urgency=medium

  * d/control: drop probert dependency, not yet in main (LP: #1831757)
  * New upstream snapshot. (LP: #1831772)
    - vmtests: determine block name via dname when verifying volume groups
    - vmtest: add Centos66/Centos70 FromBionic release and re-add tests
    - block-discover: add cli/API for exporting existing storage to config
    - vmtest: refactor test_network code for Eoan
    - curthoooks: disable daemons while reconfiguring mdadm
      [Michael Hudson-Doyle]
    - mdadm: fix install to existing raid [Michael Hudson-Doyle]
    - apt_proxy env var set but empty => do not setup any proxy
      [Paride Legovini]
    - release 19.1
    - vmtest: add missing skip_by_date on Eoan test_network_mtu
    - vmtest: remove skip_by_date on Disco Allindata test
    - block: support multipath devices in lookup and partition_kname
    - grub: add grub config to control os_prober,terminal settings in target
    - vmtest: add eoan tests [Paride Legovini]
    - vmtest: add dependency on python3-jsonschema [Paride Legovini]
    - Pylint compatibility with Python 3.7 [Paride Legovini]
    - vmtest: disable disco multipath test
    - vmtests: bump network mtu tests out a bit
    - Fix up yaml.load warnings
    - vmtest: disable trusty, it's dead jim
    - vmtest: reenable UEFI 4k tests, which got dropped when fixing
      subclassing.
    - vmtests: Add test_kernel_img_conf stub for PsuedoVMBaseClass
    - curthooks: chzdev_import must encode data if provided
    - vmtest: test for kernel-img conf on ubuntu only
    - Setup kernel-img.conf like base-installer/live-installer did.
      [Dimitri John Ledkov]
    - zfs: pass pool and fs properties to zpool_create
      [Jean-Baptiste Lallement]
    - block_meta: pass lvm_partition size through human2bytes
      [Michael Hudson-Doyle]
    - clear-holders: refactor bcache shutdown and add longer timeout
    - schema-validate-storage: remove unused imports [Paride Legovini]
    - add subcommand schema for storage-config validation
    - clear-holders: wipe raid members at data offsets when not assembled
    - Add support for s390 DASD devices
    - vmtest: skip DiscoTestAllindata while initrd lacks crypto modules
    - block_meta: allow passing a dm_crypt key by keyfile
      [Michael Hudson-Doyle]
    - ChrootableTarget: add /run to mounts for redhat targets
    - vmtest: consolidate vm mem config, defaults via release, env override

 -- Ryan Harper <email address hidden> Wed, 05 Jun 2019 13:32:52 -0500

Changed in curtin (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package curtin - 19.1-7-g37a7a0f4-0ubuntu1~18.04.1

---------------
curtin (19.1-7-g37a7a0f4-0ubuntu1~18.04.1) bionic; urgency=medium

  * d/control: drop probert dependency, not yet in main (LP: #1831757)
  * New upstream snapshot. (LP: #1831772)
    - vmtests: determine block name via dname when verifying volume groups
    - vmtest: add Centos66/Centos70 FromBionic release and re-add tests
    - block-discover: add cli/API for exporting existing storage to config
    - vmtest: refactor test_network code for Eoan
    - curthoooks: disable daemons while reconfiguring mdadm
      [Michael Hudson-Doyle]
    - mdadm: fix install to existing raid [Michael Hudson-Doyle]
    - apt_proxy env var set but empty => do not setup any proxy
      [Paride Legovini]
    - release 19.1
    - vmtest: add missing skip_by_date on Eoan test_network_mtu
    - vmtest: remove skip_by_date on Disco Allindata test
    - block: support multipath devices in lookup and partition_kname
    - grub: add grub config to control os_prober,terminal settings in target
    - vmtest: add eoan tests [Paride Legovini]
    - vmtest: add dependency on python3-jsonschema [Paride Legovini]
    - Pylint compatibility with Python 3.7 [Paride Legovini]
    - vmtest: disable disco multipath test
    - vmtests: bump network mtu tests out a bit
    - Fix up yaml.load warnings
    - vmtest: disable trusty, it's dead jim
    - vmtest: reenable UEFI 4k tests, which got dropped when fixing
      subclassing.
    - vmtests: Add test_kernel_img_conf stub for PsuedoVMBaseClass
    - curthooks: chzdev_import must encode data if provided
    - vmtest: test for kernel-img conf on ubuntu only
    - Setup kernel-img.conf like base-installer/live-installer did.
      [Dimitri John Ledkov]
    - zfs: pass pool and fs properties to zpool_create
      [Jean-Baptiste Lallement]
    - block_meta: pass lvm_partition size through human2bytes
      [Michael Hudson-Doyle]
    - clear-holders: refactor bcache shutdown and add longer timeout
    - schema-validate-storage: remove unused imports [Paride Legovini]
    - add subcommand schema for storage-config validation
    - clear-holders: wipe raid members at data offsets when not assembled
    - Add support for s390 DASD devices
    - vmtest: skip DiscoTestAllindata while initrd lacks crypto modules
    - block_meta: allow passing a dm_crypt key by keyfile
      [Michael Hudson-Doyle]
    - ChrootableTarget: add /run to mounts for redhat targets
    - vmtest: consolidate vm mem config, defaults via release, env override

 -- Ryan Harper <email address hidden> Wed, 05 Jun 2019 12:19:06 -0500

Changed in curtin (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package curtin - 19.1-7-g37a7a0f4-0ubuntu1~16.04.1

---------------
curtin (19.1-7-g37a7a0f4-0ubuntu1~16.04.1) xenial; urgency=medium

  * d/control: drop probert dependency for Xenial (LP: #1831757)
  * New upstream snapshot. (LP: #1831772)
    - vmtests: determine block name via dname when verifying volume groups
    - vmtest: add Centos66/Centos70 FromBionic release and re-add tests
    - block-discover: add cli/API for exporting existing storage to config
    - vmtest: refactor test_network code for Eoan
    - curthoooks: disable daemons while reconfiguring mdadm
      [Michael Hudson-Doyle]
    - mdadm: fix install to existing raid [Michael Hudson-Doyle]
    - apt_proxy env var set but empty => do not setup any proxy
      [Paride Legovini]
    - release 19.1
    - vmtest: add missing skip_by_date on Eoan test_network_mtu
    - vmtest: remove skip_by_date on Disco Allindata test
    - block: support multipath devices in lookup and partition_kname
    - grub: add grub config to control os_prober,terminal settings in target
    - vmtest: add eoan tests [Paride Legovini]
    - vmtest: add dependency on python3-jsonschema [Paride Legovini]
    - Pylint compatibility with Python 3.7 [Paride Legovini]
    - vmtest: disable disco multipath test
    - vmtests: bump network mtu tests out a bit
    - Fix up yaml.load warnings
    - vmtest: disable trusty, it's dead jim
    - vmtest: reenable UEFI 4k tests, which got dropped when fixing
      subclassing.
    - vmtests: Add test_kernel_img_conf stub for PsuedoVMBaseClass
    - curthooks: chzdev_import must encode data if provided
    - vmtest: test for kernel-img conf on ubuntu only
    - Setup kernel-img.conf like base-installer/live-installer did.
      [Dimitri John Ledkov]
    - zfs: pass pool and fs properties to zpool_create
      [Jean-Baptiste Lallement]
    - block_meta: pass lvm_partition size through human2bytes
      [Michael Hudson-Doyle]
    - clear-holders: refactor bcache shutdown and add longer timeout
    - schema-validate-storage: remove unused imports [Paride Legovini]
    - add subcommand schema for storage-config validation
    - clear-holders: wipe raid members at data offsets when not assembled
    - Add support for s390 DASD devices
    - vmtest: skip DiscoTestAllindata while initrd lacks crypto modules
    - block_meta: allow passing a dm_crypt key by keyfile
      [Michael Hudson-Doyle]
    - ChrootableTarget: add /run to mounts for redhat targets
    - vmtest: consolidate vm mem config, defaults via release, env override

 -- Ryan Harper <email address hidden> Wed, 05 Jun 2019 11:59:57 -0500

Changed in curtin (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers