Activity log for bug #1807978

Date Who What changed Old value New value Message
2018-12-11 15:17:54 Ryan Harper bug added bug
2018-12-11 20:21:47 Scott Moser bug task added open-iscsi (Ubuntu)
2018-12-11 20:38:11 Scott Moser open-iscsi (Ubuntu): status New Confirmed
2018-12-11 20:38:15 Scott Moser open-iscsi (Ubuntu): importance Undecided High
2018-12-11 20:38:21 Scott Moser curtin (Ubuntu): status New Invalid
2018-12-11 22:47:02 Steve Langasek open-iscsi (Ubuntu): status Confirmed Triaged
2018-12-11 22:47:36 Steve Langasek tags curtin-vmtest curtin-vmtest regression-update
2018-12-11 23:10:40 Launchpad Janitor merge proposal linked https://code.launchpad.net/~raharper/ubuntu/+source/open-iscsi/+git/open-iscsi/+merge/360760
2018-12-12 00:02:58 Scott Moser summary vmtest: iscsi tests failing on cosmic/disco vmtest: iscsi/LVM tests failing on cosmic/disco
2018-12-12 00:08:16 Scott Moser nominated for series Ubuntu Bionic
2018-12-12 00:08:16 Scott Moser bug task added open-iscsi (Ubuntu Bionic)
2018-12-12 00:08:16 Scott Moser bug task added curtin (Ubuntu Bionic)
2018-12-12 00:08:16 Scott Moser nominated for series Ubuntu Cosmic
2018-12-12 00:08:16 Scott Moser bug task added open-iscsi (Ubuntu Cosmic)
2018-12-12 00:08:16 Scott Moser bug task added curtin (Ubuntu Cosmic)
2018-12-12 00:08:25 Scott Moser curtin (Ubuntu Bionic): status New Invalid
2018-12-12 00:08:28 Scott Moser curtin (Ubuntu Cosmic): status New Invalid
2018-12-12 00:08:36 Scott Moser open-iscsi (Ubuntu Bionic): status New In Progress
2018-12-12 00:08:39 Scott Moser open-iscsi (Ubuntu Cosmic): status New In Progress
2018-12-12 00:08:43 Scott Moser open-iscsi (Ubuntu Bionic): importance Undecided High
2018-12-12 00:08:45 Scott Moser open-iscsi (Ubuntu Cosmic): importance Undecided High
2018-12-12 00:08:49 Scott Moser open-iscsi (Ubuntu): assignee Scott Moser (smoser)
2018-12-12 00:08:52 Scott Moser open-iscsi (Ubuntu Bionic): assignee Scott Moser (smoser)
2018-12-12 00:08:54 Scott Moser open-iscsi (Ubuntu Cosmic): assignee Scott Moser (smoser)
2018-12-12 00:15:50 Launchpad Janitor merge proposal linked https://code.launchpad.net/~smoser/ubuntu/+source/open-iscsi/+git/open-iscsi/+merge/360763
2018-12-12 00:17:15 Launchpad Janitor merge proposal linked https://code.launchpad.net/~smoser/ubuntu/+source/open-iscsi/+git/open-iscsi/+merge/360764
2018-12-12 00:41:20 Scott Moser description TestIscsiBasic and other Iscsi tests on Cosmic/Disco are failing in vmtest on jenkins. - looked some at curtin at iscsi failures cosmic, disco - 604 was first fail like this. cosmic 20181204 disco 20181129 https://jenkins.ubuntu.com/server/job/curtin-vmtest-devel-amd64/604/consoleFull 602 PASSED and did run disco cosmic 20181114 disco 20181109 - seems likely tied to open-iscsi upload https://bugs.launchpad.net/ubuntu/+source/open-iscsi/+bug/1755858 or https://bugs.launchpad.net/ubuntu/+source/open-iscsi/+bug/1802354 I want to revert iscsi and see if it fixes. === Begin SRU Template === [Impact] This bug results in lvm devices on top of iscsi block devices not being available to the system. The journal will show messages like: [ 17.666655] systemd[1]: dev-disk-by\x2duuid-a98f706b\x2db064\x2d4682\x2d8eb2\x2d6c2c1284060c.device: Dependency Before=network-online.target ignored (.device units cannot be delayed) And ultimately TIME [0m] Timed out waiting for device dev-di...device. [Test Case] This can be tested by running curtin's vmtest test harness. A run like this should suffice: env CURTIN_VMTEST_ADD_REPOS=proposed \ CURTIN_VMTEST_UPGRADE_PACKAGES=open-iscsi \ ./tools/jenkins-runner \ tests/vmtests/test_iscsi.py \ tests/vmtests/test_lvm_iscsi.py \ tests/vmtests/test_mdadm_iscsi.py \ tests/vmtests/test_basic.py That is all the iscsi based tests and a 'basic' install for good measure. [Regression Potential] Chance of regression is hopefully low, and hopefully lower now than before. Regression is almost certainly limited to iscsi devices. [Other Info] An attempt to fix bug 1802354 added a udev rule for open-iscsi that looked like: SUBSYSTEM=="block", ACTION=="add", ENV{ID_PATH}=="*-iscsi-*", ENV{SYSTEMD_WANTS}="iscsid.service" The problem was ENV{SYSTEMD_WANTS}="iscsid.service". The '=' operator would truncate the udev-added "wants". lvm also utilized SYSTEMD_WANTS, and the two would conflict. This is the second regression fix to the open-iscsi package as a result of the fix for bug 1755858. The regression was caught by curtin's test harness (vmtest). Specifically the following tests would fail: tests/vmtests/test_lvm_iscsi.py:BionicTestIscsiLvm tests/vmtests/test_lvm_iscsi.py:CosmicTestIscsiLvm tests/vmtests/test_lvm_iscsi.py:DiscoTestIscsiLvm Related Bugs: * bug 1755858: iscsid autostarts on all servers when it has nothing to do * bug 1802354: vmtest: iscsi tests failing on cosmic/disco === End SRU Template === TestIscsiBasic and other Iscsi tests on Cosmic/Disco are failing in vmtest on jenkins.   - looked some at curtin at iscsi failures cosmic, disco     - 604 was first fail like this.            cosmic 20181204            disco 20181129       https://jenkins.ubuntu.com/server/job/curtin-vmtest-devel-amd64/604/consoleFull       602 PASSED and did run disco            cosmic 20181114            disco 20181109     - seems likely tied to open-iscsi upload https://bugs.launchpad.net/ubuntu/+source/open-iscsi/+bug/1755858 or https://bugs.launchpad.net/ubuntu/+source/open-iscsi/+bug/1802354   I want to revert iscsi and see if it fixes.
2018-12-12 20:07:56 Brian Murray open-iscsi (Ubuntu Cosmic): status In Progress Fix Committed
2018-12-12 20:07:59 Brian Murray bug added subscriber Ubuntu Stable Release Updates Team
2018-12-12 20:08:01 Brian Murray bug added subscriber SRU Verification
2018-12-12 20:08:05 Brian Murray tags curtin-vmtest regression-update curtin-vmtest regression-update verification-needed verification-needed-cosmic
2018-12-12 20:12:55 Brian Murray open-iscsi (Ubuntu Bionic): status In Progress Fix Committed
2018-12-12 20:13:01 Brian Murray tags curtin-vmtest regression-update verification-needed verification-needed-cosmic curtin-vmtest regression-update verification-needed verification-needed-bionic verification-needed-cosmic
2018-12-13 03:00:45 Launchpad Janitor open-iscsi (Ubuntu): status Triaged Fix Released
2018-12-14 22:32:10 Scott Moser attachment added console log of test verification for cosmic https://bugs.launchpad.net/ubuntu/+source/curtin/+bug/1807978/+attachment/5222387/+files/cosmic-console.log
2018-12-14 22:33:02 Scott Moser attachment added vmtest output/ from test verification for cosmic https://bugs.launchpad.net/ubuntu/+source/curtin/+bug/1807978/+attachment/5222388/+files/cosmic-output.tar.gz
2018-12-14 22:33:33 Scott Moser tags curtin-vmtest regression-update verification-needed verification-needed-bionic verification-needed-cosmic curtin-vmtest regression-update verification-done-cosmic verification-needed verification-needed-bionic
2018-12-14 23:01:10 Scott Moser attachment added console log of test verification for bionic https://bugs.launchpad.net/ubuntu/+source/curtin/+bug/1807978/+attachment/5222399/+files/bionic-console.log
2018-12-14 23:01:47 Scott Moser attachment added vmtest output/ from test verification for bionic https://bugs.launchpad.net/ubuntu/+source/curtin/+bug/1807978/+attachment/5222400/+files/bionic-output.tar.gz
2018-12-14 23:02:30 Scott Moser tags curtin-vmtest regression-update verification-done-cosmic verification-needed verification-needed-bionic curtin-vmtest regression-update verification-done verification-done-bionic verification-done-cosmic
2018-12-19 16:24:16 Scott Moser description === Begin SRU Template === [Impact] This bug results in lvm devices on top of iscsi block devices not being available to the system. The journal will show messages like: [ 17.666655] systemd[1]: dev-disk-by\x2duuid-a98f706b\x2db064\x2d4682\x2d8eb2\x2d6c2c1284060c.device: Dependency Before=network-online.target ignored (.device units cannot be delayed) And ultimately TIME [0m] Timed out waiting for device dev-di...device. [Test Case] This can be tested by running curtin's vmtest test harness. A run like this should suffice: env CURTIN_VMTEST_ADD_REPOS=proposed \ CURTIN_VMTEST_UPGRADE_PACKAGES=open-iscsi \ ./tools/jenkins-runner \ tests/vmtests/test_iscsi.py \ tests/vmtests/test_lvm_iscsi.py \ tests/vmtests/test_mdadm_iscsi.py \ tests/vmtests/test_basic.py That is all the iscsi based tests and a 'basic' install for good measure. [Regression Potential] Chance of regression is hopefully low, and hopefully lower now than before. Regression is almost certainly limited to iscsi devices. [Other Info] An attempt to fix bug 1802354 added a udev rule for open-iscsi that looked like: SUBSYSTEM=="block", ACTION=="add", ENV{ID_PATH}=="*-iscsi-*", ENV{SYSTEMD_WANTS}="iscsid.service" The problem was ENV{SYSTEMD_WANTS}="iscsid.service". The '=' operator would truncate the udev-added "wants". lvm also utilized SYSTEMD_WANTS, and the two would conflict. This is the second regression fix to the open-iscsi package as a result of the fix for bug 1755858. The regression was caught by curtin's test harness (vmtest). Specifically the following tests would fail: tests/vmtests/test_lvm_iscsi.py:BionicTestIscsiLvm tests/vmtests/test_lvm_iscsi.py:CosmicTestIscsiLvm tests/vmtests/test_lvm_iscsi.py:DiscoTestIscsiLvm Related Bugs: * bug 1755858: iscsid autostarts on all servers when it has nothing to do * bug 1802354: vmtest: iscsi tests failing on cosmic/disco === End SRU Template === TestIscsiBasic and other Iscsi tests on Cosmic/Disco are failing in vmtest on jenkins.   - looked some at curtin at iscsi failures cosmic, disco     - 604 was first fail like this.            cosmic 20181204            disco 20181129       https://jenkins.ubuntu.com/server/job/curtin-vmtest-devel-amd64/604/consoleFull       602 PASSED and did run disco            cosmic 20181114            disco 20181109     - seems likely tied to open-iscsi upload https://bugs.launchpad.net/ubuntu/+source/open-iscsi/+bug/1755858 or https://bugs.launchpad.net/ubuntu/+source/open-iscsi/+bug/1802354   I want to revert iscsi and see if it fixes. === Begin SRU Template === [Impact] This bug results in lvm devices on top of iscsi block devices not being available to the system. The journal will show messages like:   [ 17.666655] systemd[1]: dev-disk-by\x2duuid-a98f706b\x2db064\x2d4682\x2d8eb2\x2d6c2c1284060c.device: Dependency Before=network-online.target ignored (.device units cannot be delayed) And ultimately  TIME [0m] Timed out waiting for device dev-di...device. [Test Case] This can be tested by running curtin's vmtest test harness. A run like this should suffice: env CURTIN_VMTEST_ADD_REPOS=proposed \     CURTIN_VMTEST_UPGRADE_PACKAGES=open-iscsi \     ./tools/jenkins-runner \        tests/vmtests/test_iscsi.py \        tests/vmtests/test_lvm_iscsi.py \        tests/vmtests/test_mdadm_iscsi.py \        tests/vmtests/test_basic.py That is all the iscsi based tests and a 'basic' install for good measure. [Regression Potential] Chance of regression is hopefully low, and hopefully lower now than before. Regression is almost certainly limited to iscsi devices. [Other Info] An attempt to fix bug 1802354 added a udev rule for open-iscsi that looked like:   SUBSYSTEM=="block", ACTION=="add", ENV{ID_PATH}=="*-iscsi-*", ENV{SYSTEMD_WANTS}="iscsid.service" The problem was ENV{SYSTEMD_WANTS}="iscsid.service". The '=' operator would truncate the udev-added "wants". lvm also utilized SYSTEMD_WANTS, and the two would conflict. This is the second regression fix to the open-iscsi package as a result of the fix for bug 1755858. The regression was caught by curtin's test harness (vmtest). Specifically the following tests would fail:  tests/vmtests/test_lvm_iscsi.py:BionicTestIscsiLvm  tests/vmtests/test_lvm_iscsi.py:CosmicTestIscsiLvm  tests/vmtests/test_lvm_iscsi.py:DiscoTestIscsiLvm Related Bugs:  * bug 1755858: iscsid autostarts on all servers when it has nothing to do  * bug 1802354: iscsid does not run if there are only initramfs initiated targets === End SRU Template === TestIscsiBasic and other Iscsi tests on Cosmic/Disco are failing in vmtest on jenkins.   - looked some at curtin at iscsi failures cosmic, disco     - 604 was first fail like this.            cosmic 20181204            disco 20181129       https://jenkins.ubuntu.com/server/job/curtin-vmtest-devel-amd64/604/consoleFull       602 PASSED and did run disco            cosmic 20181114            disco 20181109     - seems likely tied to open-iscsi upload https://bugs.launchpad.net/ubuntu/+source/open-iscsi/+bug/1755858 or https://bugs.launchpad.net/ubuntu/+source/open-iscsi/+bug/1802354   I want to revert iscsi and see if it fixes.
2018-12-19 16:31:41 Launchpad Janitor open-iscsi (Ubuntu Bionic): status Fix Committed Fix Released
2018-12-19 16:31:52 Brian Murray removed subscriber Ubuntu Stable Release Updates Team
2018-12-19 16:32:34 Launchpad Janitor open-iscsi (Ubuntu Cosmic): status Fix Committed Fix Released
2019-01-07 14:16:19 Scott Moser summary vmtest: iscsi/LVM tests failing on cosmic/disco vmtest: open-iscsi iscsi/LVM tests failing on cosmic/disco