SRU Request to fix Curl Segfault

Bug #73447 reported by Cody A.W. Somerville on 2006-11-27
18
Affects Status Importance Assigned to Milestone
curl (Ubuntu)
Undecided
Unassigned
Edgy
Low
Cody A.W. Somerville

Bug Description

Binary package hint: curl

Request to apply very small patch to curl package to fix segfault bug.

Bugs:
https://launchpad.net/distros/ubuntu/+source/bzflag/+bug/68074
http://sourceforge.net/support/tracker.php?aid=1523466

This bug affects individuals using programs that make use of the Curl lib.

This bug was introduced in Curl 5.15.4 (which is in Edgy), has been fixed upstream in CVS, and later released in Curl 5.15.5 (which is in Feisty).

description: updated
Colin Watson (cjwatson) wrote :

Approved for edgy-proposed.

Colin Watson (cjwatson) on 2006-12-18
Changed in curl:
status: Unconfirmed → Confirmed
Changed in curl:
assignee: nobody → cody-somerville
importance: Undecided → Low

Subscribed Ubuntu Sponsors for main as I'm not a core-dev and will require a sponsor to upload.

Daniel T Chen (crimsun) wrote :

Adjusted edgy-proposed versioning and uploaded.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Mon, 27 Nov 2006 07:12:42 -0400
Source: curl
Binary: libcurl3-dbg libcurl3 libcurl3-dev libcurl3-gnutls-dev libcurl3-openssl-
dev libcurl3-gnutls curl
Architecture: source
Version: 7.15.4-1ubuntu2.1~proposed1
Distribution: edgy-proposed
Urgency: low
Maintainer: Domenico Andreoli <email address hidden>
Changed-By: Cody A.W. Somerville <email address hidden>
Description:
 curl - Get a file from an HTTP, HTTPS, FTP or GOPHER server
 libcurl3 - Multi-protocol file transfer library
 libcurl3-dbg - libcurl compiled with debug symbols
 libcurl3-dev - Transitional package to libcurl3-openssl-dev
 libcurl3-gnutls - Multi-protocol file transfer library
 libcurl3-gnutls-dev - Development files and documentation for libcurl
 libcurl3-openssl-dev - Development files and documentation for libcurl
Changes:
 curl (7.15.4-1ubuntu2.1~proposed1) edgy-proposed; urgency=low
 .
   * lib/multi.c: Upstream patch to fix segmentation fault.
    (Closes Ubuntu: #68074, SRU bug #73447).
   * Reference: http://sourceforge.net/support/tracker.php?aid=1523466.
Files:
 02892de1257443a1d677a5c80bbcfe77 962 web optional curl_7.15.4-1ubuntu2.1~propos
ed1.dsc
 7a87d772e87e2fe9df9c38193d642d10 18958 web optional curl_7.15.4-1ubuntu2.1~prop
osed1.diff.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFFnELGe9GwFciKvaMRAjEzAJ9CNsCCqytswize3iCNMkf8RPrltwCdEiKu
eH/hgi7QvP54Ha5Tsytp/mM=
=rX+i
-----END PGP SIGNATURE-----

Tollef Fog Heen (tfheen) wrote :

Accepted into edgy-proposed.

Changed in curl:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

This has been fixed in Feisty in 7.5.15.

Changed in curl:
status: Unconfirmed → Fix Released
Martin Pitt (pitti) wrote :

Cody, please go ahead with QA testing for this according to https://wiki.ubuntu.com/StableReleaseUpdates.

Scott Kitterman (kitterman) wrote :

I'd be glad to try and verify this fix if someone would post the steps to reproduce the problem.

Martin Meredith (mez) wrote :
Michael Vogt (mvo) wrote :

I verified the fix. It can go into edgy-updates now.

I used the callsign/password that I also used in the forum to connect. The second connect gave me a segfault.
After applying the update I was able to connect/disconnect 10 times without a single segfault.

I will mark this verification-done.

Martin Pitt (pitti) wrote :

I did a no-change upload and accepted it into feisty-updates.

Changed in curl:
status: Fix Committed → Fix Released

I hope you mean edgy-updates.

On 5/2/07, Martin Pitt <email address hidden> wrote:
>
> I did a no-change upload and accepted it into feisty-updates.
>
> ** Changed in: curl (Ubuntu Edgy)
> Status: Fix Committed => Fix Released
>
> --
> SRU Request to fix Curl Segfault
> https://bugs.launchpad.net/bugs/73447
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--

Firefox (www.getfirefox.com) -- A browser you can trust

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers