libcurl4-gnutls-dev:i386 and libcurl4-gnutls-dev:amd64 conflict on shared file '/usr/include/curl/curlbuild.h'

Bug #1668741 reported by Daniel Klauer on 2017-02-28
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
curl (Ubuntu)
High
Unassigned

Bug Description

libcurl4-gnutls-dev:i386 and libcurl4-gnutls-dev:amd64 can't be installed together because they both contain a file '/usr/include/curl/curlbuild.h' but it's different.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: libcurl4-gnutls-dev (not installed)
ProcVersionSignature: Ubuntu 4.4.0-64.85-generic 4.4.44
Uname: Linux 4.4.0-64-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.5
AptOrdering:
 libcurl4-gnutls-dev: Install
 libcurl4-gnutls-dev: Configure
 NULL: ConfigurePending
Architecture: amd64
Date: Tue Feb 28 20:54:17 2017
DpkgTerminalLog:
 Preparing to unpack .../libcurl4-gnutls-dev_7.47.0-1ubuntu2.2_amd64.deb ...
 Unpacking libcurl4-gnutls-dev:amd64 (7.47.0-1ubuntu2.2) ...
 dpkg: error processing archive /var/cache/apt/archives/libcurl4-gnutls-dev_7.47.0-1ubuntu2.2_amd64.deb (--unpack):
  trying to overwrite shared '/usr/include/curl/curlbuild.h', which is different from other instances of package libcurl4-gnutls-dev:amd64
DuplicateSignature:
 package:libcurl4-gnutls-dev:(not installed)
 Unpacking libcurl4-gnutls-dev:amd64 (7.47.0-1ubuntu2.2) ...
 dpkg: error processing archive /var/cache/apt/archives/libcurl4-gnutls-dev_7.47.0-1ubuntu2.2_amd64.deb (--unpack):
  trying to overwrite shared '/usr/include/curl/curlbuild.h', which is different from other instances of package libcurl4-gnutls-dev:amd64
ErrorMessage: trying to overwrite shared '/usr/include/curl/curlbuild.h', which is different from other instances of package libcurl4-gnutls-dev:amd64
InstallationDate: Installed on 2016-08-25 (187 days ago)
InstallationMedia: Xubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.19
SourcePackage: curl
Title: package libcurl4-gnutls-dev (not installed) failed to install/upgrade: trying to overwrite shared '/usr/include/curl/curlbuild.h', which is different from other instances of package libcurl4-gnutls-dev:amd64
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel Klauer (daniel.c.klauer) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in curl (Ubuntu):
status: New → Confirmed
tags: removed: need-duplicate-check
Changed in hundredpapercuts:
status: New → Confirmed
Changed in curl (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers