Cura 3.3.1 not working correctly

Bug #1827859 reported by Eduardo Righes
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
cura (Ubuntu)
Undecided
Unassigned

Bug Description

Installed cura 3.3.1 from Ubuntu 19.04 repo and it does not show text correctly on buttons/menus (e.g. on first launch I cannot see agree/disagree/ok/cancel on the screen). If I ignore that and try to load a model, it reports that failed to load the file.

Previously I have installed cura downloading from Ultimaker website and that one worked correctly. (That was version 3.6 and now version 4.0 is available).

This is a new Ubuntu 19.04 install. Just tried to install with "sudo apt-get install cura" and accepted the default values.

Eduardo Righes (eemmrr)
description: updated
Revision history for this message
mibus (mibus) wrote :

Affected me after my upgrade to 19.04 too -- looks the same as https://bugzilla.redhat.com/show_bug.cgi?id=1708956

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cura (Ubuntu):
status: New → Confirmed
Revision history for this message
Luis Llana Díaz (luis-llana) wrote :

I have just installed 19.10 and I have the same problem

Revision history for this message
Paul Ortyl (ortylp) wrote :

Hints for those stuck with broken cura:

* there is a packaged release as AppImage (the official Linux release of cura) https://github.com/Ultimaker/Cura/releases (I did not test if it works)

* I am building from source, see https://github.com/Ultimaker/Cura/issues/6611

Revision history for this message
Logan Rosen (logan) wrote :

Thank you for reporting this bug to Ubuntu.

Ubuntu 19.10 (eoan) reached end-of-life on July 17, 2020.
Ubuntu 19.04 (disco) reached end-of-life on January 23, 2020.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test. If you then find the bug is still present in the newer Ubuntu version, please add a comment here telling us which new version it is in.

Changed in cura (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Gregor Riepl (onitake) wrote :

This has been a long-time issue with the way Cura renders the UI.

We've finally gotten a (hopefully permanent) fix from upstream into Debian, which was already auto-promoted to the Ubuntu repos: https://launchpad.net/ubuntu/+source/cura/4.8-3
The fix will also be in the next upstream Cura release, but we decided to backport it so it will land in the next Debian stable release (which is already in soft-freeze).

Please reopen if this version doesn't fix it for you.
Thanks!

Changed in cura (Ubuntu):
status: Incomplete → Fix Committed
Revision history for this message
Gregor Riepl (onitake) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.