each printed page starts with line of 'garbage' (Laserjet 4+ over network)

Bug #87597 reported by Wit Wilinski on 2007-02-24
14
Affects Status Importance Assigned to Milestone
cupsys (Ubuntu)
Undecided
Pascal De Vuyst
Nominated for Feisty by Wit Wilinski
foomatic-filters (Baltix)
Undecided
Unassigned
foomatic-filters (Ubuntu)
High
Till Kamppeter
Nominated for Feisty by Wit Wilinski

Bug Description

The printing system in feisty got broken by one of the most recent updates (last few days). Each page (checked both ljet4 and hpijs drivers) prints with a line of ASCII garbage (some data not understood by the printer).

Prints are fine on Kubuntu 6.10 with the same settings.

I've got a Laserjet 4+ printer running over ethernet with HP JetDirect module. It used to work fine on feisty until one of recent upgrades. After it got broken, I tried downgrading *cups* to 1.2.7, but it didn't help. It could be something with openprinting PPD files, but I'm not sure whether it is the cause...

Can you please provide the information as described here: https://wiki.ubuntu.com/DebuggingPrintingProblems. You may skip the printer detection part.

Changed in cupsys:
assignee: nobody → pascal-devuyst
status: Unconfirmed → Needs Info
Wit Wilinski (wit-wilinski) wrote :

Same here,

HP laserjet 5L, printerdriver :ljet4 (recommended)
Connect : Network Printer Windows Printer (SMB)

also testet with UNIX (LPD) with the same error on all pages.

> It could be something with openprinting PPD files, but I'm not sure
> whether it is the cause...

These are the only two printing related packages that entered the archive on 22/02/2007 (you can check this on https://lists.ubuntu.com/archives/feisty-changes/):
* cupsys (1.2.8-0ubuntu2)
* foomatic-filters (3.0.2-20070220-0ubuntu1)

Since downgrading cupsys does not solve your problem, that only leaves foomatic-filters. Can you try to downgrade foomatic-filters to the previous version and let us know if this fixes your problem.

task cupsys Rejected
added task foomatic-filters

Changed in foomatic-filters:
status: Unconfirmed → Rejected
Changed in cupsys:
status: Needs Info → Rejected
Changed in foomatic-filters:
assignee: nobody → pascal-devuyst
status: Unconfirmed → Needs Info
Michael S. (jellicle) wrote :

I had a similar problem; a line or two of binary garbage printed at the top of the page, followed by a relatively normal rest of the page. Worked fine in Edgy. I have a Laserjet 3200 connected to the network.

I followed the advice in the previous comment, downgrading foomatic-filters (actually I downgraded all of the foomatic packages, to the set which is dated around 20060918-20060925). Printing now works without the garbage. Culprit identified: foomatic.

Changed in foomatic-filters:
assignee: pascal-devuyst → nobody
importance: Undecided → Medium
status: Needs Info → Confirmed
Wit Wilinski (wit-wilinski) wrote :

Helped for me too - Laserjet 4+ (hpijs) working correctly after downgrade :)

Till Kamppeter (till-kamppeter) wrote :

Can you exactly tell which is the newest foomatic-filters package where the problem does not occur and which is the oldest where it occurs.

Till Kamppeter (till-kamppeter) wrote :

Can you print into a file and attach both the input file and the output?

To print into a file add "FileDevice Yes" to /etc/cups/cupsd.conf and restart CUPS with "/etc/init.d/cupsys restart". The create a print queue with the same printer model and driver but with the URI "file:/tmp/printout".

Try also to set "debug=1" in /etc/foomatic/filters.conf and send the print job again, then post the files

/tmp/foomatic-rip.log
/tmp/foomatic-rip.ps
/tmp/printout

and your input file here.

Can you also send /tmp/printout directly to your printer?

Use

nc -w1[your printer's IP] 9100 < /tmp/printout

for that.

Till Kamppeter (till-kamppeter) wrote :

I could reproduce it and fix the bug. Please test by replacing /usr/bin/foomatic-rip with the attached file. Package will come next week.

Changed in foomatic-filters:
assignee: nobody → till-kamppeter
importance: Medium → High
status: Confirmed → In Progress
Wit Wilinski (wit-wilinski) wrote :

The file You've provided fixes the problem, indeed.
Garbage is gone, page comes out clean.

(Tested on Laserjet 4+ over LAN, hpijs driver)

Changed in foomatic-filters:
status: In Progress → Fix Committed
Changed in foomatic-filters:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers