No drivers for Brother MFC-5440CN printer even though they are GPL

Bug #85539 reported by Michael Stempin
4
Affects Status Importance Assigned to Milestone
cupsys (Baltix)
New
Undecided
Unassigned
cupsys (Ubuntu)
New
Undecided
Unassigned

Bug Description

There are no drivers included in Feisty Herd 4 for Brother's MFC-5440CN Printer/Scanner/Copier/Fax even though Brother itself provides drivers for this machine (and others) as .deb-Packages and licensed under the GPL on their wedsite.

http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/lpr_debian/mfc5440cnlpr-1.0.2-1.i386.deb

http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/cups_wrapper/cupswrappermfc5440cn_1.0.0-1_i386.deb

They work fine under Edgy using this tutorial (only German, sorry)

http://micha.monsteradmin.de/archives/104-Brother-MFC-5440CN-unter-Ubuntu.html

Also the MFC-5440CN is not detected as a Scanner out-of-the-box.
Same story here. Drivers are GPL and available through the Brother site:

http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/sane_debian/brscan2-0.2.1-0.i386.deb

It works fine under Edgy using this tutorial:
http://micha.monsteradmin.de/archives/107-Brother-MFC-5440CN-und-Scannen-ueber-das-Netz-mit-Ubuntu.html

Please include these drivers into feisty (and maybe even more of Brother drivers for other machines since there are there waiting to get included (GPL).

If any further information is needed let me know.
Thank you for making Ubuntu rock!

Revision history for this message
anonym (launch-mailinator) wrote :

The drivers itself aren't open source, only the "cupswrapper" part.
But they could go to mulitverse or something like that.

Thanks!

Revision history for this message
Dave Walker (davewalker) wrote :

The SANE driver is available through GPL

"If you require, we will send you the source file based on the GPL license."[1]

[1]http://solutions.brother.com/linux/sol/printer/linux/sane_install-net.html

Revision history for this message
Michael Stempin (mstempin) wrote :

Still no change for this in Gutsy as of Tribe 2.

Is there really no chance of having those drivers integrated into Ubuntu somehow?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers