[edgy] Error printing HTTP / IPP device-uri

Bug #63707 reported by Cayetano on 2006-10-03
12
Affects Status Importance Assigned to Milestone
cupsys (Ubuntu)
High
Martin Pitt

Bug Description

Cannot print to network printers via HTTP or IPP uri, printers HP and Oki.

socket:// works properly

Attaching printingbuginfo.txt

Cayetano (hnzekto) wrote :
Cayetano (hnzekto) wrote :

/var/log/cups/error_log

I [03/Oct/2006:10:19:45 +0200] Job 104 queued on "HP2200ECO" by "root".
I [03/Oct/2006:10:19:45 +0200] Started filter /usr/lib/cups/filter/pstops (PID 17445) for job 104.
I [03/Oct/2006:10:19:45 +0200] Started backend /usr/lib/cups/backend/http (PID 17446) for job 104.
E [03/Oct/2006:10:19:45 +0200] PID 17446 (/usr/lib/cups/backend/http) stopped with status 22!
I [03/Oct/2006:10:19:45 +0200] Hint: Try setting the LogLevel to "debug" to find out more.
I [03/Oct/2006:10:19:46 +0200] [Job 104] Backend returned status 22 (unknown)
I [03/Oct/2006:10:19:46 +0200] Saving printers.conf...
I [03/Oct/2006:10:19:48 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=17451)

Cayetano (hnzekto) wrote :

LogLevel debug

..snip..

D [03/Oct/2006:10:22:53 +0200] [Job 105] /usr/lib/cups/backend/http: Permission denied

/usr/lib/cups/backend/
-rwx------ 3 root root 26040 2006-10-02 18:44 http
-rwx------ 3 root root 26040 2006-10-02 18:44 ipp

chmod +rx to that files and it works

¿package bug? ¿perms bug?

Changed in cupsys:
importance: Undecided → Medium
Till Kamppeter (till-kamppeter) wrote :

I can reproduce this bug after I have updated to the new cupsys-1.2.4-2ubuntu1 package. With the old 1.2.3 package printing to a remote CUPS printer worked correctly.

Changed in cupsys:
status: Unconfirmed → Confirmed
Till Kamppeter (till-kamppeter) wrote :

The problem was introduced by the following Debian change:

---------------------------------------------------------------------------------------------
cupsys (1.2.4-2) unstable; urgency=low

  [ Kenshi Muto ]
  * PPD transition to /usr/share/ppd is mostly finished.
    Now I remove old symlink /usr/share/ppd/cups-transitional-dir and
    /usr/share/cups/cups-included. (closes: #381266, #383291)
  * Update debconf translations:
    - Brazilian Portuguese (closes: #389222)
  * Tried to solve the backend permission problem. CUPS scheduler
    uses a permission and owner information of backend program.
    - Install ipp and lpd as mode 0700.
    - Create backend links as hardlink instead of symlink.
--------------------------------------------------------------------------------------------

I do not know really why this was done in the Debian package, the IPP backend works also as normal user. For the LPD backend this is correct for a distro which runs CUPS as root (Debian), as the LPD backend has to run as root (Ubuntu uses SUID root for it).

Setting a backend to 0700 mode and to owner root is the (documented) method of CUPS 1.2, that a backend is run as root. By default, CUPS 1.2 runs backends as the user "lp". This naturally works only if CUPS itself runs as root (and in Ubuntu CUPS does not run as root).

Martin Pitt (pitti) wrote :

Confirmed regression from last merge, will fix ASAP.

Changed in cupsys:
assignee: nobody → pitti
importance: Medium → High
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

 cupsys (1.2.4-2ubuntu2) edgy; urgency=low
 .
   * debian/rules: Do not install http/ipp backend with 0700 permissions
     (regression from 1.2.4-2). Closes: LP#63707
   * Add debian/patches/00_dsc-comment-encoding.dpatch:
     - Fix printing of jobs with invalid/misinterpreted characters in the name.
     - Patch taken from upstream SVN, thanks to Till Kamppeter for porting it
       to 1.2.4. (STR#1988)
     - Closes: LP#57445

Changed in cupsys:
status: In Progress → Fix Released

My network printer is working now with this update. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers