Ubuntu

upgrade from 1.2.0 to 1.2.2 makes Canon iP4200 unusable

Reported by Florian Labrouche on 2006-08-17
2
Affects Status Importance Assigned to Milestone
cupsys (Ubuntu)
Medium
Brian Murray

Bug Description

Binary package hint: cupsys-client

OS : Ubuntu 6.06 LTS Dapper Drake
Computer : laptop Asus A7V-R024H

I recently tried to install my Canon ip4200 inkjet printer, using the official Canon drivers. As I update regularly my system, cupsys-client was update as well as ubuntu-dektop, hence I had the newest version of cupsys-client (1.2.2)
Following the installation described on a French ubuntu wiki ( http://doc.ubuntu-fr.org/materiel/imprimante_canon_ip_4200 ), it ends up with the printer not working i.e it pauses automatically, no document whatsoever would be printed.
After some research, it results that cupsys-client must be set to the original dapper version (1.2.0) to allow the printer to function correctly. I used Synaptic to do so (force version then block version).
The main problem is that now metapacket ubuntu-dektop is removed.

Edit: this bug has been frequently reported on the French community forum : http://forum.ubuntu-fr.org/viewtopic.php?id=31613

description: updated

Thanks for you bug report.
Is this a network printer or directly connected to your PC?
Can you attach the output of the printingbuginfo script, it can be found here: https://wiki.ubuntu.com/PrintingBugInfoScript.
It would be nice if you could attach the CUPS error_log of CUPS 1.2.2. Therefore edit /etc/cups/cupsd.conf and change LogLevel to debug. Then restart cups: "sudo /etc/init.d/cupsys restart" and try to print something (e.g. test page). After this attach the file /var/log/cups/error_log to this bug report.

Changed in cupsys:
status: Unconfirmed → Needs Info

This printer is directly connected (USB) to my PC.
I attached both outputs you need. But strangely after i reinstalled cupsys-client 1.2.2 and restarted cupsys like you mentioned above, the printer does work properly. I could print a test page and an Openoffice document.

Since you are able to print I see nothing special in the error_log.
Did you do dist-upgrade from breezy or fresh install of dapper?
It would have been nice to have an error_log, /etc/cups/cupsd.conf and /etc/cups/cups.d/* before you did downgrade to 1.2.0. You should point other users with the same problem to this bug report to find out more.

I did a fresh install of dapper, using the Alternate CD. But I installed the printer for the first time after I upgraded cupsys-client. I tried to remove completely cupsys-client along with configuration files and then reinstalled it, but the issue has totally disappeared from my PC.
Also I posted a message on the forum, hopefully someone else will be able to help.

Robert Casanova (secoder) wrote :

I use a router with a printer server and it happens the same. When I use the same configuration but throught USB it works fine.

So something happens whit the ipp protocol...

Somewhere mentioned the "partial" solution of giving a password to the root user, and add the 'cupsys' user to the 'shadow' group and it doesn't work neither.

Here is my printing file generated.

@Robert Casanova:
You have a network printer and your printer works if connected directly through USB. This is NOT the same issue as described by the initial bug reporter.
You probably suffer from bug #55828, please take a look there and try the suggestions, if it solves your problem please add a comment there. If you are not sure if a bug is the same problem you have it is better to open a complete new one instead of adding unrelated comments to existing bug reports.
Please don't add further comments here since it only confuses people and makes bug triaging difficult.
Thanks for you understanding.

Robert Casanova (secoder) wrote :

@Pascal De Vuyst:
You're right I misunderstood the bug report in here. I'll check up your suggestion.
My fault.

Ante Karamatić (ivoks) wrote :

Is it OK to close this bug? Looks like no one can reproduce it (including author of bug report).

Quick look at error_log; looks like CUPS wasn't started since CUPS loads print jobs from cache.

Please wait for another error_log before closing this bug. I can ensure you there are other users who have reported it. One of them told me he can't manage to reproduce this bug before august 31st since he doesn't have the printer with him currently.

Eventually I got an error_log of CUPS corresponding to the described bug. I attached it to this comment.

Ante Karamatić (ivoks) wrote :

Could you install test packages, adding:

deb http://www.grad.hr/~ivoks/ubuntu/cups ./

to sources.list and doing update/upgrade?

Thanks

Changed in cupsys:
importance: Untriaged → Medium
Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in cupsys:
assignee: nobody → brian-murray
status: Needs Info → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers