Wishlist: Support Epson-Kowa printers in Cups

Bug #47085 reported by Dominik Kubla on 2006-05-28
16
Affects Status Importance Assigned to Milestone
cupsys (Ubuntu)
Wishlist
Unassigned

Bug Description

This is strictly a wishlist item. Since it involves non-free software a rejection of this bug is accepted without complaint. ;-)

Many Epson printers (especially the multifunction variety like the Stylus CX3600) are not well supported by the open source drivers.

Avasys (which seems to be the sucessor of Epson-Kowa) offers proprietary CUPS drivers at:

http://www.avasys.jp/english/index_e.html

But only for RPM-based distros (even so Debian is listed). It would be nice to have "official" packages available since these printers are cheap and popular.

Till Kamppeter (till-kamppeter) wrote :

You should report this to the Epson/Avasys people.

This problem is also addressed on the FSG OpenPrinting Summit which I am organizing:

http://www.freestandards.org/en/OpenPrinting/SummitLexington#How_to_write_a_cross_distro_printer_driver

We will provide a standard DDK to printer manufacturers and driver developers which allow them to make distro-independent driver packages and upload them to the new FSG OpenPrinting database (successor of linuxprinting.org). Then every distro will simply automatically get drivers from there. Should work from Ubuntu 7.10 on, perhaps already from 7.06.

Ralph Janke (txwikinger) wrote :

Is this report still an issue, or can it be closed?

Thanks

Changed in cupsys:
assignee: nobody → txwikinger
status: New → Incomplete

Am Dienstag 19 Februar 2008 schrieb Ralph Janke:
> Is this report still an issue, or can it be closed?
>
> Thanks
>
> ** Changed in: cupsys (Ubuntu)
> Assignee: (unassigned) => Ralph Janke (txwikinger)
> Status: New => Incomplete

I think most printers are supported now. But the vendor tools support querying
the ink level. This functionality is still missing.

Regards,
  Dominik

Ralph Janke (txwikinger) wrote :
Changed in cupsys:
assignee: txwikinger → nobody
status: Incomplete → Confirmed
Phillip Susi (psusi) wrote :

Hardy has reached end of life, and this package is not present in later releases. Closing all related bugs.

Changed in cupsys (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers