printer always goes to pause and cannot be resumed

Bug #41313 reported by PascalC on 2006-04-25
16
Affects Status Importance Assigned to Milestone
cupsys (Ubuntu)
Medium
Martin Pitt

Bug Description

With dapper versions :
ii cupsys 1.1.99.rc2-0ubuntu2 Common UNIX Printing System(tm) - server
ii cupsys-bsd 1.1.99.rc2-0ubuntu2 Common UNIX Printing System(tm) - BSD commands
ii cupsys-client 1.1.99.rc2-0ubuntu2 Common UNIX Printing System(tm) - client programs (SysV)

Begining with a fresh cupsys installation, I have no printer defined. I define an HP IPP printer with no problem. The printer is ready in kdeprint. I print one file, no problem printing. I print a second file that does not want to print. Printer is stopped in kdeprint. If I try to resume the printer, kdeprint shows it processing for a second then coming back to stopped state.

In cupsys error_log (once bug #41267 is managed) I can see the following when trying to resume the printer:

E [25/Apr/2006:16:58:11 +0200] cupsdAuthorize: Local authentication certificate not found!
E [25/Apr/2006:16:58:11 +0200] Resume-Printer: Unauthorized
E [25/Apr/2006:16:58:12 +0200] [Job 104] Print file was not accepted (client-error-bad-request)!
E [25/Apr/2006:16:58:12 +0200] PID 11062 (/usr/lib/cups/backend/ipp) stopped with status 1!
E [25/Apr/2006:17:02:57 +0200] cupsdAuthorize: Local authentication certificate not found!

PascalC (p92) wrote :

well as of today midday with :
ii cupsys 1.1.99.rc3-0ubuntu1
ii kdeprint 3.5.2-0ubuntu14

On a fresh KDE user, this seems to work OK now, BUT
I had to create my IPP printer again and remove the old one.

PascalC (p92) wrote :

humm forget it - same error as yesterday after printing a bunch of files - printer goes to pause and cannot be restarted.

error_log shows :

E [26/Apr/2006:18:17:41 +0200] [Job 110] Print file was not accepted (client-error-bad-request)!
E [26/Apr/2006:18:17:41 +0200] PID 9044 (/usr/lib/cups/backend/ipp) stopped with status 1!

ibc (ibc2) wrote : I confirm this bug

It's a terrible bug that makes the system unusable for common users who are annoyed when the simply can't print with no reason.

I can confirm this bug in Kubuntu Breezy and Kubuntu Dapper. In the first case using a USB HP printer and in the second case using a printer in a remote Debian CUPS server.

Many times after Kubuntu is started the printer is paused, and sometimes I can "active" them but many times it just become "paused" again in a few seconds.

Please, tell me about which data you need to investigate about this problem.

Ante Karamatić (ivoks) wrote :

This isn't common problem. Attach your /etc/cups/cupsd.conf, /etc/cups/cups.d/ports.conf, /etc/cups/cups.d/browse.conf and /etc/cups/printers.conf. Also, please provide output of lpinfo -v.

Thank you

I just found this information at http://www.linuxprinting.org/beh.html:
Very annoying with CUPS is that when an error on the communication between the CUPS backend and the printer occurs, CUPS disables the print queue and to be able to continue printing an administrator (root access required) has to re-enable the queue. It is not enough to simply fix the printer's communication problem (like turning it on, fixing the network connection, ...).
This is especially a very bad design for desktop/home users. They often only turn on their printers when they really want to print (to save energy). Then it happens easily that they send a job and forget to turn on the printer. CUPS disables the queue and the annoying re-enabling procedure has to be done.

So it could be your printer was just switched OFF when you sent print jobs. Or perhaps your network connection is not permanent.

Confirmed by ibc

Changed in kdeprint:
status: Unconfirmed → Confirmed
Martin Pitt (pitti) wrote :

I discussed this with Till. We should change the default error policy in cups, since this is indeed horribly annoying.

Changed in cupsys:
assignee: nobody → pitti
status: Confirmed → In Progress
Till Kamppeter (till-kamppeter) wrote :

Fortunately, CUPS was cleanly programmed and so the patch (attached) is tiny. I had to switch the default only on one place (in cupsd) and in both the web interface and the command line interface ("lpadmin") the patched cups defaults to the "Retry Job" error policy.

I have tested the patch on my Mandriva test box, but it should work the same way with any other distro, as it applies to the CUPS code only.

A better solution would be adding a directive "DefaultErrorPolicy" to cupsd.conf, so distros can set this to "Retry job" in their desktop versions and "Stop printer" in their enterprise server versions.

Martin Pitt (pitti) on 2006-10-02
Changed in cupsys:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

 cupsys (1.2.4-2ubuntu1) edgy; urgency=low
 .
   * Merge recent Debian changes to get some bug fixes and new upstream version
     1.2.4 (UVF exception approved by Matt Zimmerman):
     - The --with-printcap configure option did not work (STR #1984)
     - The character set reported by cupsLangGet() did not always reflect the
       default character set of a given locale (STR #1983)
     - Older Lexmark and Tektronix printers did not work with IPP (STR #1980)
     - Failsafe printing did not work (PR #6328)
     - Some web interface redirects did not work (STR #1978)
     - The web interface change settings button could introduce a "Port 0" line
       in cupsd.conf if there was no loopback connection available (STR #1979)
     - The web interface change settings and edit configuration file buttons
       would truncate the cupsd.conf file (STR #1976)
     - The German web interface used the wrong printer icon images (STR #1973)
     - (The other changes of 1.2.4 were already present as patch in the
       previous version.)
     - Remove transitional PPD symlink which is not necessary any more and just
       causes loops. Closes: LP#62198
     - Fix CPU hogging of gnome-cups-manager. Closes: LP#44196
   * Add debian/patches/ubuntu-default-error-policy-retry-job.dpatch:
     - Do not stop the printer if a job failed, just reattempt it. The default
       policy might be suitable for large offices with an admin, but it
       puts home users at loss. Thanks to Till Kamppeter for the patch!
       Closes: LP#41313

Changed in cupsys:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers