HP 2500 Laserjet "may not be connected"

Bug #235957 reported by gabeb on 2008-05-30
10
Affects Status Importance Assigned to Milestone
cupsys (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 8.04
Release: 8.04

administrator@administrator-desktop:~$ apt-cache policy packagename
W: Unable to locate package packagename
administrator@administrator-desktop:~$

system-config-printer 0.7.81

I atched a USB printer (HP 2500 color LaserJet) and tried to print with it.

When I try to print the document just gos to the printer cue and sits there indefinitely.
A yelow baloon apears and tells me the "printer 'HP_2500_laserjet' may not be connected"

gabeb (rafttrip) wrote :

This looks like a kernel usb bug.
Please attach your PrintingBugDocs again in plain text and in seperate uncompressed attachments, so developers can directly see the contents of those files.
Please also attach the minimal information as described here: https://wiki.ubuntu.com/KernelTeamBugPolicies.

If this printer has a parallel printer port please try to print this way.

Jacob Kochems (jacobkochems) wrote :

I have the same problem with a HP Deskjet 970Cxi

Jacob Kochems (jacobkochems) wrote :

Sorry, I tried to attach the files uncompressed but instead I accidentally released my unfinished comment. I'd like to send the minimal information uncompressed but it seems that I can only attach on file. Therefore I try it again with an archive.
To the Bug:
Like I said before: I have the same problem with a 'HP Deskjet 970Cxi'. It worked fine -if I remember correct- under Kernel version 2.6.24-16. The bug also occurred under version 2.6.24-18. Now I'm using version 2.6.24-19.

iainv (iainvarley) wrote :

I had this same problem with Gutsy, and have now fixed it on Hardy and Gutsy.

The Device URI that is selected when the printer is autodetected is hp://usb/hp_color_LaserJet%202500?serial= and then a long number.

Replacing this URI with:

hal:///org/freedesktop/Hal/devices/usb_device_3f0_717_999999996434_if0_printer_noserial

makes the printer function perfectly.
I found the above URI by randomly installing and uninstalling anything I could to get it to work originally, and this was one setting that came up.

With a plain install of Hardy on my laptop, letting the computer detect the printer and then just changing the URI to the one I discovered on my desktop, it worked first time.

If there's any other info that might be helpful to someone to understand why this worked, please let me know.

Iain

Mark Taylor (mrt-111) wrote :

I fixed this on my system by

1. downloaded hplip-2.8.10.run
2. sudo mkdir /usr/share/hplip-2.8.10
3. sudo mv ~/hplip-2.8.10.run /usr/share/hplip-2.8.10
4. cd /usr/share/hplip-2.8.10
5. sh hplip-2.8.10.run
6. use default answers for all questions
7, ln -s /usr/share/hplip-2.8.10 /usr/share/hplip

The key to solving this one was in the syslog

hp_color_LaserJet_2500?serial=999999942349: io/hpmud/model.c 528: no hp_color_LaserJet_2500 attributes found in /usr/share/hplip/data/models/models.dat

Phillip Susi (psusi) wrote :

Hardy has reached end of life, and this package is not present in later releases. Closing all related bugs.

Changed in cupsys (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers