Cups Server error. There was an error during Cups operation: 'server-error-service-unavailable'.

Bug #182551 reported by Rizlaw on 2008-01-13
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cupsys (Ubuntu)
Medium
Unassigned

Bug Description

After a "CUPS" packages update a few days ago, I started getting this error message every morning at about the time update manager performed its daily check for new Ubuntu 7.10 updates:

CUPS SERVER ERROR
There was an error during cups operation: 'server-error-service-unavailable'.

Jeremy Impson (jdimpson) wrote :

Me too! Same symptoms. Additionally, I get the following audit report in /var/log/syslog every day, which I believe is related:

Jan 25 07:37:04 artoo kernel: [3141949.390618] audit(1201264624.231:82): type=1503 operation="inode_permission" requested_mask="rw" denied_mask="rw" name="/dev/tty" pid=7571 profile="/usr/sbin/cupsd"
Jan 25 07:37:04 artoo kernel: [3141949.417150] audit(1201264624.231:83): type=1503 operation="inode_permission" requested_mask="rw" denied_mask="rw" name="/dev/tty" pid=7574 profile="/usr/sbin/cupsd"

I have two desktop users (on on console, one on a VNC server virtual desktop) and both get the daily "CUPS SERVER ERROR There was an error during cups operation: 'server-error-service-unavailable'" popup error message, and that is presumably why I get the syslog message twice daily.

I have not tried messing with permissions of /dev/tty, although that seems to be the culprit. Or is this SELinux profile related?

I'm willing to help debug.

Fabian (fsturm) wrote :

Me too, so it seems to be a common error.
Printing still works even with the error message.
Whatever we should try please tell us.

package hint: cupssys

Changed in cupsys:
importance: Undecided → Medium
status: New → Confirmed
houstonbofh (leesharp) wrote :

<AOL>Me too!</AOL>
It only seems to show up in my primary user. No other effect noted.

Jeremy Impson (jdimpson) wrote :

At some point in the past three months this problem went away for me. I'm at cupsys version 1.3.2-1ubuntu7.5

houstonbofh (leesharp) wrote :

More information... It only happens when I log in immediately. If I boot and go away, and log in some time after the boot process completes, it never happens. This is repeatable. Sounds like a init order issue.

pinzia (pinzia) wrote :

7.10 is EOF..verfied the bug in new version or close

Phillip Susi (psusi) wrote :

Hardy has reached end of life, and this package is not present in later releases. Closing all related bugs.

Changed in cupsys (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers