cups-lpd results in freezing of Gusty

Bug #159260 reported by ingo on 2007-11-01
2
Affects Status Importance Assigned to Milestone
cupsys (Debian)
New
Undecided
Unassigned
cupsys (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cupsys

Upgrading from Feisty to Gusty disabled cups-lpd from beeing started by openbsd-inetd.
This line in /etc/inetd.conf was commented out:
#<off># printer stream tcp nowait lp /usr/lib/cups/daemon/cups-lpd cups-lpd \
        -o document-format=application/octet-stream

As I definitely need the lpd-extension of CUPS to print via the network, I did enable it again.
inetd starts properly, but printing on the local printer via port 515 does not work.
To check whether cups-lpd is running I issued the command:

ps ax | grep lp

This results in a huge amount of strange characters output and the terminal crashes.
After a while of network traffic the whole system freezes and only 'hard reset' does help.
I did try to disable AppArmor, problem persists.

According to 'Help information' in Ubuntu as well as CUPS documentation all seems to be set up correctly.
In Feisty all worked perfectly. I am using openbsd-inetd version 0.20050402-6.
CUPS-documentation for version 1.3 (http://localhost:631/help/whatsnew.html) even states:

" 5. LPD Support; The LPD backend now supports a faster streaming mode that does not require a temporary file"

ingo (ingo-steiner) wrote :

Here the corresponding information from 'var/log/messages when trying to print out of a Paralles-VM to cups-lpd on Gusty (the host):

root@pp:/home/ingo# tail /var/log/messages
   Nov 3 12:50:18 pp kernel: [ 5657.392000] [ 7427] svm_support_on(): SVM mode activated
   Nov 3 12:50:18 pp kernel: [ 5657.396000] device eth0 entered promiscuous mode
   Nov 3 12:50:18 pp kernel: [ 5657.396000] audit(1194090618.284:8): dev=eth0 prom=256 old_prom=0 auid=4294967295
   Nov 3 12:50:32 pp kernel: [ 5671.704000] rtc: lost 1 interrupts
   Nov 3 12:51:55 pp cups-lpd[7448]: Connection from valf.home (IPv4 192.168.0.21)
   Nov 3 12:51:55 pp cups-lpd[7448]: Receive print job for Queue
   Nov 3 12:52:46 pp cups-lpd[7448]: Closing connection
   Nov 3 12:53:01 pp kernel: [ 5820.900000] device eth0 left promiscuous mode
   Nov 3 12:53:01 pp kernel: [ 5820.900000] audit(1194090781.793:9): dev=eth0 prom=0 old_prom=256 auid=4294967295
   Nov 3 12:53:01 pp kernel: [ 5820.900000] [ 7427] svm_support_off(): SVM mode deactivated.

Unfortunately after such crashes even the root-filesystem gets corrupted and I have to do 'mkfs.ext3 and play back Ubuntu from a backup. For me Parallels Workstation (Parallels-2.2.2164-lin-en.deb) is one of the most important applications, which worked reliable under Feisty and other OS's.

ingo (ingo-steiner) wrote :

An easy way to reproduce that bug is:

just start 'cups-lpd' (with aid of 'openbsd-inetd' and entry in 'inetd.cof' and print something to cups-lpd:
immediately 'cupsd' is killed!

As this bug affects a vital feature for me, I had to revert to Feisty!

ingo (ingo-steiner) wrote :

To gather further information on this matter, I did try to perform the same task under Debian-Lenny, which is quite similar to Gusty (kernel 2.6.22-2, cups 1.3.2-1).
The only difference: Lenny does nor freeze, but collects thousands of missed RTC-IRQ's in the syslog. Printing via cups-lpd does not work either. The link between cups-lpd and cupsd seems broken. Here the relevant part of /var/log/messages:

pp:/home/ingo# tail /var/log/messages
Nov 12 12:17:25 pp cups-lpd[4155]: Connection from 192.168.0.21 (IPv4
192.168.0.21)
Nov 12 12:17:25 pp cups-lpd[4155]: Receive print job for Queue
Nov 12 12:17:25 pp kernel: rtc: lost some interrupts at 1024Hz.
Nov 12 12:17:56 pp last message repeated 1517 times
Nov 12 12:18:20 pp last message repeated 1211 times
Nov 12 12:18:20 pp syslogd 1.5.0#1: restart.
Nov 12 12:18:20 pp kernel: rtc: lost some interrupts at 1024Hz.
Nov 12 12:18:22 pp last message repeated 97 times
Nov 12 12:18:22 pp cups-lpd[4155]: Closing connection
Nov 12 12:18:22 pp kernel: rtc: lost some interrupts at 1024Hz.

So I maked the bug as 'affects Distribution.

ingo (ingo-steiner) wrote :

Meanwhile I upgraded to Hardy and no longer use 'cups-lpd'.
So I cannot comment any more on this.

Ingo

Thank you for taking the time to report this bug and helping to make Ubuntu better. The version of Ubuntu your using is in End of Life status. More information may be found at: https://wiki.ubuntu.com/Releases As well, the issue that you reported should be reproducible with the live environment of the Desktop CD development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find more about the development release at http://www.ubuntu.com/testing/. Please repost a detailed error report and update the bug status. Thanks again and we appreciate your help.

Changed in cupsys (Ubuntu):
status: New → Incomplete
Phillip Susi (psusi) wrote :

Hardy has reached end of life, and this package is not present in later releases. Closing all related bugs.

Changed in cupsys (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers