Ubuntu

cupsd crashed with SIGSEGV

Reported by tyler on 2007-10-04
24
Affects Status Importance Assigned to Milestone
cupsys (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: cupsys

When logging in, cupsd crashes.

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Thu Oct 4 12:37:01 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/sbin/cupsd
NonfreeKernelModules: nvidia
Package: cupsys 1.3.2-1ubuntu1
PackageArchitecture: amd64
ProcCmdline: /usr/sbin/cupsd
ProcCwd: /
ProcEnviron: PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
Signal: 11
SourcePackage: cupsys
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: cupsd crashed with SIGSEGV
Uname: Linux hellfire 2.6.22-12-generic #1 SMP Sun Sep 23 20:03:18 GMT 2007 x86_64 GNU/Linux
UserGroups:
SegvAnalysis:
 Segfault happened at: 0x441110: mov 0x18(%rbx),%rdi
 PC (0x00441110) ok
 source "0x18(%rbx)" (0x61622f7370756347) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA

tyler (durdon-tyler) wrote :

StacktraceTop:delete_rules (rules=0x6ada70) at mime.c:473
mimeDeleteType (mime=<value optimized out>, mt=0x660d00) at mime.c:160
cupsdDeletePrinter (p=0x673b00, update=<value optimized out>) at printers.c:728
cupsdDeleteAllPrinters () at printers.c:585
cupsdReadConfiguration () at conf.c:1060

Changed in cupsys:
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Thanks for your report, May you tell us a few steps in order to reproduce the crash? thanks in advance.

Changed in cupsys:
status: New → Incomplete
miked (miked11) wrote :

Ubuntu Hardy Heron 8.04 Alpha 5
root@tower-desktop:~#

Till Kamppeter (till-kamppeter) wrote :

Can you do a full update of Hardy so that you get CUPS 1.3.6 and check again whether the CUPS daemon still crashes?

miked (miked11) wrote :

Added Info

Changed in cupsys:
status: Incomplete → New
Kees Cook (kees) on 2009-09-16
description: updated
Thomas Hotz (thotz) wrote :

Can you still reproduce this error on supported Ubuntu versions? Thank you for telling us!

Thomas Hotz (thotz) on 2012-11-10
Changed in cupsys (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for cupsys (Ubuntu) because there has been no activity for 60 days.]

Changed in cupsys (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers