Cups can't remove its own tempfiles

Bug #133015 reported by Martijn vdS on 2007-08-16
2
Affects Status Importance Assigned to Milestone
cupsys (Ubuntu)
High
Martin Pitt

Bug Description

Binary package hint: cupsys

I tried to restart cups (I can't get it to print anymore on gutsy, I'll post a bug about that shortly), and after restarting, I got this error message:

E [16/Aug/2007:20:45:10 +0200] Unable to remove temporary file "/var/spool/cups/tmp/gs_ceNGtf" - Permission denied

That directory has the following permissions:
drwxrwx--T 2 root lp 4096 2007-08-16 20:39 tmp

And the file:
-rw------- 1 lp lp 0 2007-08-16 20:39 gs_ceNGtf

Printing still doesn't continue.

Martin Pitt (pitti) on 2007-08-20
Changed in cupsys:
assignee: nobody → pitti
importance: Undecided → High
status: New → Triaged
Martin Pitt (pitti) wrote :

cupsys (1.3.0-3ubuntu1) gutsy; urgency=low

  * Merge bugfixes from Debian.
  * debian/local/apparmor-profile: Allow dac_override for now; this is
    slightly nasty, but cups chowns a lot of files (e. g. in
    /var/spool/cups/tmp) to 'lp' and thus cannot read/write them any more
    afterwards. Since we confine file access pretty tightly, this should not
    be much of a problem. (LP: #133015)
  * debian/local/apparmor-profile: cupsd should manage /etc/printcap.
    (LP: #132969)

cupsys (1.3.0-3) unstable; urgency=low

  [ Martin Pitt ]
  * debian/control: Allow 'ghostscript' as alternative dependency to gs-esp.
  * debian/cupsys.dirs: Create /usr/lib/cups/backend/ (regression from the big
    debian/rules cleanup). (closes: #438432)
  * debian/cupsys.preinst: Bump the version comparison for the file owner
    cleanup, since some log files were still left as owned by 'cupsys' until
    #437536 was fixed.
  * debian/cupsys-common.files: Do not install the .po files, cups does not
    use them at runtime. (closes: #438625)

  [ Till Kamppeter ]
  * debian/local/postscript.ppd: New generic PostScript PPD file for
    unknown PostScript printers added.

 -- Martin Pitt <email address hidden> Tue, 21 Aug 2007 07:48:34 +0200

Changed in cupsys:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers