cupsys-client: cupsaddsmb doesn't install cups for windows drivers

Bug #12293 reported by Debian Bug Importer on 2005-01-26
4
Affects Status Importance Assigned to Milestone
cupsys (Debian)
Fix Released
Unknown
cupsys (Ubuntu)
Medium
Unassigned

Bug Description

Automatically imported from Debian bug report #292380 http://bugs.debian.org/292380

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Wed, 26 Jan 2005 19:36:25 +0100
From: "PROD'HOMME Nicolas DDSC SDAM BSI" <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: cupsys-client: cupsaddsmb doesn't install cups for windows drivers

Package: cupsys-client
Version: 1.1.23-2
Severity: grave
Justification: renders package unusable

cupsaddsmb fails to do its job, without error message.

When looking to drivers directory, i see that :
-W32X86 directory is not created and the cups drivers files are copied nowhere.

After looking into source file cupsaddsmb.c, i can see that :

cupsaddsmb needs :
-Windows 2000 driver files
-CUPS driver V6 files ( they don't exist yet )
-Adobe Win9x driver files

It doesn't work if you have old version of CUPS driver for WINDOWS, like V5

However it is possible to manually install CUPS driver for WINDOWS V5 only as
discribed in SAMBA HOWTO COLLECTION chapter 19.2

IMHO, cupsaddsmb should test the version of CUPS driver for WINDOWS files found
and allow to install only the ones available.

Otherwise it should print an error message showing the missing files.

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.8-2-686
Locale: LANG=fr_FR@euro, LC_CTYPE=fr_FR@euro (charmap=ISO-8859-15)

Versions of packages cupsys-client depends on:
ii libc6 2.3.2.ds1-20 GNU C Library: Shared libraries an
ii libcupsys2-gnutls10 1.1.23-2 Common UNIX Printing System(tm) -
ii zlib1g 1:1.2.2-3 compression library - runtime

-- no debconf information

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Thu, 27 Jan 2005 08:47:22 +0900
From: Kenshi Muto <email address hidden>
To: "PROD'HOMME Nicolas DDSC SDAM BSI" <email address hidden>
Cc: <email address hidden>, <email address hidden>
Subject: Re: Bug#292380: cupsys-client: cupsaddsmb doesn't install cups for windows drivers

severity 292380 important
thanks

At Wed, 26 Jan 2005 19:36:25 +0100,
PROD'HOMME Nicolas DDSC SDAM BSI wrote:
> Package: cupsys-client
> Version: 1.1.23-2
> Severity: grave
> Justification: renders package unusable
>
> cupsaddsmb fails to do its job, without error message.

OK, I'll check it.
But because cupsaddsmb is one of extra tool for cupsys-client, I
downgrade this severity.

Thanks,
--
Kenshi Muto
<email address hidden>

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Thu, 27 Jan 2005 21:34:16 +0900
From: Kenshi Muto <email address hidden>
To: "PROD'HOMME Nicolas DDSC SDAM BSI" <email address hidden>
Cc: <email address hidden>
Subject: Re: Bug#292380: cupsys-client: cupsaddsmb doesn't install cups for windows drivers

At Wed, 26 Jan 2005 19:36:25 +0100,
PROD'HOMME Nicolas DDSC SDAM BSI wrote:
> It doesn't work if you have old version of CUPS driver for WINDOWS, like V5
>
> However it is possible to manually install CUPS driver for WINDOWS V5 only as
> discribed in SAMBA HOWTO COLLECTION chapter 19.2
>
> IMHO, cupsaddsmb should test the version of CUPS driver for WINDOWS files found
> and allow to install only the ones available.

Unfortunatelly ESP stopped distribute CUPS driver for Windows.
Because I've no version of it, I couldn't try it.

Thanks,
--
Kenshi Muto
<email address hidden>

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Thu, 27 Jan 2005 19:10:31 +0100
From: "PROD'HOMME Nicolas DDSC SDAM BSI" <email address hidden>
To: Kenshi Muto <email address hidden>
Cc: <email address hidden>
Subject: Re. : Re: Bug#292380: cupsys-client: cupsaddsmb doesn't install cups for
 windows drivers

At Wed, 26 Jan 2005 19:36:25 +0100,
PROD'HOMME Nicolas DDSC SDAM BSI wrote:
> It doesn't work if you have old version of CUPS driver for WINDOWS, like V5
>
> However it is possible to manually install CUPS driver for WINDOWS V5 only as
> discribed in SAMBA HOWTO COLLECTION chapter 19.2
>
> IMHO, cupsaddsmb should test the version of CUPS driver for WINDOWS files found
> and allow to install only the ones available.

Unfortunatelly ESP stopped distribute CUPS driver for Windows.
Because I've no version of it, I couldn't try it.

Thanks,
--
Kenshi Muto
<email address hidden>

I have all files needed.
May be can i help you ?

in cupsaddsmb.c file V1.18 and above, a peace of source code has been lost.

in fact, in the ( export_dest() function ) 120 LOC have been remove.

i am rewriting the cupsaddsmb.c with V1.17 + V1.20 code.

may be are you interested by my file?

Matt Zimmerman (mdz) wrote :

Only affects cupsaddsmb, downgrading

Matt Zimmerman (mdz) wrote :

No point in tracking this independently of Debian; we're not going to pursue it.

Changed in cupsys:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.