Print to cups server with invalid credentials - no indication why it won't print

Bug #989852 reported by David Burke on 2012-04-27
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned

Bug Description

I have a CUPS server that work computers print to. Users must be "allowed users" in the centralized CUPS server to use a printer. If I print with 12.04 to a printer I'm not allowed to use - the print job just hangs in my local print queue and I get no warning. This is highly confusing.

In 11.10 and before I used to get a password prompt. This prompt actually didn't work, but at least it indicated authentication related issue.

Ideally I think CUPS should prompt for user credentials if the CUPS server isn't allowing a print job. However any indication that the user isn't allowed to print would be great.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: cups 1.5.2-9ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
NonfreeKernelModules: wl
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
Date: Fri Apr 27 11:45:09 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: LENOVO 0611AF8
Papersize: letter
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic-pae root=UUID=ba52d7ac-351f-4031-a1fe-92508f4b2f04 ro quiet splash vt.handoff=7
SourcePackage: cups
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/11/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8FET30WW (1.14 )
dmi.board.asset.tag: Not Available
dmi.board.name: 0611AF8
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: DOE-LN0084754
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8FET30WW(1.14):bd07/11/2011:svnLENOVO:pn0611AF8:pvrThinkPadX120e:rvnLENOVO:rn0611AF8:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 0611AF8
dmi.product.version: ThinkPad X120e
dmi.sys.vendor: LENOVO

David Burke (bufke) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
DavidJB (davidjb) wrote :

I'm seeing this also on my Ubuntu 12.04 installation and can vouch for this being extremely confusing as the only indication I could find that something was wrong was stumbling upon a "Tree connect failed (NT_STATUS_ACCESS_DENIED)" error message in the Printer State field against the printer properties .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers